前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ2318 TOYS 判断点与直线位置关系 【计算几何】

POJ2318 TOYS 判断点与直线位置关系 【计算几何】

作者头像
ACM算法日常
发布2018-12-10 11:57:43
6880
发布2018-12-10 11:57:43
举报
文章被收录于专栏:ACM算法日常ACM算法日常

Calculate the number of toys that land in each bin of a partitioned toy box.

计算每一个玩具箱里面玩具的数量

Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 妈妈和爸爸有一个问题,他们的孩子约翰从来没有在玩完玩具后把玩具都放好,他们有了约翰一个矩形的箱子用来放他的玩具,但是约翰很叛逆,他服从了他父母,不过只是简单地把玩具扔进了箱子里。所有的玩具都搞混了,并且约翰不可能找到他最喜欢的玩具。

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

约翰的父母想出了如下的注意,他们在箱子里放了纸板进行分区,即使约翰不停地把玩具扔进箱子里,至少玩具被扔进不同的垃圾箱并保持分开,下图展现了样例玩具箱的俯视图。

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

对于这个问题,当约翰把玩具扔进箱子里时,你被要求确定有多少个玩具被扔进了分区。

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

输入文件包含一个或多个问题,第一行是第一个问题包含6个数,n,m,x1,y1,x2,y2,纸板分区的数目为n(0 < n <= 5000),玩具的数量是m(0<m<5000),箱子左上角的坐标为(x1,y1),右下角的坐标为(x2,y2)。以下N行,每行包含两个整数,Ui Li,表示第i个纸板分区的结束是在坐标(UI,y1)和(Li,y2)。你可以假设纸板分区彼此不相交,它们是从左到右按排序顺序指定的。接下来的m行每行包含两个整数,Xj Yj指定该位置被第j个玩具落在了箱子里,玩具位置的顺序是随机的。你可以假设没有玩具会准确地落在硬纸板的隔板上或盒子的外面(就是所有玩具肯定都会掉进箱子里面),输入由一个单0组成的行终止。

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

每个问题的输出将是玩具箱中每个独立的箱子的一行。对于每一个箱子,打印它的箱子的号码,后面是冒号和一个空格,后面跟着丢进箱子的玩具数量。箱编号从0(最左边箱子)N(最右边的箱子)。用一条空行分隔不同问题的输出。

Sample Input 5 6 0 10 60 0 3 1 4 3 6 8 10 10 15 30 1 5 2 1 2 8 5 5 40 10 7 9 4 10 0 10 100 0 20 20 40 40 60 60 80 80 5 10 15 10 25 10 35 10 45 10 55 10 65 10 75 10 85 10 95 10 0

Sample Output

0: 2 1: 1 2: 1 3: 1 4: 0 5: 1

0: 2 1: 2 2: 2 3: 2 4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box. 如图所示,落在盒子边界上的玩具在盒子里

分析:

给n条线段,构成n+1个区间,然后是m个点的坐标,问0-n个区间,每个区间有多少个点?

我们先来看一下只有1条线段的情况,一条线段把平面分成两个区间,如果点在线段的左侧,那么这个点在左区间(0号),否则在右区间(1号);

点(u,y1)和点(x,y)连线的斜率为k1= ,点(l,y2)和点(x,y)连线的斜率为k2=

  1. k1=k2,三点共线
  2. k1>k2,点在直线的右侧
  3. k1<k2,点在直线的左侧

源代码:

代码语言:javascript
复制
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
struct point{
    int x,y;
};//记录坐标
struct Node{
    point a,b;
}A[5010];//隔板上下的点
int pos[5010];
//判断点(x,y)与线段A[mid]的关系
bool judge(int xx,int yy,int mid){
    int ans=(A[mid].a.x-xx)*(A[mid].b.y-yy)-(A[mid].a.y-yy)*(A[mid].b.x-xx);
    if(ans<0)return false;//点在线段左边
    return true;//点在线段右边
}
//二分查找点(x,y)最近的线段
void search(int xx,int yy,int n){
    int left=0,right=n-1;
    while(left<=right){
        int mid=(left+right)>>1;
        if(judge(xx,yy,mid)){//点在mid所在那条线段的右侧
            left=mid+1;
        }
        else { //点在mid所在那条线段的左侧
            right=mid-1;
        }
    }
    pos[left]++;//记录不同箱子所得到的玩具的数量
}
int main()
{
    int n,m,i,j,x1,x2,y1,y2;
    while(scanf("%d",&n),n){
        scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
        for(i=0;i<n;++i){
            int xd,xu;
            scanf("%d%d",&xu,&xd);
            A[i].a.x=xu;
            A[i].a.y=y1;
            A[i].b.x=xd;
            A[i].b.y=y2;
        }//存储隔板的位置
        memset(pos,0,sizeof(pos));
        for(i=0;i<m;++i){
            int xx,yy;
            scanf("%d%d",&xx,&yy);
            search(xx,yy,n);
        }//寻找这个玩具在那个区间

        for(i=0;i<=n;++i){
            printf("%d: %d\n",i,pos[i]);
        }
        printf("\n");
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自微信公众号。
原始发表:2018-11-08,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 ACM算法日常 微信公众号,前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档