烽火2640路由器命令行手册-02-接口配置命令

第1章   接口配置命令

本文描述用于不同类型接口的基本命令,这些命令对应于手册包括的接口配置任务,有关配置要点,参考下面列出的各项内容。

接口类型

参阅内容

一般接口

接口配置概述

以太网接口

配置以太网接口

串行接口

配置串行接口

逻辑接口

配置逻辑接口

拨号接口

配置拨号接口

E1接口

配置E1接口

DTU接口

配置DTU接口

1.1  接口配置命令

接口配置命令包括:

l   async mode

l   bandwidth

l   Cablelength

l   channel-group

l   clock

l   controller E1

l   delay

l   description

l   duplex

l   encapsulation

l   encapsulation dot1q

l   framing

l   interface

l   interface dialer

l   linecode

l   linemode

l   mtu

l   physical-layer mode

l   physical-layer speed

l   physical-layer speed

l   physical-interface fiber

l   show interface

l   shutdown (E1 controller)

l   shutdown (interface)

l   speed

l   tunnel

1.1.1   async mode

该命令用于设定异步端口的通讯方式。

[no] async mode [interactive | dedicated] [reverse-telnet]

参数

参数

参数说明

interactive

将该端口用作命令交互端口。这样所有通过背靠背电缆或Modem拨号连接到该端口的用户可对路由器进行配置(类似于Console口)。

dedicated

该端口只能用于一般的链路层封装模式(如PPP)。

reverse-telnet

将该端口用于反向telnet。此命令只能在interactive后配置。

缺省

命令模式

端口配置态(异步模式)

 示例

router_conf_s1/0#physical-layer mode async

router_conf_s1/0#async mode interactive

将s1/0改为交互模式。这时s1/0对应于一个异步线路(line),line tty 1。可在line tty 1下进行相应的其他配置。

1.1.2   bandwidth

使用bandwidth接口配置命令设置接口的带宽值。使用这个命令的no形式恢复缺省值。

bandwidth kilobps

no bandwidth

参数

参数

参数说明

Kilobps

设置的带宽,每秒千位。对于以太网接口,输入值为10000。

缺省

缺省带宽值在创建接口时设置,可以使用show interface命令显示,或者使用bandwidth ?会以<最小值-最大值[当前值]>的格式提示。

命令模式

接口配置态

使用说明

bandwidth命令只设置一个信息参数,不能使用这个命令设置接口的实际带宽。对于一些介质,如Ethernet,带宽是固定的;而对于另一些介质,如串行线,可以通过调整硬件来改变实际的带宽。对于这两类介质,都可以使用bandwidth配置命令把当前带宽传递给上层协议。

注意:

这只是一个路由参数,不影响物理接口的实际通信速率,实际通信速率请用physical-layer speed命令设置。

示例

下面的例子设置E1传输的带宽:

!

interface serial 1/0

bandwidth 2000

!

相关命令

show interface

physical-layer speed

1.1.3   cablelength

该命令用于设定PCI E1端口的连线方式。

[no] cablelength [ short | long]  

参数

参数

参数说明

short

表示该PCI UE1接口所连接的线为短线

long

表示该PCI UE1接口所连接的线为长线

缺省

无  

命令模式

controller e1配置态  

示例

Router_config#controller e1 2/0

Router_config_controller_e1_2/0#cablelength short

Router_config_controller_e1_2/0#no cablelength

Router_config_controller_e1_2/0#cablelength long

1.1.4   channel-group

使用channel-group命令,配置E1接口的通道。通道可以占用任何未分配的时隙,并能够任意组合时隙。E1通道配置成功后产生新的接口。使用这个命令的no形式清除通道,相应的接口也被删除。

channel-group channel-group timeslots { number | number1-number2 } [,number | number1-number2 ... ]

no channel-group channel-group

参数

参数

参数说明

channel-group

E1通道号,范围为0-30。

number,number1,number2...

E1时隙号,范围为1-31,可任意组合。

缺省

无缺省值

命令模式:

E1配置态

使用说明

E1接口在信道化(Channelized)方式下,当配置的channel-group参数后,系统产生新的接口。其逻辑特性与同步串口相同。名字为serial<slot>/<group>:<channel-group>,其中<slot>与<group>和controller E1 <slot>/<group>一致。

E1接口在非信道化(Unchannelized)方式下,系统产生新的interface。名字为serial<slot>/<group>:0

可在该interface上封装PPP、帧中继、LAPB和X.25等 链路层协议。

示例

下面的例子配置了5个通道:

Router_config#controller E1 2/0

Router_config_controller_E1_2/0#channel 1 timeslots 1

Router_config_controller_E1_2/0#channel 2 timeslots 2-3

Router_config_controller_E1_2/0#channel 3 timeslots 4,6-8

Router_config_controller_E1_2/0#channel 4 timeslots 9-10,5

Router_config_controller_E1_2/0#channel 5 timeslots 18,11-13,20,22,30-28,24-25

Router_config_controller_E1_2/0#interface s1/0:5

Router_config_interface_s2/0:5#

下面的例子清除了通道2:

Router_config#controller E1 2/0

Router_config_controller_E1_2/0#no channel 2

相关命令

controller E1

1.1.5   clock

使用clock命令配置链路同步方式。使用这个命令的no形式,设置链路默认使用接收线路同步信号。

clock {external|internal}

no clock

参数

参数

参数说明

external

设置链路使用接收线路同步信号

internal

设置链路使用芯片内部同步信号

缺省

使用接收线路同步信号

命令模式

E1配置态

示例

下面的例子设置链路使用芯片内部同步信号:

Router_config#controller E1 2/0

Router_config_controller_E1_2/0#clock internal

相关命令

1.1.6   controller E1

使用controller E1命令配置E1接口,进入E1配置态。

controller E1 <slot>/<group>

参数

参数

参数说明

slot

E1控制器所在的槽号。

group

E1控制器的链路号。

缺省

无缺省值。

命令模式

全局配置态

使用说明

配置E1接口,首先必须在全局配置态下输入controller E1命令,进入E1配置态。

示例

下面的例子配置E1接口2/0:

Router_config#controller E1 2/0

Router_config_controller_E1_2/0#

相关命令

framing

channel-group

1.1.7   delay

使用delay接口配置命令,设置接口的时延。使用这个命令的no形式恢复缺省时延。

delay tens-of-microseconds

no delay

参数

参数

参数说明

tens-of-microseconds

指定接口的时延,以十微秒为单位。

缺省

缺省时延值在创建接口时设置,可以使用show interface命令显示,或者使用delay ?会以<最小值-最大值[当前值]>的格式提示。

命令模式

接口配置态

使用说明

delay命令只设置一个信息参数,不能使用这个命令设置接口的实际时延。delay配置命令仅用于把配置时延传递给上层协议。

示例

下面的例子设置串行接口1/2上3000微秒的延时:

!

interface serial 1/2

delay 300

!

相关命令

show interface

1.1.8   description

使用description接口配置命令,设置接口的描述。使用这个命令的no形式清除接口的描述信息。

description line

no description

参数

参数

参数说明

line

指定接口的描述,可为任意字符。

缺省

接口缺省描述为空。

命令模式

接口配置态

使用说明

description命令只设置接口的描述,便于用户的记忆,不影响接口的任何功能。可以使用show interface或show running-config命令显示。

示例

下面的例子设置串行接口1/2上描述:

!

interface serial 1/2

description Connect to Beijing

!

相关命令

show interface

show running-config

1.1.9   duplex

使用duplex接口配置命令设置以太网接口使用的双工类型。使用这个命令的no形式恢复缺省封装

duplex  duplex-type

参数

参数

参数说明

duplex-type

双工类型,为下面的关键字之一:half-半双工、full-全双工。

缺省

缺省值与接口的速度有关。例如,快速以太网如为自适应,则此命令不起作用。10M以太网口缺省为半双工模式。

命令模式

接口配置态

使用说明

进入相应的以太网接口配置态下使用此命令。

示例

下面的例子设置10M以太网接口1/0上的全双工模式:

!

interface ethenet 1/0

duplex full

!

下面的例子恢复10M以太网接口1/0上的缺省封装:

!

interface ehenet 1/0

no duplex

!

相关命令

speed

1.1.10   encapsulation

使用encapsulation接口配置命令设置接口使用的封装协议。使用这个命令的no形式恢复缺省封装

encapsulation encapsulation-type

参数

参数

参数说明

encapsulation-type

封装类型,为下面的关键字之一: frame-relay-帧中继(用于串行接口); hdlc-串行接口的HDLC协议,它提供HDLC的同步帧和检错功能而无窗口或重传机制; ppp-PPP(用于串行接口); slip-SLIP(用于串行接口); x25-X.25(用于串行接口); sdlc-串行接口的SDLC协议;

缺省

缺省值与接口的类型有关。例如,同步串行接口缺省为HDLC,异步接口和拨号接口缺省为PPP。

命令模式

接口配置态

使用说明

若想同时支持多个封装,可以使用autoselect命令。此命令设置接口的主要封装协议。可以使用show interface命令显示接口的主要封装。目前此命令只在串行接口有效。

示例

下面的例子设置串行接口1/1上的帧中继封装:

!

interface serial 1/1

encapsulation framerelay

!

下面的例子恢复串行接口1/0上的缺省封装:

!

interface serial 1/0

no encapsulation

!

相关命令

show interface

1.1.11   encapsulation dot1q

使用encapsulation dot1q以太网子接口配置命令设置该子接口的vlan id。使用这个命令的no形式恢复缺省封装

encapsulation dot1q vlan-identifier

参数

参数

参数说明

vlan-identifier

整数类型,vlan id

缺省

没有封装802.1Q

命令模式

以太网子接口配置态

使用说明

必须配置相应的vlan id该子接口才能有效,同一个主接口的多个子接口不能配置相同的vlan id。

示例

下面的例子设置串行接口1/0.1上的vlan id为1:

int f!

interface FastEthernet0/0.1

encapsulation dot1q 1

!

相关命令

1.1.12   framing

使用framing命令配置链路校验方式。使用这个命令的no形式,设置链路默认使用crc4校验。

framing {crc4 | no-crc4}

no framing

参数

参数

参数说明

crc4

设置链路使用crc4校验。

no-crc4

设置链路不使用crc4校验。

缺省

使用crc4校验。

命令模式

E1配置态

使用说明

示例

下面的例子设置链路使用crc4校验:

Router_config#controller E1 2/0

Router_config_controller_E1_2/0#framing crc4

相关命令

1.1.13   interface

使用interface全局配置命令配置接口类型和进入接口配置态。使用这个命令的no形式删除接口或初始化接口。

interface type interface-number

interface type slot/port (用于带有非信道化E1的物理接口的路由器)

interface serial slot/port:channel-group(用于配置非信道化E1的物理接口)

要配置子接口,使用这个形式的interface全局配置命令:

interface serial slot/port.subinterface-number {multipoint | point-to-point}

参数

参数

参数说明

type

指定要配置的接口类型。

interface-number

逻辑接口序号

slot

插槽或插卡编号

port

插槽或插卡端口编号

channel-group

范围为0-30的E1信道组号,使用channel-group配置命令定义

subinterface-number

范围为1-32767的子接口号。

multipoint| point-to-point

指定点对多点或点对点子接口,没有缺省值。创建时必须指定。

缺省

无接口被缺省配置。

命令模式

全局配置态

使用说明

子接口可以用于配置支持非全连通的帧中继网络。

表 1‑1 接口类型关键字和描述对照表

关键字

接口类型

async

异步接口

bm

DTU接口

bri

ISDN基本速率接口(BRI)

dialer

拨号接口

ethernet

以太网接口

fastethernet

快速以太网接口

loopback

仅软件实现的回环接口,模拟总是开启的接口。 interface-number是想创建或配置的回环接口序号。

null

空接口

serial

串行接口

Multilink

Multilink接口

Virtual-template

Virtual-template接口

Virtual-tunnel

Virtual-tunnel接口

Vlan-intf

Vlan-intf接口

Tunnel

Tunnel接口

对于物理接口和子接口,使用no interface命令恢复接口的缺省配置。对于其它接口,使用no interface命令删除。

示例

下面的例子使用PPP封装配置串行接口1/0:

!

interface serial 1/0

encapsulation ppp

!

下面的例子配置回环接口,并给接口分配一个IP网络地址和网络掩码。

!

interface loopback 0

ip address 192.168.1.1 255.255.255.0

!

下面的例子表明如何配置子接口。在这个例子中,子串行接口1/0.1配置为有3个关联帧中继PVC的点对多点子接口,子串行接口1/0.2配置为点对点子接口。

!

interface serial 1/0

encapsulation framerelay

!

interface serial 1/0.1 multipoint

ip address 192.168.1.1 255.255.255.0

map 192.168.1.2 pvc 22 broadcast

map 192.168.1.3 pvc 23 broadcast

!

interface serial 1/0.2 point-to-point

ip address 192.168.2.1 255.255.255.0

map 192.168.2.2 pvc 102 broadcast

!

下面的例子配置E1链路的信道组3封装PPP协议:

!

controller E11 2/3

channel-group 3 timeslots 0-3

!

interface serial 2/3:3

ip address 192.168.3.1 255.255.255.0

encapsulation ppp

!

相关命令

show interface

1.1.14   interface dialer

使用interface dialer全局配置命令进行拨号接口的配置。使用no形式删除拨号接口。

interface dialer interface-number

no interface dialer interface-number

参数

参数

参数说明

interface-number

拨号接口序号,范围0-32767。

缺省

缺省没有创建拨号接口

命令模式

全局配置态

使用说明

拨号接口支持把一个接口配置应用于一组接口。这样配置在要求许多呼叫目的地的环境中是有用的,此时只有该拨号接口需要进行dialer map命令配置。接口要求的唯一配置是dialer rotary-group命令,指示是哪个拨号接口组的一部分。尽管拨号接口被配置为一个接口,但它不是一个物理接口,而是代表一组接口。在进入拨号接口配置态后输入的接口配置命令将应用于所有隶属于此拨号接口的物理接口。

示例

下面的例子示范一个拨号接口的可能配置:

!

interface dialer 1

encapsulation ppp

ip address 192.168.1.1 255.255.255.0

dialer map 192.168.1.2 name 2222 14155553434

dialer map 192.168.1.3 name 3333

!

相关命令

dialer rotary-group

1.1.15   linecode

使用linecode命令配置链路编码方式。使用这个命令的no形式,设置链路默认使用hdb3编码。

linecode{ hdb3| ami}

no linecode

参数

参数

参数说明

hdb3

设置链路使用hdb3编码

Ami

设置链路使用ami编码

缺省

使用hdb3编码

命令模式

E1配置态

使用说明

示例

下面的例子设置链路使用hdb3编码:

Router_config#controller E1 2/0

Router_config_controller_E1_2/0#linecode hdb3

相关命令

1.1.16   linemode

命令描述

用于选择Dtu卡的工作模式。

命令格式

linemode [NT/LT]

参数

参数

参数说明

NT

Dtu卡工作在NT模式下。

LT

Dtu卡工作在LT模式下。

缺省

NT

命令模式

端口配置模式

示例

配置DTU卡为LT工作模式:

router_ config #interface bm2/0

router_ config bm2/0#linemode lt

1.1.17   mtu

使用mtu接口配置命令调整最大分组尺寸或MTU尺寸。使用这个命令的no形式恢复MTU值到它的缺省值。

mtu bytes

no mtu

参数

参数

参数说明

bytes

要求MTU的大小,单位为字节。

缺省

除了回环接口为1514以外,其它接口缺省值均为1500。

命令模式

接口配置态

使用说明

每个接口的缺省值通常为该类型接口的最大可能的尺寸。在串行接口上,MTU大小是变化的,但不能小于68字节。可以通过show interface命令察看当前MTU的设置,使用mtu ?会以<最小值-最大值[当前值]>的格式提示。

注意:

使用mtu接口配置命令改变MTU值会影响该命令协议特定版本的值(如ip mtu)。如果使用ip mtu接口配置命令指定的值与使用mtu接口配置命令指定的值相同,则若改变mtu接口配置命令的值,ip mtu自动匹配新的MTU。但是,改变ip mtu接口配置命令的值不影响mtu接口配置命令的值。

示例

下面的例子指定576字节的MTU:

!

interface serial 1/0

mtu 576

!

相关命令

ip mtu

1.1.18   physical-layer mode

使用physical-layer mode接口配置命令指定串行接口的同异步模式。使用这个命令的no形式,使接口回到默认的同步模式。

physical-layer mode {sync | async}

no physical-layer mode

参数

参数

参数说明

sync

设置接口为同步模式。

async

设置接口为异步模式。

缺省

同步模式

命令模式

接口配置态

使用说明

当处于异步模式时,接口支持标准异步接口可用的所有命令。当同异步模式切换时,对于在新的模式下不存在的封装协议将自动被永久删除。如果都不存在,则封装变为新模式下的缺省封装。

示例

下面的例子把串行接口从同步更改为异步:

!

interface serial 1/2

physical-layer mode async

!

相关命令

1.1.19   Physical-layer speed

命令描述

用来设定传输速率

命令格式

physical-layer speed <64000/128000/default>

参数

参数

参数说明

64000

传输速率为64k ,B1通道。

128000

传输速率为128k,B1+B2通道。

default

缺省模式,64k。

缺省

deflault

命令模式

端口配置模式

示例

配置DTU卡工作在128K速率下。

router_ config #interface bm2/0

router_ config config_bm2/0#physical-layer speed 128000

1.1.20   physical-layer speed

使用physical-layer speed接口配置命令指定串行接口的速率。

physical-layer speed speed

参数

参数

参数说明

speed

接口的速率值。

表 1‑2 同步和异步接口支持的速率值表

同步接口

异步接口

1200,2400,4800,9600,14400,19200,38400, 64000,115200,128000,256000,512000,1024000,2048000

1200,2400,4800,9600,14400,19200,38400,57600,115200

缺省

同步模式下为64000bps。

异步模式下为9600bps。

命令模式

接口配置态

使用说明

异步串口线路两端的两台路由器异步串口的波特率设置必须一致。在同步方式设成异步方式后,路由器会将波特率自动改为9600 bps。

两个同步串口相连时,线路上的波特率由DCE侧决定,因此当同步串口工作在DCE方式下, 需要配置波特率,如果作为DTE设备使用,则不需配置波特率。在异步方式设成同步方式后,路由器会将波特率自动改为64000 bps。

示例

下面的例子把串行接口速率设置为57600 bps:

!

interface serial 1/2

physical-layer speed 57600

!

相关命令

physical-layer mode

1.1.21   physical-interface fiber

使用physical-interface全局配置命令配置以太网口的光口模式。

参数

缺省

命令模式

接口配置态

使用说明

进入相应端口的配置态下使用。

示例

相关命令

1.1.22   show interface

使用show interface全局配置命令配置接口状态。

show interface

show interface type interface-number

show interface type slot/port (用于带有非信道化E1的物理接口的路由器)

show interface serial slot/port:channel-group(用于显示非信道化E1的物理接口)

show interface serial slot/port.subinterface-number(用于显示子接口)

参数

参数

参数说明

type

指定要配置的接口类型。

interface-number

逻辑接口序号。

slot

插槽或插卡编号。

port

插槽或插卡端口编号。

channel-group

范围为0-30的E1信道组号,使用channel-group配置命令定义。

subinterface-number

范围为1-32767的子接口号。

缺省

命令模式

管理态

使用说明

若show interface命令后面不带任何参数,则显示所有接口的信息。

示例

相关命令

1.1.23   shutdown (E1 controller)

使用shutdown命令关闭一个E1接口。使用这个命令的no形式重新启用被停用的E1接口。

shutdown

no shutdown

参数

缺省

所有接口缺省都是启用的。

命令模式

E1配置态

使用说明

shutdown命令禁止指定E1接口上的所有功能。

示例

下面的例子停用E1接口1/0:

Router_config#controller E1 2/0

Router_config_controller_E1_2/0#shutdown

下面的例子再次启用这个接口:

Router_config#controller E1 2/0

Router_config_controller_E1_2/0#no shutdown

相关命令

1.1.24   shutdown (interface)

使用shutdown接口配置命令停用一个接口。使用这个命令的no形式重新启用被停用的接口。

shutdown

no shutdown

参数

缺省

所有接口缺省都是启用的。

命令模式

接口配置态

使用说明

shutdown命令禁止指定接口上的所有功能。在串行接口上,这个命令引起DTR信号下降。同时这个命令也标记接口不可用。要检查接口是否被停用,使用show interface命令。被停用的接口在这个命令的显示中显示为“administratively down”。

示例

下面的例子停用Ethernet接口1/1:

!

interface ethernet 1/1

shutdown

!

下面的例子再次启用这个接口:

!

interface ethernet 1/1

no shutdown

!

相关命令

show interface

1.1.25   speed

使用speed接口配置命令对以太网进行配置。使用这个命令的no形式重新恢复缺省的配置。

speed (10|100)

no speed

参数

参数

参数说明

10

指定快速以太网口工作于10M模式下。

100

指定快速以太网口工作于100M模式下。

缺省

自适应

命令模式

接口配置态

使用说明

示例

下面的例子配置FastEthernet接口1/0工作在10M速度下:

!

interface fastethernet 1/0

speed 10

!

下面的例子恢复接口为缺省(自适应):

!

interface fastethernet 1/1

no speed

!

相关命令

1.1.26   tunnel

使用tunnel接口配置命令配置Tunnel类型接口中的相关参数。使用这个命令的no形式恢复这些参数的缺省值。

tunnel { checksum | destination ip-address | key key-number | mode type | sequence-datagrams | source {ip-address | interface} | test| speed-up }

no tunnel { checksum | destination | key | mode | sequence-datagrams | source | test| speed-up }

参数

参数

参数说明

checksum

指定打开端对端的包校验。

destination

配置Tunnel的目的地址 。

key

配置Tunnel的钥匙 。

key-number

十进制类型的钥匙 。

mode

配置Tunnel的封装协议 。

type

封装协议的类型参数 。

sequence-datagrams

丢弃乱序的数据包 。

source

配置Tunnel的源地址 。

interface

当前路由器上的接口 。

test

测试封装协议

speed-up

打开tunnel 加速处理。

test

测试封装协议 。

缺省

缺省值

缺省值说明

checksum

关闭

destination

key

关闭

mode

封装gre/ip协议

sequence-datagrams

关闭

source

test

未启动

speed-up

不打开

命令模式

接口配置态(且仅只有在Tunnel类型接口中存在)

使用说明

tunnel命令仅存在于Tunnel类型接口中,若要使一个Tunnel类型接口协议能够运行(protocal up),必须配置以下几个参数:

l   接口的IP地址

l   Tunnel的源地址

l   Tunnel的目的地址

同时要确保有达到Tunnel目的地址的有效路由。

当前版本中,Tunnel能够支持的封装协议为GRE。

示例

下面的例子启用Tunnel接口100:

!

interface Ethernet1/1

ip address 10.1.1.1 255.255.255.0

!

interface Tunnel100

ip address 192.168.20.202 255.255.255.0

tunnel source Ethernet1/1

tunnel destination 10.1.1.2

!

由于Tunnel类型接口缺省封装协议为GRE/IP,所以在下面例子中的恢复Tunnel类型接口缺省封装协议命令和配置GRE/IP封装协议命令等效:

router_config#interface Tunnel100

router_config_t100#no tunnel mode

等效于

router_config#interface Tunnel100

router_config_t100#tunnel mode gre ip

相关命令

interface tunnel

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

发表于

我来说两句

0 条评论
登录 后参与评论

相关文章

来自专栏coding

RabbitMQ实战5.路由

注意!交换机为匿名交换机时,routing_key指的是队列名,这只是一个特例!这个参数的本意是路由键名!

922
来自专栏用户2442861的专栏

【网络协议】TCP连接的建立和释放

转载请注明出处:http://blog.csdn.net/ns_code/article/details/29382883

1491
来自专栏高性能服务器开发

从抓包的角度分析connect()函数的连接过程

这篇文章主要是从tcp连接建立的角度来分析客户端程序如何利用connect函数和服务端程序建立tcp连接的,了解connect函数在建立连接的过程中底层协议栈做...

1311
来自专栏王亚昌的专栏

开多少个FCGI进程才合适

    现在网站很多都用FCGI布署到WEB SERVER上提供服务,但同一个服务的FCGI开多少个进程才合适呢?

791
来自专栏向治洪

maven配置详解

什么是pom?     pom作为项目对象模型。通过xml表示maven项目,使用pom.xml来实现。主要描述了项目:包括配置文件;开发者需要遵循的规则,缺...

2485
来自专栏青玉伏案

TCP/IP协议族(一) HTTP简介、请求方法与响应状态码

接下来想系统的回顾一下TCP/IP协议族的相关东西,当然这些东西大部分是在大学的时候学过的,但是那句话,基础的东西还是要不时的回顾回顾的。接下来的几篇博客都是关...

2816
来自专栏转载gongluck的CSDN博客

UNPv13:#第4章#基于TCP套接字编程

概述 ? socket函数 #inlcude <sys/socket.h> int socket(int family, int type, int prot...

3638
来自专栏康怀帅的专栏

Linux 常见问题解决方法

本文列举了 Linux 常见问题及其解决方法。 sudo 找不到命令 编辑 /etc/sudoers 文件。 Defaults secure_path=......

3516
来自专栏xcywt

关于HTTP的笔记

网上看了一篇关于HTTP的博客,觉得还不错,这里就记下来了。 参考:https://www.cnblogs.com/guguli/p/4758937.html ...

3286
来自专栏Java架构师历程

TCP连接的状态详解以及故障排查

我们通过了解TCP各个状态,可以排除和定位网络或系统故障时大有帮助。(总结网络上的内容)

9482

扫码关注云+社区

领取腾讯云代金券