烽火2640路由器命令行手册-03-广域网配置命令

第1章   帧中继(FR)配置命令

1.1  FR配置命令

帧中继(FR)配置命令包括:

l   encapsulation frame-relay

l   frame-relay cir

l   frame-relay interface

l   frame-relay inverse-arp

l   frame-relay lmi-type

l   frame-relay local-dlci

l   frame-relay map

l   frame-relay n391

l   frame-relay n392

l   frame-relay n393

l   frame-relay t391

l   frame-relay t392

l   frswitch 

l   clear frame-relay-inarp

l   show frame-relay

l   show frswitch

l   show interface 

l   debug frame-relay

1.1.1   encapsulation frame-relay

接口封装帧中继。no取消封装。

encapsulation frame-relay

no encapsulation frame-relay

参数

缺省

命令模式

接口配置态

使用指南

使用no取消封装,即回到封装HDLC方式。

示例

下面例子在串口s1/1配置帧中继封装方式:

!

interface s1/1

encapsulation frame-relay

!

1.1.2   frame-relay cir

为帧中继虚电路设定提交信息速率。

frame-relay cir bps

参数

参数

参数说明

bps

提交信息速率(CIR), 每秒比特数. 默认值64000。

其值为1至2048000之间的值。

缺省

64000

命令模式

接口配置态

使用指南

提交速率在申请DLCI时确定。

示例

把s1/1口配成帧中继,并配置cir为2048000。

!

interface s1/1

encapsulation frame-relay

frame-relay cir 2048000

!

相关命令

1.1.3   frame-relay intf-type

设定帧中继的交换类型。

frame-relay intf-type [dce | dte | nni]

参数

参数

参数说明

dce

(可选项) 连接到路由器的路由器或访问服务器以交换机的方式工作。

dte

(可选项) 路由器或访问服务器以接入帧中继网络的终端设备方式工作。这是缺省配置。

nni

(可选项) 路由器或访问服务器以交换机的方式连接到网络,即支持NNI网络连接。

缺省

dte

命令模式

接口配置态

使用指南

当帧中继端口与网络相连一般应配为DTE,若路由器为背靠背相连,则一台配成DTE,另一台配成DCE。如果需要双向LMI过程,应配置为NNI。 帧中继标准描述了一个终端用户与一帧中继网络之间的接口,称为UNI,以及邻近帧中继网络之间的接口,称之为NNI。下图描述了UNI和NNI的概念。

一条端到端PVC链接由许多PVC段构成。每条PVC段由一个UNI和一个NNI或两个NNI分隔。要激活一条PVC,需要激活所有PVC段。网络可以是链状的。一个终端用户站点连接着的网络称作存取网络,中间的网络称作传输网。每个网络均为本地寻址,这意味着PVC的每一段都有独立的DLCI号。但是在两个邻接着的网络中的链接上使用的DLCI号必须一致。NNI与UNI基于同样的标准。为提供一个平衡接口,在两端必须同时提供网络端与用户端过程。

示例

把s1/1口配成frame-relay,配置interface为dce 。

!

interface s1/1

enca frame-relay

frame-relay intf-type dce

!

1.1.4   frame-relay inverse-arp

在配置帧中继的路由器或访问服务器上,如果未激活反向地址解析协议(Inverse ARP),则使用这个命令重新激活反向地址解析协议。

[no] frame-relay inverse-arp

参数

缺省

打开反向地址解析协议(IARP)。

命令模式

接口配置态

使用指南

反向ARP是用于帧中继网上询问对方协议地址的协议。其实现可以参见RFC1293。它使配置帧中继的路由器或访问服务器能发现与虚电路关联的协议地址。

在帧中继网络中,PVC的DLCI可以看成硬件地址。通过信令信息,网络建立一条虚电路,通过反向ARP可以发现电路另一端的协议地址。

示例

把s1/1口配成帧中继,禁止反向ARP 。

!

interface s1/1

enca frame-relay

no fr inverse-arp

!

相关命令

show frame-relay

1.1.5   frame-relay lmi-type

配置LMI的类型。使用no frame-relay lmi-type命令恢复到默认类型值:

[no] frame-relay lmi-type { q933a | bcisco | ansi}

参数

参数

参数说明

q933a

ITU-T Q.933附件A。

ansi

ANSI T1.617附件定义的接口类型。

bcisco

Group of Four的Rev 1。与Cisco兼容。

缺省

Autosense

命令模式

接口配置态

使用指南

LMI定义了用户设备与帧中继网络之间的操作,它提供永久虚电路(PVC)的状态或过时的通知。q933a采用ITU-T Q.933附件A中定义的过程与消息。ansi采用ANSI T1.617 附件D中定义的过程与消息。bcisco采用Group of Four Rev.#1中定义的过程与消息。 LMI类型的设置是基于接口的,可以通过命令show interface来查看。

示例

下面的例子配置接口LMI为ANSI 附件D:

!

interface S1/1

encapsulation frame-relay

frame-relay lmi-type ansi

!

1.1.6   frame-relay local-dlci

配置本地DLCI。使用no命令取消设置。

frame-relay local-dlci number [cir speed]

no frame-relay local-dlci number

参数

参数

参数说明

number

本地DLCI

speed

CIR速率

缺省

无本地DLCI 。

CIR速率缺省为64000 。

命令模式

接口配置态

使用指南

用于没有配置LMI或背靠背连接并做DCE时,配置可用的DLCI。在其它情况下,可通过LMI获得。 no表示删除该DLCI。

示例

下面的例子配置一条编号100的本地DLCI:

!

interface s1/1

frame-relay local-dlci 100

!

1.1.7   frame-relay n391

设定执行全部状态信息的查询前的状态查询次数。

frame-relay n391 keep-exchanges

参数

参数

参数说明

keep-exchanges

设定全部状态信息的查询时间间隔。范围:1-255。

缺省

交换6次

命令模式

接口配置态

使用指南

接口必须是DTE设备或NNI接口,才能使用这个命令。每n391次轮询包中发送一次请求完全PVC状态。

示例

下面的例子中,每四次状态查询,将执行一次全状态信息查询。其他三次,交换机只返回变化的状态信息。

!

interface s1/0

frame-relay intf-type dte

frame-relay n391 4

!

1.1.8   frame-relay n392

配置错误门限计数器。

frame-relay n392 threshold

参数

参数

参数说明

threshold

错误的门限值。范围为:1-10,默认值为3。

缺省

3

命令模式

接口配置态

使用指南

若每n393个轮询包中有连续n392个失败,则链路状态异常。在判定链路关闭的N393事件计数器到达以前,必须出现N392定义的错误次数。因此,这个值必须小于frame-relay n393 中定义的值。

示例

下面的例子配置LMI的错误门限值为4。该路由器为帧中继DCE设备或NNI交换机:

!

interface s1/0

frame-relay intf-type dce

frame-relay n392 4

!

相关命令

frame-relay n393

1.1.9   frame-relay n393

配置监视的事件计数器。

frame-relay n393 events

参数

参数

参数说明

events

监视的事件计数值。范围1-10。默认值为4。

缺省

4

命令模式

接口配置态

使用指南

这个命令与frame-relay n392配置的参数是链路关闭的条件。在执行中,在判定链路关闭的N393事件计数器内,N392定义的错误次数必须出现。

示例

下面的例子配置LMI监视的事件计数器值为3。路由器以帧中继的DCE或NNI交换机的方式工作:

!

interface s1/0

frame-relay interface dce

frame-relay n393 3

!

相关命令

frame-relay n392

表 1‑1 LMI系统参数计数器

计数器

描 述

范围

缺省

用 途

用户或网络端

N391

Status (full)轮询计数器

1-255

6

轮询循环

用户端

N392

出错门限

1-10

3

出错

双方

N393

监测的事件计数

1-10

4

事件

双方

注意:

N392要小于或等于N393。N391始终用于用户端过程。

1.1.10   frame-relay t391

配置链路完整性验证轮询定时器。

frame-relay t391 seconds

参数

参数

参数说明

seconds

轮询验证定时器的值, 以秒为单位.范围5-30.默认值为10秒。

缺省

10 秒

命令模式

接口配置态

使用指南

用于DTE端。 每t391秒发送状态请求消息,如果未收到状态端消息,则记录错误。

示例

下面的命令设置链路完整性验证轮询定时器的值为20秒:

!

interface s1/1

frame-relay intf-type dce

frame-relay t391 20

!

相关命令

frame-relay t392

1.1.11   frame-relay t392

配置轮询验证定时器。

frame-relay t392 seconds

参数

参数

参数说明

seconds

轮询验证定时器的值, 以秒为单位.范围5-30.默认值为15秒.

缺省

15 秒

命令模式

接口配置态

使用指南

用于DCE端。 每t392秒期待一个状态请求消息,若未收到,则记录错误。 t392>t391。

示例

下面的命令设置轮询验证定时器的值为20秒:

!

interface s1/1

frame-relay intf-type dce

frame-relay t392 20

!

相关命令

frame-relay t391

表 1‑2 LMI系统参数定时器

定时器

描述

范围

缺省(秒)

启动

停止

超时系统的行为

T391

链路完整性校验轮询定时器。

5-30

10

发送Status Enquiry消息。

如果Status消息未收到,记录错误。

T392

轮询验证定时器。

5-30

15

发送Status消息。

收到Status Enquiry消息。

通过增加N392来记录错误,并重新启动定时器。

注意:

T392要大于T391,T391始终用于用户端过程,T392始终用于网络端过程。

1.1.12   frswitch

这个全局配置命令在帧中继的DCE或NNI上激活PVC交换。no命令取消配置。

frswitch in-port in-dlci out-port out-dlci

no frswitch in-port in-dlci out-port out-dlci

参数

参数

参数说明

in_port

交换的第一个端口。

in_dlci

第一个端口的DLCI。

out_port

交换的第二个端口。

out_dlci

第二个端口的DLCI。

缺省

命令模式

全局配置态

使用指南

配置交换表时,连接的两个端口必须封装成帧中继,而且存在有效的永久虚电路。

示例

下面的例子说明,路由器在接口s1/1与接口s1/2之间实现PVC的交换。在接口1上收到的DLCI 100的帧将从串口2的DLCI 200上转发出去。

frswitch s1/1 100 s1/2 200

1.1.13   frame-relay map

配置通过DLCI连接的目的协议地址。使用no命令取消设置。

[no] frame-relay map ipaddress pvc dlci [broadcast]

参数

参数

参数说明

ipaddress

目的IP地址。

dlci

连接目的协议地址的DLCI(16-1007)。

broadcast

(可选参数) 当多播未激活时,从这个接口转发广播包。

缺省

无缺省

命令模式

接口配置态

使用指南

路由器与访问服务器可以有多个DLCI,发送数据。但它们能被复用到一条物理链路上。帧中继map命令定义了在特定的协议与地址对与DLCI之间的逻辑连接。Broadcast激活了两个功能:如果未激活多播,则转发广播;简化帧中继非广播网络中的OSPF的配置。

示例

下面的例子把IP地址172.16.123.1映射到DLCI 100:

!

interface s1/0

frame-relay map 172.16.123.1 pvc 100 broadcast

!

OSPF 将使用DLCI 100 广播路由更新。  

1.1.14   clear frame-relay-inarp

该命令用于清除指定帧中继端口(或所有端口)用Inverse ARP协议获得的远端地址表。

命令格式

clear frame-relay-inarp [Serial]

参数

参数

参数说明

Serial

为封装帧中继的端口名称。

命令模式

管理态

1.1.15   show frame-relay

显示连接的当前的映射项和信息。

show frame-relay

参数

该命令无参数

命令模式

所有配置态

使用说明

察看所有帧中继端口及活跃的DLCI状态。先显示所有配置了帧中继协议的端口上的协议状态,可为“UP”或“DOWN”,必须保证协议状态为“UP”才有可能进行上层协议数据的传输。状态表,按端口和DLCI排序,每条DLCI占一行,每行分为五列,从左到右依次为端口名称、DLCI的值、DLCI的状态、远端IP地址、本地IP地址和类型。DLCI状态可为ACTIVE、INACTIVE或DELETED,分别表示DLCI活跃、不活跃或被删除。 类型域主要用来区别静态或动态的映射方式。M为静态,I为动态(InverseARP)。

下面是一样本输出:

Router#show frame-relay

Frame Relay/IP状态

Serial1/0 UP 

=======================================================================

端口

DLCI

状态

远端IP地址

本地IP地址

类型

=======================================================================

Serial1/0

32

ACTIVE

130.130.0.2

M

Serial1/1

33

ACTIVE

133.133.0.3

M

相关命令

show interface

1.1.16   show frswitch

显示帧中继交换表信息。

show frswitch

参数

命令模式

所有配置态

使用说明

帧中继背靠背做实验时,两端DLCI应一致,若通过交换机相连,则可能不同。

示例

下面是一样本输出:

Router#show frswitch

帧中继PVC连接路由表

源端口        pvc            目的端口      pvc

Serial1/0       32    <--->    Serial1/1      35

相关命令

show interface

1.1.17   show interface

该命令用于显示串口信息和协议统计信息。如果串口使用帧中继封装,则可以使用它显示帧中继协议的统计信息。

show interface type number

参数

参数

参数说明

type

接口类型 。

number

接口编号。

命令模式

所有配置态

使用说明

这个命令显示帧中继链路的状态和统计信息。

示例

下面执行串口的样本输出:

router#show int s1/0

Serial1/0 is up, line protocol is up

  Hardware is SCC Mode=Sync,Speed=64000

  DTR=UP,DSR=UP,RTS=UP,CTS=UP,DCD=UP

  Interface address is 96.0.0.2/8

  MTU 1500 bytes, BW 64 kbit, DLY 2000 usec

  Encapsulation frame-relay, loopback not set

  Keepalive set(10 sec)

  frame-relay DCE, LMI type is Q933A, LMI DLCI 1023

  LMI DCE Link Errors 1, Protocol Errors 2, Inactives 0

  Recvd Octets 2630, Recvd Frames 203, Recvd Discards 0

  Sent Octets 2802, Sent Frames 202, Sent Discards 0

  Recvd Errors 1, Send Errors 0, Recvd Unknowns 1 

1 minute input rate 11 bits/sec, 0 packets/sec

  1 minute output rate 11 bits/sec, 0 packets/sec

     203 packets input, 3046 bytes, 0 no buffer

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     202 packets output, 3206 bytes, 0 underruns

PowerQUICC SCC specific errors:

  0 recv allocb mblk fail       0 recv no buffer

  0 transmitter queue full      0 transmitter hwqueue_full

相关命令

show frame-relay

表 1‑3 帧中继可能显示的统计信息见下表

中文

英文

含义

接收字节数

Recvd Octets

该端口自从配置为帧中继协议以来收到的字节数。

接收帧数

Recvd Frames

该端口自从配置为帧中继协议以来收到的帧数 。

接收到但被丢弃帧数

Recvd Discards

该端口自从配置为帧中继协议以来接收正确但被丢弃的帧数。

接收到的错误帧数

Recvd Errors

该端口自从配置为帧中继协议以来接收错误的帧数 。

接收的未知协议帧数

Recvd Unknown Protocols

该端口自从配置为帧中继协议以来接收正确但封装未知协议的帧数 。

发送字节数

Sent Octets

该端口自从配置为帧中继协议以来发送成功的字节数。

发送帧数

Sent Frames

该端口自从配置为帧中继协议以来发送的帧数。

丢弃的发送帧数

Sent Discards

该端口自从配置为帧中继协议以来丢弃的待发送帧数。

发送出错帧数

Sent Errors

该端口自从配置为帧中继协议以来发送出错的帧数。

DTE链路错

LMI DTE Link Errors

自从该端口配置成帧中继协议以来,通过LMI DTE过程发现链路出错的次数。

DTE链路不活跃错

LMI DTE Inactives

自从该端口配置成帧中继协议以来,通过LMI DTE过程发现协议状态无效的次数。

DTE协议错

LMI DTE Protocol Errors

自从该端口配置成帧中继协议以来,通过LMI DTE过程发生消息内容错误的次数。

DCE链路错

LMI DCE Link Errors

自从该端口配置成帧中继协议以来,通过LMI DCE过程发现链路出错的次数 。

DCE链路不活跃错

LMI DCE Inactives

自从该端口配置成帧中继协议以来,通过LMI DCE过程发现协议状态无效的次数。

DCE协议错

LMI DCE Protocol Errors

自从该端口配置成帧中继协议以来,通过LMI DCE过程发生消息内容错误的次数。

1.1.18   debug frame-relay

显示帧中继交互信息。用no debug frame-relay停止显示信息。

[no] debug frame-relay [raw | event | lmi | packet] Serial

参数

参数

参数说明

Serial

需要打开debug信息的端口名。该端口可以是物理端口或E1映射的端口。

raw

显示原始帧中继帧。

event

显示所有帧中继事件。

lmi

显示所有LMI消息。

packet

显示所有数据报文。

命令模式

管理态

示例

Router#debug frame-relay lmi s1/0

Router#debug frame-relay event s1/0

Router#debug frame-relay packet s1/0

FR Serial1/0: TX -> LMI STATUS ENQUIRY(full) message, send seq 5, expect seq 7

FR Serial1/0: RX <- LMI STATUS(full) message, send seq 8, expect seq 5 200 A

FR Serial1/0: Active DLCI 200 according LMI message

FR Serial1/0: TX -> InARP request on DLCI 200, src(0,192.168.75.4),dst(200,0.0.0.0)

FR Serial1/0: RX <- InARP reply on DLCI 200, src(200,192.168.75.1),dst(200,192.168.75.4)

FR Serial1/0: Add map DLCI 200 to IP 8.0.0.1 according InARP message

FR Serial1/0: TX -> LMI STATUS ENQUIRY(link) message, send seq 7, expect seq 9

FR Serial1/0: RX <- LMI STATUS(link) message, send seq 10, expect seq 7

FR Serial1/0: Receive packet from upper on DLCI 200:Len = 84

FR Serial1/0: TX -> IP packet on DLCI 200:Len = 88

FR Serial1/0: RX <- IP Packet on DLCI 200:Len = 84

45 00 00 54 00 07 00 00 FF 01 AB 9F 08 00 00 01 E..T............

08 00 00 02 00 00 E2 70 00 0D 00 00 03 05 25 6E .......p......%n

FR Serial1/0: Forward packet to upper on DLCI 200:Len = 84

第一行表明端口发送LMI的完全状态查询消息。

第二行表明端口收到LMI的完全状态响应消息,其中DLCI 200有效。

第三行表明端口根据收到的LMI完全状态响应消息,激活DLCI 200。

第四行表明端口发送Inverse ARP请求,并携带本地IP地址192.168.75.4。

第五行表明端口收到Inverse ARP响应,对端地址为192.168.75.1,对应DLCI 200。

第六行表明端口将DLCI 200和192.168.75.1建立动态映射关系。

第七行表明端口发送LMI状态请求消息。

第八行表明端口收到LMI的状态响应消息。

第九行表明端口收到上层数据报文,DLCI为200。长度为84字节。

第十行表明端口通过DLCI 200发送该报文,长度为88字节。

第十一行表明端口在DLCI 200收到数据报文,长度为88字节。随后的两行是数据分组的具体信息。

第十四行表明端口将该报文上交给网络层(IP)。

第2章   X.25和LAPB配置命令

2.1  X.25和LAPB配置命令

使用本章的命令配置平衡型链路访问控制规程(LAPB)和X.25服务。X.25可以提供远程终端访问和封装IP协议等服务。

X.25和LAPB配置命令包括:

l   encapsulation x25

l   translate x25

l   translate tcp

l   x25 address

l   x25 alias

l   x25 cwla

l   x25 dbit

l   x25 ebackup

l   x25 htc

l   x25 idle

l   x25 incallcheck

l   x25 interface

l   x25 k

l   x25 map(pad)

l   x25 map(pvc)

l   x25 map(svc)

l   x25 mod 

l   x25 n1

l   x25 n2

l   x25 nps

l   x25 nui

l   x25 nws 

l   x25 pad-access

l   x25 psize

l   x25 pvc

l   x25 t1

l   x25 t2

l   x25 t20

l   x25 t23 

l   x25 tcp

l   x25 wsize

l   x25switch connect

l   x25switch destination

l   x25switch xot pvc

l   x25switch xot svc

l   x29 profile

l   clear x25

l   show x25

l   show x25 tcp

l   show x25 xot

l   show x25 vc

l   show x25switch 

l   show x29

l   debug lapb

l   debug x25

l   pad

2.1.1   encapsulation x25

将串行接口指定为X.25设备。no encapsulation x25取消X.25封装。

[no] encapsulation x25

参数

该命令没有参数或关键词。

命令模式

接口配置态

使用指南

X.25链路的一端必须是逻辑DCE,另一端必须是逻辑DTE(这种分配与接口硬件的DTE或DCE身份无关)。

示例

下例配置封装X.25协议:

Router_config#interface s1/0

Router_config_s1/0#encapsulation x25

相关命令

x25 map

2.1.2   translate x25

将x25封装到虚端口.

translate x25 x121-address virtual-template virtual-template-interface-number

参数

参数

参数说明

x121-address

可变长X.121 地址,该地址由X.25网络服务提供者分配。

Virtual-template-interface-number

逻辑虚模板的端口号。

缺省

无缺省值

命令模式

全局配置态

使用指南

X121 地址是X.25网络服务提供商分配的地址 + 一个子地址(可用于识别逻辑虚端口)。 在X121地址的长度不大于15位时,X25网络会将所有的地址信息传至目的地。由于该配置是将X25的vc映射到逻辑虚端口上,所以最大的虚连接数目受限于系统的最大虚端口数(路由器系统目前<300),与实际的X25虚连接是不一样的(最大每个物理端口可以配置4095条)。

示例

下例的配置将目的地址为12345611(123456+11)的X25报文送到由逻辑virtual-template 0 克隆而来的virtual-access逻辑端口(该端口是动态创建的),从而完成实际的通信过程。

Router_config# translate x25 12345611 virtual-template 0

2.1.3   translate tcp

translate tcp ip ip-address x25 x121address

配置x25-tcp交换。 

参数

参数

参数说明

x121-address

可变长X.121 地址,该地址由X.25网络服务提供者分配。

Ip-address

连接源端的ip地址 。

缺省

无缺省值

命令模式

全局配置态

使用说明:

X121 地址是X.25网络服务提供商分配的地址 + 一个子地址(可用于识别逻辑虚端口)。 在X121地址的长度不大于15位时,X25网络会将所有的地址信息传至目的地。(该功能未在正式版本中提供,目前仅限于部分试用版本)

示例

下例的配置将来自于192.168.20.130的tcp连接请求,转到目的地址为111的x25连接请求。从而建立x25-tcp的交换链路

Router_config# translate tcp ip 192.168.20.130 x25 111

2.1.4   x25 address

设置网络接口的X.121地址。

x25 addressx121-address

参数

参数

参数说明

x121-address

可变长X.121 地址,该地址由X.25网络服务提供者分配。

缺省

无缺省值

命令模式

接口配置态

使用说明

用户必须设置该参数才可正常工作。该地址必须同X.25网络服务提供商分配的地址匹配。

示例

下例设置接口的X.121地址:

Router#interface s1/0

Router_config_s1/0#encapsulation x25

Router_config_s1/0#x25 address 00000123005

2.1.5   x25 alias

配置接口的地址别名,该地址别名允许该接口用其它信宿地址接收呼叫。

[no] x25 alias  string

参数

参数

参数说明

string

设置一个本端口地址别名。

缺省

无别名

命令模式

接口配置态

使用说明

每个端口最多可设置8个地址别名。当呼入时,这些地址别名可起到与本地X.121地址相同的作用,呼出时,这些地址别名不起作用。

示例

下例中,串口1/0配置别名为12345:

Router#interface s1/0

Router_config_s1/0#encapsulation x25

Router_config_s1/0#x25 address 0000123

Router_config_s1/0#x25 alias 12345

2.1.6   x25 cwla

X.25呼叫请求分组中携带主呼地址。

[no] x25 cwla

参数

参数

参数说明

no

禁止出呼叫分组中携带主呼地址。

缺省

呼叫请求分组中携带主呼地址。

命令模式

接口配置态

使用说明

在X.25呼叫请求分组中主呼地址是可省略的,本命令指出呼叫时是否携带主呼地址。

示例

禁止出呼叫分组中携带主呼地址。

Router_config_s1/0#no x25 cwla

2.1.7   x25 dbit

设定是否允许D比特置位

[no] x25 dbit

参数

参数

参数说明

no

不允许D比特置位。

缺省

不允许D比特置位。

命令模式

接口配置态

使用指南

D比特可以在呼叫建立分组和数据分组中使用。目的是为了区分数据分组的确认是由X.25接口本地确认,还是由远端DTE进行确认。D=0表示由本地确认,D=1表示用远端DTE确认。

示例

允许D比特置位 。

Router_config_s1/0#x25 dbit

2.1.8   x25 ebackup

Ebackup功能用于对X.25或帧中继线路进行远端侦测,可不使用动态路由而实现备份方案。ebackup功能将对本接口的所有类型为ebackup的映射(map)地址进行远端主机状态监测。并将远端主机的状态报告给上层模块,实现多线路备份过程的稳定切换。

x25 ebackup seconds

参数

参数

参数说明

seconds

轮询时间间隔  1-65535(秒)。

命令模式

接口配置态

示例

下面是ebackup功能的典型配置:

Router_config_s1/0#x25 map 192.168.0.1 svc 1111 ebackup

Router_config_s1/0#x25 ebackup 30

2.1.9   x25 htc

要设置最大虚电路号,使用x25 htc 接口配置命令:

x25 htc circuit-number

参数

参数

参数说明

circuit-number

1~4095之间的虚电路号。缺省值为16。

缺省

16

命令模式

接口配置态

使用说明

htc值应大于pvc值。

示例

下例设置有效虚电路范围为25:

Router_config_s1/0#x25 htc 25

相关命令

要获得相关命令的文档信息,请使用主索引或在线搜索.

x25 pvc

x25 clear

2.1.10   x25 idle

指定路由器清除SVC之前的SVC空闲时间。

x25 idle seconds

参数

参数

参数说明

seconds

空闲周期。范围:0- 2147483647(秒)。 缺省为100秒,0秒表示不启用该定时器。

缺省

100秒

命令模式

接口配置态

使用说明

在X.25网上传输IP数据时,必须先建立X.25连接,然后才能传输IP数据报。如果一直有IP数据传输,X.25连接将不清除,一直保持着连接状态。因为X.25的收费是根据建立连接后所用的时间和传输的数据量的大小来计费的,所以从节省通信费用的角度来讲,一旦长时间没有IP数据报传输,应清除X.25连接。该参数即为指定无IP数据报时等待多长时间清除X.25连接。清除X.25连接后,下次有IP数据发送时,仍先自动建立X.25连接。

该参数设置为0时,意味着空闲周期无穷大。

示例

下例在清除空闲电路之前,设置5分钟等待周期:

Router_config#interface s1/2

Router_config_s1/2#x25 idle 300

相关命令

要获得相关命令的文档信息,请使用主索引或在线搜索。

2.1.11   x25 incallcheck

设置是否根据X.25映射表检查主叫地址。

[no] x25 incallcheck

参数

参数

参数说明

no

不检查呼叫的X.121地址。

缺省

根据X.25映射表检查主叫地址。

命令模式

接口配置态

示例

不检查呼叫的X.121地址。

Router_config_s1/1#no x25 incallcheck

2.1.12   x25 interface

指定本X.25端口是DTE还是DCE。

x25 interface [dte|dce]

参数

参数

参数说明

dte

指定本X.25端口是DTE 。

dce

指定本X.25端口是DCE。

缺省

dte

命令模式

接口配置态

使用说明

一个X.25连接,必须一端逻辑上为DCE,另一端逻辑上为DTE。通常,在连入公用分组交换网的时候,用户设备设为DTE,而分组交换机所在那一端设为DCE。

示例

设置端口为DCE方式。

Router_config_s1/1#x25 interface dce

2.1.13   x25 k

指定允许未处理的帧(称为窗口尺寸)最大数目。

x25 k window-size

参数

参数

参数说明

window-size

帧数。取值范围2~模尺寸-1。如果模为8,则最大帧计数为7;如果模为128,则最大帧数为127。缺省为7帧。

缺省

7帧

命令模式

接口配置态

使用说明

在协议处于连接状态时,如果改变窗口尺寸,将导致协议复位。

使用LAPB模128(扩展模式)时,在要求确认之前必须增加窗口参数k来发送更大数量的帧。增加窗口参数是在具有低差错率的高速链路上获得更大吞吐能力的基础。

这个值必须与X.25交换机中配置的值相匹配,不匹配将导致重复的LAPB拒绝(REJ)帧。

示例

下例设置LAPB窗口尺寸(k参数)为10帧:

Router_config_s1/0#x25 k 10

相关命令

要获得相关命令的文档信息,请使用主索引或在线搜索。

x25 mod

2.1.14   x25 map(pad)

设置可以通过pad访问路由器的源x121地址表:

[no] x25 map pad x121-address

参数

参数

参数说明

x121-address

X.121地址。

no

表示删除一条交换虚电路映射,否则为增加一条交换虚电路映射。

缺省

不设置。

命令模式

接口配置

使用说明

该表只有在配置了命令x25 pad-access才起作用……过滤来访的x121地址。

示例

下例配置了一个可以访问该路由器的X.121地址1234:

Router_config#interface s1/0

Router_config_s1/0#x25 map pad 1234

相关命令

x25 pad-access

show x25

2.1.15   x25 map(pvc)

使用x25 map接口配置命令设置LAN协议到远端主机的映射。按下面的命令增加或删除一条永久虚电路映射:

[no] x25 map ipaddress pvc pvc_no [broadcast] [ebackup]

参数

参数

参数说明

ipaddress

IP 地址。

pvc_no

DLCI号。

broadcast

表示该地址映射允许发送广播报文。

ebackup

表示该地址映射为增强备份类型。

no

表示删除一条交换虚电路映射,否则为增加一条交换虚电路映射。

缺省

不设置到远程主机的映射。

命令模式

接口配置态

示例

(1)       把s1/1口配成X.25,增加一条永久虚电路映射:130.130.0.1, pvc 16。

Router_config#interface s1/1

Router_config_s1/1#enca x25

Router_config_s1/1#x25 map 130.130.0.1 pvc 16

(2)       删除一条永久虚电路映射:130.130.0.1, pvc_no:16

Router_config_s1/0#no x25 map 130.130.0.1 pvc 16

相关命令

show x25

2.1.16   x25 map(svc)

设置LAN协议到远端主机的映射。按下面命令增加或删除一条交换虚电路映射:

[no] x25 map ipaddresssvc x121-address [broadcast] [ebackup]

参数

参数

参数说明

ipaddress

IP 地址。

x121-address

X.121地址。

broadcast

表示该地址映射允许发送广播报文

ebackup

表示该地址映射为增强备份类型。

no

表示删除一条交换虚电路映射,否则为增加一条交换虚电路映射。

缺省

不设置到远程主机的映射。

命令模式

接口配置

使用说明

当对方的X.121地址不定时(如对方通过X.32或拨号X.28入网), 应将对方的X.121地址配置为8个"0", 此时路由器不主动呼叫对方。

由于大多数数据报路由协议依靠广播或者组播来发送信息到其邻居,因此必须在X.25上使用broadcast关键词来运行这样的路由协议。

为了避免配置上的混乱,一个给定的协议/地址对不能在同一接口上用于多个映射。

示例

下例把IP地址172.20.2.5映射为X.121地址000000010300。broadcast关键词通过该接口把广播发送到指定的X.121地址:

Router_config#interface s1/0

Router_config_s1/0#x25 map 171.20.2.5 svc 000000010300 broadcast

相关命令

show x25

2.1.17   x25 mod

要指定LAPB和X25基本(模8)和扩展(模128)协议模式。

x25 mod modulus

参数

参数

参数说明

modulus

为8或128。8指定基本模式,128指定扩展模式,缺省为8。

缺省

模8

命令模式

接口配置态

使用指南

模参数决定使用基本模式还是扩展模式。基本模式在0~7之间对信息帧进行编号,而扩展模式在0~127之间对信息帧进行编号。基本模式使用比较广泛,并且对大多数链路来说已足够。扩展模式是可选的功能,该功能在差错率低的高速链路上能够获得较大的吞吐量。

LAPB操作模式可以在LAPB链路或X.25设置。X.25的模与LAPB层的模无关,链路两端必须使用相同的LAPB模。为简化配置,路由器将LAPB和X.25的模同时配置,即用这条命令可以同时配置LAPB和X25的操作模式,两者总是相同。

使用LAPB模128(扩展模式)时,在请求确认之前必须增加窗口参数k来发送更大数量的帧。增加窗口参数是在具有低差错率的高速链路上获得更大吞吐能力的基础。

在协议处于连接状态时改变窗口尺寸,会导致协议复位。

示例

下例使用LAPB扩展模式配置X.25链路:

Router_config#interface s1/1

Router_config_s1/1#encapsulation x25

Router_config_s1/1#x25 mod 128

Router_config_s1/1#x25 k 40

相关命令

要获得相关命令的文档信息,请使用主索引或在线搜索。

x25 k  

2.1.18   x25 n1

要指定最大帧长度(LAPB N1参数),使用x25 n1接口配置命令:

x25 n1 bytes

参数

参数

参数说明

Bytes

最大字节数,137-1512。

缺省

1500

命令模式

接口配置态

使用指南

改变LAPB N1参数的值并不能给接口MTU提供多大好处,并且如果配置错误,容易导致链路失败。建议保留该参数为缺省值。

X.25接收缺省分组大小和呼叫,该呼叫指定大于LAPB层支持的最大分组大小,但是协商位于可能支持的最大接口上的呼叫。对交换式呼叫,分组大小通过路由器进行端到端协商,所以呼叫不会超过所涉及的两个接口中任意一个接口的最大分组大小。

示例

设n1为136:

Router_config# interface s1/1

Router_config_s1/1# x25 n1 137

相关命令

要获得相关命令的文档信息,请使用主索引或在线搜索。

2.1.19   x25 n2

要指定数据帧传输的最大次数(LAPB N2参数),使用x25 n2 接口配置命令:

x25 n2 tries

参数

参数

参数说明

tries

传输计数。取值范围1~255,缺省为16次传输。

缺省

16次传输 。

命令模式

接口配置态

使用说明

N2一般应取5-16。

示例

下例设置N2为为50:

Router_config#interface s1/0

Router_config_s1/0#x25 n2 50

2.1.20   x25 nps

打开/关闭分组长度协商功能

[no] x25 nps

参数

参数

参数说明

no

禁止分组长度协商(出呼叫)。

缺省

禁止分组长度协商(出呼叫)

命令模式

接口配置态

使用说明

路由器在接收所有X.25入呼叫分组时,能处理分组中关于长度和窗口的有关协商参数,并能作出相应的处理。本参数主要是指出呼叫时是否带上协商参数。

示例

打开分组长度协商功能(出呼叫)。

Router_config_s1/1#x25 nps

2.1.21   x25 nui

要设定网络用户识别标识符(NUI)和口令(password),使用x25 nui 接口配置命令:

[no] x25 nui passwd&nui

参数

参数

参数说明

passwd&nui

口令和网络用户识别符,nui标准为8位

缺省

标准的X.25封装没有缺省值。

命令模式

接口配置

示例

设网络用户识别标示符为SHSHX000,口令为ABCDEF。

Router_config_s1/1#x25 nui ABCDEFSHSHX000

2.1.22   x25 nws

打开/关闭分组窗口尺寸协商功能。

[no] x25 nws

参数

参数

参数说明

no

禁止分组窗口尺寸协商(出呼叫)。

缺省

禁止分组窗口尺寸协商(出呼叫) 。

命令模式

接口配置态

使用说明

路由器在接收所有X.25入呼叫分组时,能处理分组中关于长度和窗口的有关协商参数,并能作出相应的处理。本参数主要是指出呼叫时是否带上协商参数。

示例

打开分组窗口尺寸协商功能(出呼叫)。

Router_config_s1/1#x25 nws

2.1.23   x25 pad-access

打开/关闭x25 pad 访问控制功能 。

[no] x25 pad-access

参数

参数

参数说明

no

禁止x25 pad 访问控制功能 。

缺省

禁止x25 pad 访问控制功能。

命令模式

接口配置态

使用指南

配置了该功能时,路由器在接收所有X.25 pad入呼叫分组时,将检查呼入源的x121地址,如果该地址在静态配置的pad映射表中,则接收该呼叫,否则拒绝。如果未配置pad映射表将拒绝所有的pad入呼叫.

示例

使能x25 pad 访问控制功能 。

Router_config_s1/1#x25 pad-access

2.1.24   x25 psize

设定X.25分组层分组大小,使用x25 psize接口配置命令:

x25 psize size

参数

参数

参数说明

size

分组层分组大小(单位为字节),范围为(128,256,512,1024)

缺省

缺省为128

命令模式

接口配置态

使用说明

修改psize的值时应注意使N1的值大于psize的值加8。

示例

修改psize为256 。

Router_config_s1/1#x25 psize 256

2.1.25   x25 pvc

要设置最大永久虚电路号,使用x25pvc 接口配置命令:

x25 pvccircuit-number

参数

参数

参数说明

circuit-number

1~1024之间的虚电路号,如果没有永久虚电路为0。缺省值为0。 上限值受到x25 htc命令的影响。

缺省

0

命令模式

接口配置态

使用指南

永久虚电路数应小于或等于虚电路总数。在下述配置下,各虚电路状态如下表:

虚电路

1

2

3

4

...

14

15

16

状态

pvc

pvc

svc

svc

...

svc

svc

svc

示例

下例设置有效永久虚电路范围:

Router_config#interface s1/0

Router_config_s1/0#x25 pvc 2

相关命令

x25 htc

x25 clear

2.1.26   x25 t1

要设置重发定时器周期(LAPB T1参数),使用x25 t1 接口配置命令:

x25 t1 seconds

参数

参数

参数说明

seconds

秒时间。取值范围1~64秒。缺省为3秒。

缺省

3

命令模式

接口配置态

使用说明

重发定时器决定传输帧能够保持多长时间不确认之后,LAPB软件才进行论询确认。LAPB协议设计规定如果在T1内没有收到确认,就假定帧已丢失。T1值太小可能导致重复控制信息,这可能严重中断服务。

示例

下例设置T1重发定时器为2秒:

Router_config#interface s1/0

Router_config_s1/0#x25 t1 2

2.1.27   x25 t2

要设置链路层接收超时计时器,使用x25 t2 接口配置命令:

x25 t2 seconds

参数

参数

参数说明

seconds

链路层接收超时秒数,范围为1至32。

缺省

1

命令模式

接口配置态

使用指南

DTE设备中T2的值可以与DCE中的T2值不同,但应通知对方。当T2计时器到时时,DTE(或DCE)必须发证实帧,使得对方DTE(或DCE)的T1计时器超时之前能接收到证实帧(T2<T1)。

示例

设置t2为2:

Router_config#interface s1/0

Router_config_s1/0#encapsulation x25

Router_config_s1/0#x25 t2 2

相关命令

要获得相关命令的文档信息,请使用主索引或在线搜索。

x25 n2

x25 t1

2.1.28   x25 t20

要设置DTE设备的重发定时器(T20),使用x25 t20命令:

x25 t20 seconds

参数

参数

参数说明

seconds

秒数,缺省为180秒。

缺省

180

命令模式

接口配置态

示例

下例设置T20定时器为90:

Router_config#interface s1/0

Router_config_s1/0#x25 t20 90

2.1.29   x25 t23

要设置DTE设备的清除请求重发定时器(T23),使用x25 t23 接口配置命令:

x25 t23 seconds

参数

参数

参数说明

seconds

秒数,缺省为180秒。

缺省

180

命令模式

接口配置态

示例

下例设置T23定时器为90秒:

interface s1/0

 x25 t23 90   

2.1.30   x25 tcp

配置x25-tcp 交换网关相关参数

x25 tcp user-data line

x25 tcp pkt-format [rfc1006|transparent|user]

x25 tcp iso-address line

x25 tcp pvc-cause-diag  cause diag

x25 tcp pvc-rst-timeout time-value

参数

参数

参数说明

Line

十六进制的字串格式。

Rfc1006

按rfc1006格式进行报文交换。

Trans-parent

按透明方式进行报文交换 。

user

按特定用户自定义格式进行报文交换 。

pvc-cause-diag

采用X25-TCP的pvc方式时,pvc reset报文的原因码和诊断码 。

pvc-rst-timeout

未收到第二个pvc reset之前的等待时间 。

缺省

user-data          缺省为空

pkt-format         缺省为rfc1006   

iso-address       缺省为空  

pvc-cause-diag    缺省为0,0

pvc-rst-timeout    缺省为60s

命令模式

接口配置态

使用说明

user-data 的配置根据目标交换机的配置要求来确定。Pkt-format中的user实现的是特定用户的需求,一般不要设置该选项。对iso-address而言,有些交换机需要有些不需要,缺省是未设置。 不同类型的交换机对建立pvc连接采用的原因码和诊断码可能不同,可以用命令x25 pvc pvc-cause-diag来配置。不同类型的交换机需要pvc reset过程的次数可能不一样,对一次reset过程,可以将pvc-rst-timeout设为最短(1s),对于两次reset过程,可以将pvc-rst-timeout设为最长(255s)来确保第二次reset过程。

示例

下例配置用户数据为“10300025”,该数据在x25建链时,将携带在setup报文中。

config_s1/1#x25 tcp user-data 10300025

2.1.31   x25 wsize

设定X.25分组层窗口尺寸,使用x25 wsize 接口配置命令:

x25 wsize packets

参数

参数

参数说明

packets

分组层窗口尺寸大小 ,范围为2至 wsize模数-1。

缺省

缺省为2

命令模式

接口配置态

使用说明

模8时该参数取值2-7,模128时该参数取值2-127。

示例

修改wsize为5。

config_s1/1#x25 wsize 5

2.1.32   x25switch connect

在X.25交换表中增加/删除一条永久虚电路(PVC)连接路由,使用x25switch connect接口配置命令:

[no] x25switch connect port1 port1_pvc_no port2 port2_pvc_no

参数

参数

参数说明

port1

PVC交换的第一个端口。

port1_pvc_no

第一个端口的PVC号。

port2

PVC交换的第二个端口。

port2_pvc_no

第二个端口的PVC号。

no

表示删除一条PVC连接路由,否则表示添加

缺省

命令模式

全局配置态

使用指南

配置交换表时,连接的两个端口必须封装成X25,而且存在有效的永久虚电路。

示例

把s1/0,s1/1端口设置成X25,设置它们的PVC数为2,在X.25交换表中增加PVC连接,在s1/0口的第一条pvc与s1/1口的第一条pvc之间交换分组。

Router_config#int s1/0

Router_config_s1/0#enca x25

Router_config_s1/0#x25 pvc 2

Router_config_s1/0#quit

Router_config#int s1/1

Router_configs1/1# enca x25

Router_config_s1/10#x25 pvc 2

Router_config_s1/1#quit

Router_config#x25sw connect s1/0 1 s1/1 1

2.1.33   x25switch destination

在X.25(SVC)交换表中增加/删除一条端口寻址:

[no] x25switch destination [x121addr|default] port

参数

参数

参数说明

x121addr

X121地址(可用“*”表示0-9)。

default

保留字,指所有未指明的X.121地址。

port

封装为X.25的端口。

no

表示删除一条PVC连接路由,否则表示添加。

缺省

无缺省值

命令模式

全局配置态

使用指南

配置交换表时,交换端口必须封装成X.25。

示例

把s1/0,s1/1端口设置成X.25,在X.25交换表中增加SVC连接:1111->s1/0,2222->s1/1,则两台主机可通过呼叫1111,2222直接在X.25上进行通信,同时也可完成IP报文交换。

Router_config#int s1/0

Router_config_s1/0#enca x25

Router_config_s1/0#x25 interface dce

Router_config_s1/0#quit

Router_config#int s1/1

Router_config_s1/1#enca x25

Router_config_s1/1#x25 interface dce

Router_config_s1/1#quit

Router_config#x25sw destination 1111 s1/0

Router_config#x25sw destination 2222 s1/1

2.1.34   x25switch xot pvc

该命令用来配置基于PVC 的X25 Over Tcp。

参数

参数

参数说明

local-interface

本地接口。

local-pvc-number

本地PVC号。

remote-interface

远端的接口。

remote-pvc-number

远端的PVC号。

remote-ip-address

远端的ip地址。

source interface

原端口。

缺省

无缺省值

命令模式

全局配置态

使用指南

先配置的一端,无法建立TCP连接,必须等到另一端配置后,由另一端发起连接请求,从而建立连接。配置该命令时,应该注意两端PVC号及IP地址的交叉。

示例

下例的配置将本地的serial1/0上PVC 2上的X25报文通过TCP发送至远端192.168.20.92,报文在远端将被转发至serial 1/0上的PVC 3。

Router_config#x25switch xot pvc serial 1/0 2 serial 1/0 3 192.168.20.92

相关命令

show_x25_xot

debug_x25

2.1.35   x25switch xot svc

该命令用来配置基于SVC 的X25 Over Tcp。

参数

参数

参数说明

X.121-address

远端的X.121地址。

remote-ip-address

远端的IP地址。

source interface

原端口。

缺省

    无缺省值

命令模式

全局配置态

使用指南

本地配置后,当接收到向目的远端(X.121-address)的呼叫时,TCP连接才建立;当取消配置或收到了清除连接的消息时,TCP连接断开。

示例

下例的配置将接收到的向目的地1760001的呼叫,通过TCP连接转发到远端192.168.20.92

Router_config#x25switch xot svc 1760001 192.168.20.92

相关命令

show_x25_xot

debug x25

2.1.36   x29 profile

配置pad操作所使用的x3相关参数。

x29 profile default [[x3-param:x3-value]…]

x29 profileprofile-number [[x3-param:x3-value]…]

参数

参数

参数说明

Default

配置x29d使用的x3参数。

profile-number

配置指定profile号码的x3参数。

x3-param

X3参数序号。

x3-value

X3参数值。

缺省

x29和 x29d的x3参数相同:

1:1    2:1    3:66   4:0    5:0    6:5    7:0    8:0    9:0   10:0   11:14

12:0   13:0   14:0   15:1   16:0   17:0   18:0   19:0   20:0   21:0   22:0

命令模式

配置态

使用说明

配置过程中可以输入任意多个参数值对,相同的参数序号,采用最后一次出现的。

示例

Router_config# x29 profile default 3:2  

2.1.37   clear x25

清除某一X.25交换虚电路(SVC)。

clear x25 portvc-number

参数

参数

参数说明

port

x.25端口号。

vc-number

1~1024之间的SVC编号。(此为默认值,该范围上下限分别由x25 pvc 和 x25 htc决定)。

命令模式

接口配置态

使用指南

该命令形式用于强制终止个别电路上的服务。

示例

下面的命令清除s1/0端口的1号SVC:

Router#clear x25 s1/0 1

2.1.38   show x25

显示x25的版本信息。

show x25

参数

该命令没有参数或关键词。

命令模式

管理态

使用指南

show x25命令显示下面的信息:

l   x25 的版本信息;

l   XOT的版本信息;

示例

下面是show x25命令的实例输出:

Router# show x25

X.25 software, Version 2.0.1d

XOT software, Version 1.0.1d 

2.1.39   show x25 tcp

显示已建立连接的x25-tcp信息。

show x25 tcp

参数

该命令没有参数或关键词。

命令模式

管理态

使用说明

show x25 tcp 命令显示下面的信息:

l   已建立的x25-tcp PVC交换信息;

l   已建立的x25-tcp SVC交换信息;  

(该功能未在正式版本中提供,目前仅限于部分试用版本)

示例

下面是show x25 tcp命令的实例输出:

Router#show x25 tcp

Serial1/0 PVC 1: Connected

  TCP: [192.168.20.73,2000/192.168.20.70,1672]

  X25: Is521/0, Os1/0

  TCP: Is1/525, Os1/0

Serial1/0 SVC 3: From 1111 Connect To 4444

  TCP: [192.168.20.73,2000/192.168.20.70,3840]

  X25: Is2084/0, Os1/0

  TCP: Is1/2100, Os1/0

2.1.40   show x25 xot

显示已配置xot的信息。

show x25 xot

参数

该命令没有参数或关键词。

命令模式

管理态

使用指南

show x25 vc 命令显示下面的信息:

l   已配置的XOT PVC交换路由信息。

l   在用的XOT SVC交换路由信息;

示例

下面是show x25 xot命令的实例输出:

Router#show x25 xot

Serial1/0 SVC 1024, Interface: [192.168.20.78,20011/192.168.20.92,1998]

Connects From 2750 To 1760001

Window size input: 2, output: 2

Packet size input: 128, output: 128

Is 11/6 RESETs 1/0 RNRs 0/0 REJs 1/0 INTs 1/0 Discards 0/0

2.1.41   show x25 vc

显示已配置X25交换表的信息。

show x25 vc

参数

该命令没有参数或关键词。

命令模式

管理态

使用说明

show x25 vc 命令显示下面的信息:

l   已配置的X.25 PVC交换路由表;

l   已配置的X.25 SVC交换路由表;

l   已配置的X.25 XOT交换路由信息;

示例

下面是show x25 vc命令的实例输出:

Router#show x25 vc

X.25/IP state Serial1/0 DOWN Serial1/1 UP =======================================================================

No. Port VC I/O State X.121 Address IP Address XOT =======================================================================

01 Serial1/1 11 in clr_out 0.0.0.0 

2.1.42   show x25switch

显示已配置X25交换表的信息。

show x25switch

参数

该命令没有参数或关键词。

命令模式

管理态

使用指南

show x25 switch命令显示下面的信息:

l   已配置的X.25 PVC交换路由表;

l   已配置的X.25 SVC交换路由表;

示例

下面是show x25switch命令的实例输出:

Router#show x25switch

X.25 switch SVC route table

X.121 address         port

==============================================

1111       -->    Serial0/0

2222       -->    Serial0/1 

2.1.43   show x29

显示所有x29 profile的配置信息。

show x29

参数

该命令没有参数或关键词。

命令模式

管理态

使用说明

show x29命令显示下面的信息:

l   x29d 的profile信息;

l   x29的所有profile信息;

示例

下面是show x29命令的实例输出:

Router#show x29

X.29d X3 pad parameters:

 1:1    2:1    3:66   4:0    5:0    6:5    7:0    8:0    9:0   10:0   11:14

 12:0   13:0   14:0   15:1   16:0   17:0   18:0   19:0   20:0   21:0   22:0 

X.29 X3 pad Profile 0:

 1:1    2:1    3:66   4:0    5:0    6:5    7:0    8:0    9:0   10:0   11:14

 12:0   13:0   14:0   15:1   16:0   17:0   18:0   19:0   20:0   21:0   22:0 

X.29 X3 pad Profile 1:

  1:1    2:1    3:66   4:0    5:0    6:5    7:0    8:0    9:0   10:0   11:14

 12:0   13:0   14:0   15:1   16:0   17:0   18:0   19:0   20:0   21:0   22:0 

2.1.44   debug lapb

显示LAPB交互信息。例如发出SABM帧,收到UA帧,发出I帧,收到I帧等。当路由器和主机无法通过X.25协议进行通信时,可以用于分析LAPB交互情况。。

[no] debug lapb [iframes | sframes| uframes | raw] Serial

参数

参数

参数说明

Serial

需要打开debug信息的端口名。该端口可以是物理端口或E1映射的端口。

Iframes

只显示I帧。

Sframes

只显示S帧。

Uframes

只显示U帧。

raw

显示收发的原始帧。

如果不输入端口名,将打开所有X.25端口的LAPB的调试信息。

命令模式

管理态  

使用说明

关于debug x25 tcp 的相关命令未在正式版本中提供,目前仅限于部分试用版本。

示例

(1)       显示s1/1所有收发的帧。

Router#debug lapb s1/1 uframes s1/0

Router#debug lapb s1/1 iframes s1/0

Router#debug lapb s1/1 sframes s1/0

LAPB Serial1/1: TX -> SABM abyte=01 cbyte=3f P=1

LAPB Serial1/1: RX <- UA abyte=01 cbyte=73 F=1

LAPB Serial1/1: TX -> I(0,0) abyte=01 cbyte=00 P=0

LAPB Serial1/1: RX <- RR(1) abyte=01 cbyte=21 PF=0

LAPB Serial1/1: RX <-I(0,1) abyte=03 cbyte=20 P=0

LAPB Serial1/1: TX -> RR(1) abyte=03 cbyte=21 PF=0

第一行表明LAPB发出一个SABM帧,其地址字段为01(DCE),控制字段为3f,置探询位。

第二行表明LAPB收到UA响应帧,其地址字段为01(DTE),控制字段为73,置响应位。这意味着双方X.25协议握手成功。

第三行表明LAPB发出一个I帧,其发送序号为0,接收序号也为0。该帧中的具体信息,应查看X.25的debug。

第四行表明LAPB收到RR响应帧,表明已收到发送序号为1以前的帧。

第五行表明LAPB收到I帧,其发送序号为0,接收序号为1。

第六行表明LAPB发送RR响应帧,表明已收到发送序号为1以前的帧。

(2)       不显示s1/1口LAPB U帧的交互信息。

Router#no debug lapb uframes s1/1

2.1.45   debug x25

显示X.25层交互信息。例如发出重新启动请求,收到拆线请求,收到数据分组,发出复位请求等。当路由器和主机无法通过X.25协议通信时,可以用于分析X.25交互情况。用no debug x25停止显示信息。

[no] debug x25 [events | normal | packet | tcp |xot] Serial

参数

参数

参数说明

serial

需要打开debug信息的端口名。该端口可以是物理端口或E1映射的端口。

events

显示所有呼叫,拆线,重启,复位,诊断和登记分组。

normal

显示所有数据分组。

packet

显示所有X25报文的HEX格式。

tcp

显示X25-TCP建、拆连接消息,链路状态以及数据报文。

Xot

显示所有收到的xot的数据包(该命令不针对端口,为全局型)

如果不输入端口名,将打开所有X.25端口的X.25的调试信息。

命令模式

管理态

示例

Router#debug x25 events s1/0

X25 Serial1/0: TX -> RESTART, cause 0, diag 0

X25 Serial1/0: RX <- RESTART CONFIRM

X25 Serial1/0: TX -> CALL on vc 1, From: 2222 To: 1111

X25 Serial1/0: RX <- CLEAR on vc 1, cause 0, diag 47

X25 Serial1/0: TX -> CLEAR CONFIRM on vc 1, cause 8, diag 68

第一行表明端口发出重新启动请求分组,原因为0,诊断码为0。

第二行表明端口收到重新启动证实分组。

第三行表明端口发出建立链接请求,虚电路号为1,主呼地址为2222,被呼叫地址为1111,不设D比特,呼叫群组为0。第四行是分组的详细信息。

第四行表明端口收到清除虚电路请求,虚电路号为1,原因为0,诊断码为47。

第五行表明端口发送清除虚电路确认,虚电路号为1,原因为8,诊断码为68。

2.1.46   pad

要登录到PAD,使用pad用户EXEC命令:

pad svc x121-address [profile-number [r|w]]

pad pvc interface-number pvc-number [profile-number [r|w]]

参数

参数

参数说明

svc

采用svc进行呼叫。

pvc

采用pvc进行pad操作。

x121-address

指定X.25主机的X.121地址。

Interface-number

指定pvc pad的端口。

Pvc-number

Pad采用的pvc 号。

profile-number

采用该profile提供的x3参数进行应答请求。

r

Profile提供的x3参数为只读。

w

Profile提供的x3参数可读写。

命令模式

用户态或管理态

使用说明

可以同时让几个PAD连接打开并在它们之间进行切换,也可以在任意地点退出连接并返回用户模式提示符。

要退出会话,简单地终止同远端系统的连接,然后输入exit命令终止活跃会话。

PAD模式是用大于号(>)路由器提示符标识的,进入该模式后,就可以使用标准的PAD用户界面(除了转义序列外)。可以从该界面使用X.3参数配置PAD设备或者访问X.25。

在PAD模式中,可以使用标准或者扩展命令设置PAD命令信号。例如,可以输入clrclear命令清除虚呼叫。用标准命令语法指定的命令只是扩展语法版本的缩写版。

采用pvc的pad操作,以发送reset request报文开始一个会话,以发送或收到reset 报文结束一个会话。

表 2‑1 列出了在标准和扩展命令语法中均可用的命令

标准语法

描述

Clr

清除虚呼叫。

Help

显示帮助信息。

Int

发送中断分组。

par? Par

显示本地参数当前值(参见表 2)。

Prof

装载一个标准或者命名轮廓值。

Reset

复位呼叫。

Set

改变本地参数值(参见表2)。

Set?

改变然后读取参数值。

Stat

请求联接状态。

Quit

退出PAD连接。

下表列出了在PAD 模式中使用set parameter-number new-value PAD 命令信号可以设置的不同参数类型。

表 2‑2 PAD参数 

参数号

功能

参数值

描述

1

PAD状态轮换字符

使用一个字符转换PAD状态。 最小值:0;最大值::126; 缺省值::1

2

本地回送

0

无本地回送(缺省为入PAD连接)

1

本地回送开启(缺省为出连接)

最小值:0最大值:1;缺省值:1

3

数据转送字符

0

None---无数据转发字符。

1

阿拉伯数字字符

2

回车<CR> (缺省为出连接)

4

ESCAPE、BEL、ENQ或 ACK

8

DEL、CAN或 DC2

16

ETX 或EOT

32

HT、 LT、VT或 FF所有其它字符

64

转发字符的数据选择:最小值: 0;最大值: 255;缺省值:126

4

空闲计时器时延

0

无定时器,不起作用

1-255

时延值,单位为50ms(两种连接类型的缺省值为1)。

空闲计时器延迟选择最小值:0; 最大值:25; 缺省值:0。

5

辅助设备控制

在数据传输阶段,传输控制终端和数据流的流量控制字符 辅助设备控制最小值::0;最大值:2; 缺省值:1

6

服务信号控制

不支持。PAD服务信号控制。 最小值:0;最大值:255;缺省值:2

7

接收来自DTE的Break 信号后的操作

0

收到中止<Break>信号后,PAD不产生任何操作。

1

发送中断分组通知远端DTE或远端产生中止信号 的PAD

2

传输复位分组复位虚电路。

4

向远端DTE或者PAD发送X。29中止(缺省为出连接)。

8

脱离数据传输阶段,进入等待命令状态。

16

放弃向本地终端输出,设置参数8为1。

21

有效组合(1+4+16) (缺省为入连接)。

PAD收到中止信号后的操作。 最小值: 0;最大值::31; 缺省值:2。

8

放弃输出

0

以正常方式向本地终端发送数据(缺省为出连接)。

1

放弃向本地终端输出数据;由参数7设置。最小值:0;最大值:1; 缺省值 0

9

回车字符之后的填充

PAD接收到(来自远端DTE)回车<CR>字符之后是否要提供填充字符(插入过滤字符)。 回车后添加的字节数。 最小值::0;最大值:255;缺省值:2

10

行折

不支持。

11

接口二进制速率

10 5 9 0 1 6 8 2 4 3 7 11 12 13 14 15 16 17 18

50 波特 75波特 100 波特 110 波特 134.5 波特 150 波特 200 波特 300 波特 600波特 1200 波特 1800 波特 75/1200波特 2400 波特 4800 波特 9600 波特 19200 波特 48000 波特 56000 波特 64000波特 起止式DTE的二进制速率 最小值::0;最大值:18; 缺省值:14

12

由DTE执行流量控制

该参数决定在数据传输阶段起止式终端是否可以 向PAD传输XON/XOFF字符 PAD流量控制。最小值: 0; 最大值: 1; 缺省值: 1

13

回车字符之后插入换行

0 1 2 4

<CR>之后不插入<LF>(缺省为出连接) 在发往终端的<CR>之后插入<LF> 在来自终端的<CR>之后插入<LF> 在发送到终端的回送<ECHO>数据的<CR>之后插入<LF> 回车之后插入换行 最小值: 0;最大值: 7; 缺省值: 0。

14

换行填充

该参数决定在数据传输阶段向终端发送<LF>字符之后由PAD插入的<LF>字符的数量。 最小值: 0; 最大值: 255; 缺省值: 0。

15

本地编辑

0 1

不提供编辑功能。 提供编辑功能 最小值: 0; 最大值: 1; 缺省值: 0

16

字符删除

0-127

选择一个ASCII字符, 缺省为ASCII 127 (Del) 最小值: 0; 最大值: 127;缺省值: 127。

17

行删除

0-127

缺省情况 is选择一个ASCII字符 缺省为 ASCII 21 (Ctrl-U)。 最小值: 0; 最大值: 127; 缺省值: 24。

18

行显示

0-127

选择一个ASCII字符, 缺省为ASCII 18 (Ctrl-R)。 最小值: 0; 最大值: 127; 缺省值: 18。

19

编辑PAD服务信号

不支持。 最小值: 0; 最大值: 126; 缺省值: 2。

20

回送屏蔽

不支持。 最小值: 0; 最大值: 255; 缺省值: 0。

21

奇偶处理

不支持

22

页等待

不支持

(1)       600是依赖于Pad类型的值的第一个;

(2)       275为来自PAD; 1200为发往PAD。

缺省

对PAD出连接而言,X.3参数的缺省值如下:

2:1, 3:2, 4:1, 7:4, 16:127, 17:21, 18:19

所有其它参数缺省值为0,但是用set命令可以改变这些参数。

对入PAD连接而言,软件发送X。29 SET PARAMETER分组仅设置下面的参数:

2:0, 4:1, 7:21, 15:0

示例

下例启动一个PAD会话:

Router A# pad 123456789

Trying 123456789…Open

Router B>     

相关命令:

x29 profile

show x29

第3章   PPP配置命令

本章中的命令为路由器上的拨号式广域网连接配置PPP。

关于在路由器上配置PPP的信息,请参考“配置PPP”一章。

关于PPP的更多信息,请参考RFC 1661。关于MLP的更多信息,请参考RFC 1717。

关于PAP的更多信息,请参考RFC 1334。关于CHAP的更多信息,请参考RFC 1994。

3.1  PPP配置命令

PPP配置命令包括:

l   encapsulation ppp

l   interface multilink

l   interface virtual-tunnel

l   ip local pool

l   multilink bundle-name

l   multilink-group

l   multilink max-fragments

l   multilink max-links

l   multilink min-links

l   peer default ip address

l   peer neighbor-route

l   ppp account

l   ppp authentication

l   ppp authorization

l   ppp callback

l   ppp chap echo

l   ppp chap hostname

l   ppp chap refuse

l   ppp ddr

l   ppp ipcp rfc-default

l   ppp lcp echo

l   ppp lcp enddisc-type

l   ppp lcp rfc-default

l   ppp lcp [ close | listen | open ]

l   ppp max-bad-auth

l   ppp multilink

l   ppp pap refuse

l   ppp pap sent-username

l   ppp timeout authentication

l   ppp timeout ncp

l   ppp timeout lcp

l   show ip local pool

l   show ppp

l   username

l   debug ppp

3.1.1   encapsulation ppp

在串行接口或ISDN接口上,设置PPP封装,可使用接口配置命令encapsulation ppp。使用no encapsulation ppp 可取消PPP封装。

encapsulation ppp

no encapsulation ppp

参数

缺省

在异步串行接口使用PPP封装,在同步串行接口使用HDLC封装。

命令模式

接口配置态

使用说明

要使用PPP封装,路由器必须用IP路由协议配置。

示例

下面例子在串行接口serial 1/0激活PPP封装:

!

interface s1/0

encapsulation ppp

!

相关命令

ppp authentication

3.1.2   interface multilink

为了创建一个multilink bundle或者进入mutlink 接口配置态 ,使用命令interface multilink。使用no interface multilink删除该接口。

interface multilink group-number

no interface multilink

参数

参数

参数说明

group-number

Multilink bundle 的号码。

缺省

没有配置该接口

命令模式

全局配置态

使用说明

该命令首次出现在版本1.2.4中。

multilink接口首次创建时,缺省情况下自动封装为PPP协议,并启用multilink。

示例

下面例子为创建multlink bundle 1,并配置IP地址。

interface multilink 1

ip address 192.168.20.100 255.255.255.0

相关命令

multilink-group 

3.1.3   interface virtual-tunnel

为了创建一个client和NAS合并在一起的VPDN,使用命令interface virtual-tunnel。使用no interface virtual-tunnel删除该接口。

interface virtual-tunnel interface-number

no interface virtual-tunnel

参数

参数

参数说明

interface-number

Virtual-tunnel 的号码。

缺省

没有配置该接口

命令模式

全局配置态

使用说明

Virtual-tunnel接口首次创建时,缺省情况下自动封装为PPP协议,并在特殊情况下触发VPDN连接。

示例

下面例子为创建virtual-tunnel 1,并配置IP地址。

!

interface virtual-tunnel 1

ip address 192.168.20.100 255.255.255.0

!

相关命令

ppp ddr 

3.1.4   ip local pool

使用全局配置命令ip local pool配置一个本地地址池,将IP地址分配给那些连接点到点接口的远端。使用no ip local pool 删除一个本地地址池。

ip local pool {default | pool-namebegin-ip-address[ip-address-number]}

no ip local pool {default | poolname}

参数

参数

参数说明

default

在没有命名其它地址池时使用的缺省本地地址池。

pool-name

指定的本地地址池名字。

begin-ip-address

地址池中的起始IP地址。

ip-address-number

(可选的)地址池中的IP地址的数目。如果参数中不包含这个值,那么地址池中仅仅有地址begin-ip-address。每个地址池中最多可含有1024个IP地址。

缺省

没有配置地址池

命令模式

全局配置态

使用说明

使用命令ip local pool生成一个或多个本地地址池,当有一个主机拨入时从这些地址池中为它分配一个IP地址。要在接口上使用某个命名的地址池,使用接口配置命令peer default ip address pool。

使用show ip local pool命令可以查看地址池。

示例

下面例子生成了一个名为mypool的本地IP地址池,所包含的IP地址范围从172.16.23.0到172.16.23.255:

ip local pool mypool 192.168.23.0 255

相关命令

show ip local pool

3.1.5   multilink bundle-name

multilink bundle-name name-method

no multilink bundle-name

参数

参数

参数说明

authenticated

使用远端认证所使用的用户名命名。

both

使用远端认证所使用的用户名和其端点标示命名。

endpoint

使用远端端点标示命名(远端端点标示由PPP在 LCP 协商时获取)。

缺省

使用远端认证所使用的用户名。

命令模式

全局配置态

使用说明

命令multilink bundle-name用于指定multilink bundle的命名方式。该命令的no形式,用于恢复的缺省的命令方式。

示例

下面例子使用远端认证所使用的用户名和其端点标示命名机制命名bundle:

multilink bundle-name both

相关命令

interface multilink

ppp multilink

multilink virtual-template

3.1.6   multilink-group

为了指定一个接口作为multilink 专线bundle的一部分,在接口配置态下使用命令multilink-group。

使用该命令的no形式,用于将接口从bundle中删去。

multilink-group group-number

no multilink-group

参数

参数

参数说明

group-number

Multilink bundle 的号码

缺省

未启用

命令模式

接口配置态

使用说明

使用该命令指定到同一个bundle中的所有接口必须具用相同的带宽。使用multilink-group命令时,如果相应的multilink 接口尚没有被创建,其将自动创建一个multilink接口。使用multilink-group命令后,在该接口上所有PPP的命令不再可以进行配置,而是由multilink interface自动克隆到其上直到解除该命令。如此其该接口上的配置将会始终与指定的multilink 接口上的配置同步。

示例

下面例子将serial1/0作为multilink bundle 1的一部分。

!

interface serial1/0

encapsulation ppp

multilink-group 1 

!

相关命令

interface multilink

3.1.7   multilink max-fragments

为了指定multlink bundle接口上每个传输报文的最大分片数目,在接口配置态下使用命令multilink max-fragments。使用该命令的no形式,用于将最大分片数目恢复缺省值。

multilink max-fragments fragment-number

no multilink-group

参数

参数

参数说明

fragment-number

分片数目(1 – 16)。

缺省

16

命令模式

接口配置态

使用说明

使用该命令仅仅应用于与multilink 相关的虚端口。

示例

下面例子将接口multilink 1上的最大分片数目设置为10。

!

interface multilink 1

multilink max-fragments 10 

!

相关命令

interface multilink

interface virtual-template

interface dialer

3.1.8   multilink max-links

为了指定multlink bundle接口上链路数目的上限,在接口配置态下使用命令multilink max-links。使用该命令的no形式,用于将链路数目上限恢复缺省值。

multilink max-links link-number

no multilink-group

参数

参数

参数说明

links-number

分片数目(1 – 255).

缺省

255

命令模式

接口配置态

使用说明

使用该命令仅仅应用于与multilink 相关的虚端口。

示例

下面例子将接口multilink 1上的链路数目上限设置为100。

!

interface multilink 1

multilink max-links 100

!

相关命令

interface multilink

interface virtual-template

interface dialer

user username user-maxlinks

3.1.9   multilink min-links

为了指定multlink bundle接口上链路数目的下限,在接口配置态下使用命令multilink min-links。使用该命令的no形式,用于将链路数目下限恢复缺省值。

multilink min-links link-number

no multilink-group

参数

参数

参数说明

links-number

分片数目(0 – 255)。

缺省

0

命令模式

接口配置态

使用说明

使用该命令仅仅应用于与multilink 相关的虚端口。

示例

下面例子将接口multilink 1上的链路数目下限设置为2。

!

interface multilink 1

multilink min-links 2

!

相关命令

interface multilink

interface virtual-template

interface dialer

3.1.10   peer default ip address

使用接口配置命令为连接该接口的远端指定一个IP地址或者是从某个IP地址池或DHCP机制得到IP地址。使用no peer default ip address取消原先在接口上的远端IP地址池配置。

peer default ip address {ip-address | dhcp| pool [pool-name]}

no peer default ip address

参数

参数

参数说明

ip-address

为接口上拨入的远端分配一个IP地址。为了防止在接口上分配了重复的IP地址,这个参数不能用于dialer rotary group和ISDN接口。

dhcp

通过DHCP协议交互为对方分配一个IP地址。

pool

如果没有指定pool-name,就使用ip address-pool定义的全局缺省机制。

pool-name

(可选的) 使用ip local-pool 命令生成的本地地址池名,从该地址池中取得一个地址,而忽略全局缺省机制的设置。

缺省

没有配置地址池

命令模式

接口配置态

使用说明

管理员可以使用这条命令对每个接口配置所有可能的地址池机制。

(1)       对于那些没有用peer default ip address机制进行配置的接口,路由器将使用ip address-pool命令定义的全局缺省机制。

(2)       如果使用了peer default ip address pool pool-name,路由器将在接口上使用这个本地配置的地址池。而忽略任何地址池。

(3)       如果使用了peer default ip address ip-address,这个指定的IP地址将分配给与接口相连的远端,而忽略任何全局缺省机制。

示例

下面例子指定接口使用名为mypool的本地IP地址池。

peer default ip address pool mypool

下面例子指定接口使用IP地址192.168.3.29 。

peer default ip address 192.168.3.29

下面例子指定接口重新使用全局缺省机制。

peer default ip address pool

相关命令

encapsulation ppp

ip local pool

3.1.11   peer neighbor-route

在接口配置态下,使用命令peer neighbor-route可在已取消生成主机路由的缺省行为的接口上重新激活主机路由的生成。使用no peer neighbor-route给点到点接口上的对端取消生成邻居路由的缺省行为。

peer neighbor-route

no peer neighbor-route

参数

该命令无关键词或参数

缺省

在PPP IPCP协商完成之后,生成一条路由指向点到点接口的远端地址。

命令模式

接口配置态

使用说明

仅仅当缺省行为在你的网络中造成问题时,使用命令no peer neighbor-route。

示例

下面例子在接口上重新激活缺省行为 。

peer neighbor-route

3.1.12   ppp account

使用接口配置命令ppp account指定接口上使用ppp计费功能,使用no ppp account 取消计费。

ppp account

no ppp account

参数

缺省

不进行PPP计费。

命令模式

接口配置态

使用说明

计费功能被激活后,在连接建立和断开的时候会把统计信息发送给用户管理模块进行计费(一般来说是用radius服务器),并在用户管理模块得到统计后的计费信息。

示例

下面例子在接口s1/0上激活了计费功能 。

!

interface s1/0

encapsulation ppp

ppp account

!

相关命令

aaa authentication ppp

encapsulation ppp

username password

3.1.13   ppp authentication

使用接口配置命令ppp authentication指定接口上使用CHAP或PAP协议的次序,使用no ppp authentication 取消认证。

ppp authentication {chap|ms-chap|pap}[[list-name|default][callin]

no ppp authentication

参数

参数

参数说明

chap

在串行接口上激活CHAP

pap

在串行接口上激活PAP

ms-chap

在串行接口上激活MS-CHAP

list-name

(可选的)与AAA/TACACS+一起使用,指定执行认证时使用的TACACS+方法列表名。如果没有指定列表名,系统将使用缺省列表。使用命令aaa authentication ppp创建列表。

default

(可选的)与AAA/TACACS+一起使用。使用命令aaa authentication ppp 创建缺省缺省列表。

callin

(可选的)指定仅对收到的呼叫(calls)进行认证。

进行PPP认证时,chap、ms-chap和 pap三者必选其一,或者三者任意组合。

缺省

不进行PPP认证。

命令模式

接口配置态

使用说明

一旦你激活了CHAP、MS-CHAP和PAP认证中的一个、两个或者全部激活,本地路由器在允许远端设备传送数据之前,要求对其身份进行验证。

(1)       PAP认证要求远端设备发送一个名字/口令对,来检验在本地用户数据库或者远程TACACS/TACACS+数据库中是否有一个匹配项。

(2)       CHAP认证发送一个challenge给远端设备,远端设备必须使用公有密钥对challenge进行加密并把加密结果和自身名字以response报文的形式返回给本地路由器。本地路由器使用远端设备名字在本地用户数据库或者远程TACACS/TACACS+数据库中查找到相应的密钥,用它对最初challenge进行加密,并验证该加密结果是否与远端设备返回的结果相同。

你可能以任何次序激活PAP、MS-CHAP和CHAP。如果两种方法都被激活了,那么使用第一个方法在链路协商阶段提出请求。如果远端建议使用第二种方法或者简单地拒绝了第一种方法,将使用第二种方法。一些远端设备仅仅支持CHAP或仅仅支持PAP。至于指定这两种认证方法的次序,则要根据你对远端设备正确进行协商的能力的估计,以及你对数据线路安全方面的考虑。PAP的用户名和口令是作为明文传送的,有可能被截获和重新使用;而CHAP则消除了目前所知的大部分安全漏洞。

激活或者取消PPP认证都不会影响本地路由器是否要向远端设备验证自己。

示例

下面例子在接口s1/0上激活了CHAP认证并使用认证列表access1 。

interface s1/0

encapsulation ppp

ppp authentication chap access1

相关命令

aaa authentication ppp

encapsulation ppp

username password

3.1.14   ppp authorization

为了在指定接口上激活AAA 授权,在接口配置态下使用命令 ppp authorization ,使用no命令取消授权。

ppp authorization [default | list-name]

no ppp authorization

参数

参数

参数说明

default

(可选) 由aaa authorization 命令创建的方法列表名。

list-name

(可选) 指定授权列表名。如果没有指定,则使用default值。

缺省

没有启用授权

命令模式

接口配置态

使用说明

在启用aaa authorization 命令并且定义了授权方法列表(或使用缺省的方法列表)后,必须在适当的接口上存在对应上述授权列表的授权。使用命令ppp authorization是为了在指定接口上应用指定的方法列表(如果没有指定列表,则使用缺省列表) 。

示例

在接口s1/0上使用方法列表sun。

interface s1/0

encapsulation ppp

ppp authorization sun

相关命令

aaa authorization

3.1.15   ppp callback

使用接口配置命令ppp callback用于接收对端的回拨请求或者请求对端回拨。

使用命令no ppp callback取消PPP callback的配置。

ppp callback {accept | initiate | request}

no ppp callback

参数

参数

参数说明

accept

接受PPP客户端的回拨请求。

initiate

不经过PPP callback的协商,对接口上拨入的PPP客户端主动发起回拨。

request {cbcp}

向PPP对端发出回拨请求 (如果带有参数cbcp,则使用CBCP协议进行回拨协商)。

缺省

不接受对端的回拨请求。

命令模式

接口配置态

使用指南

要接受一个来自客户端的回拨请求,首先必须配置ppp callback accept或ppp callback initiate,并且配置CHAP或PAP对客户端进行认证,在通过认证时,向客户端发起回拨。

如果使用CBCP进行回拨协商,在Caller一端需要配置ppp callback request cbcp(如果需要caller指定电话号码,还需配置dialer caller xx)。在Answerer一端除了需要配置ppp callback accept外,如果不需要回拨,无需配置回拨的电话号码;如果回拨的电话号码由Caller指定,需要配置user xx password xx callback-dialstring *或dialer called *;如果由Answerer指定回拨的电话号码,需要配置user xx password xx callback-dialstring xx;如果要Caller从Answerer提供的一组电话号码中选一个,需要配置dialer called xx ;xx;xx。

优先查询user xxx password xx callback-dialstring xx,再查询dialer called xx。另外,总机号码与分机号码之间用“,”分隔,一组电话号码之间用“;”分隔。

示例

下面示例接受PPP客户端的回拨请求。

ppp callback accept

下面示例不需ppp callback的协商就向对端发起回拨:

ppp callback initiate

下面示例向对端发出回拨请求:

ppp callback request

下面示例用Answerer指定的电话号码12345回拨:

Caller端配置:

ppp callback request cbcp

Answerer端配置:

user sun password sun callback-dialstring 12345

进入接口配置态,输入:

ppp callback accept

相关命令

ppp authentication

username

3.1.16   ppp chap echo

启用CHAP认证通过后,设置定时进行 CHAP 认证的时间间隔。

ppp chap ehco seconds

参数

参数

参数说明

seconds

CHAP 认证时间间隔 范围<0 - 2147483647> 秒。

缺省

缺省不进行定时CHAP 认证,缺省配置为0 秒 。

命令模式

接口配置态

使用说明

配置CHAP 定时认证时,必须将second 配置为大于0。

示例

配置接口Serial1/0进行CHAP定时验证时,本地路由器名为routerA, echo 定时为 10 秒。

interface s1/0

encapsulation ppp

ppp authentication chap

ppp chap hostname routerA

ppp chap echo 10

相关命令

ppp authentication

ppp authentication

ppp chap hostname

3.1.17   ppp chap hostname

使用接口配置命令ppp chap hostname来创建一个路由器chap 主机名。要取消这个功能,使用no ppp chap hostname命令。

ppp chap hostname hostname

no ppp chap hostname hostname

参数

参数

参数说明

hostname

在CHAP challenge报文中发送的名字。

缺省

未启用该功能。缺省时,在所有CHAP challenge中发送路由器的主机名。

命令模式

接口配置态

使用说明

该命令通常应用于本地CHAP认证(即对对端进行认证),但它也可以用于远端CHAP认证。

示例

下面例子中的命令在接口dialer 0上封装PPP。CHAP仅仅对收到的呼叫进行认证。用户名guest将随所有CHAP challenge和response报文一起发送

interface dialer 0

encapsulation ppp

ppp authentication chap callin

ppp chap hostname guest

相关命令

aaa authentication ppp

ppp authentication

ppp chap password

ppp pap

3.1.18   ppp chap refuse

拒绝对端使用CHAP验证本地。

参数

无参数和关键词

缺省

缺省时不拒绝对端使用CHAP验证本地。

命令模式

接口配置态

使用说明

配置ppp chap refuse后,将要拒绝所有user使用CHAP认证本地(包括合法user)。

示例

配置接口Serial1/0拒绝CHAP验证。

interface s1/0

encapsulation ppp

ppp chap refuse

相关命令

ppp authentication

3.1.19   ppp ddr

设置virtual-tunnel端口由数据报文触发vpdn连接。

参数

无参数和关键词

缺省

缺省时不是由数据报文触发vpdn连接,只要端口line up起来,就不断尝试进行vpdn连接。

命令模式

接口配置态

使用说明

配置ppp ddr后,virtual-tunnel端口向上层报protocol up并添加本地路由,当由上层数据报文经过该本地路由发送到该virtual-tunnel端口时,触发vpdn连接

示例

配置接口Serial1/0拒绝CHAP验证。

!

interface virtual-tunnel 0

ppp ddr

!

相关命令

interface virtual-tunnel

3.1.20   ppp ipcp rfc-default

设置IPCP协商选项为PPP协议缺省值,不协商所有IPCP选项。

参数

无参数和关键词

缺省

IPCP协商选项不为协议缺省值,即协商IPCP选项。

命令模式

接口配置态

使用说明

一般情况下,该命令不需要设置。仅用于测试或对端不支持IPCP协商的情况。

示例

设置IPCP协商为协议缺省。

ppp ipcp rfc-default

相关命令

encapsulation ppp

3.1.21   ppp lcp echo

设置LCP 发送echo报文的时间间隔 。

ppp lcp echo seconds

参数

参数

参数说明

seconds

发送LCP echo请求报文的时间间隔 范围<0 - 2147483647> 秒。

缺省

10 秒

命令模式

接口配置态

使用说明

需要发送LCP echo请求报文时,必须将second 配置为大于0。

示例

配置接口Serial1/0上的,lcp echo 定时为 10 秒。

!

interface s1/0

encapsulation ppp

ppp lcp echo 10

!

相关命令

encapsulation ppp

3.1.22   ppp lcp enddisc-type

选择multilink ppp端点标志类型。

ppp lcp enddisc-type [null | local | ip | ieee8021 | ppp | psdn]

参数

命令模式

端口配置态(multilink端口)

使用指南

为multilink ppp选择协议协商时的断点标志类型。

示例

37DE_config_m1#ppp lcp enddisc-type ppp

37DE#debug ppp negotiate

 PPP Serial0/1: LCP  Listen  ; RX <- Config Req, id: 182, len: 32

2003-4-28 11:36:19     making Magic Number: 0xc69038e7

2003-4-28 11:36:19     making Protocol compression

2003-4-28 11:36:19     making Addr/Ctl compression

2003-4-28 11:36:19     making MRRU: 1524

2003-4-28 11:36:19     making ENDDISC: class 4 ,address "000000e3"

2003-4-28 11:36:19

PPP Serial0/1: LCP  Listen  ; TX -> Config Req, id: 8, len: 25

2003-4-28 11:36:19     checking Magic Number: 0xcff04a72

2003-4-28 11:36:19         result Config Ack, option 5, length 6

2003-4-28 11:36:19         making Magic Number: 0xcff04a72

2003-4-28 11:36:19     checking Protocol compression

2003-4-28 11:36:19         result Config Ack, option 7, length 2

2003-4-28 11:36:19         making Protocol compression

2003-4-28 11:36:19     checking Addr/Ctl compression

2003-4-28 11:36:19         result Config Ack, option 8, length 2

2003-4-28 11:36:19         making Addr/Ctl compression

2003-4-28 11:36:19     checking MRRU: 1524

2003-4-28 11:36:19         result Config Ack, option 17, length 4

2003-4-28 11:36:19         making MRRU: 1524

2003-4-28 11:36:19     checking ENDDISC: class 1 ,address "BD-00000059" ,len 11 ,toss(11->0)

2003-4-28 11:36:19         result Config Ack, option 19, length 14

2003-4-28 11:36:19         making ENDDISC: class 1 ,address "BD-00000059"

上面的示例中,可以看到本端发送的lcp config request里包含enddisc的协商内容,其类型为4,也就是enddisc type ppp。对端的协商报文里面包含的enddisc类型为1,也就是enddisc type local。

附:enddisc类型数与类型名的对应关系

class                 name

0                     null

1                     local

2                     ip

3                     ieee8021

4                     ppp

5                     psdn

3.1.23   ppp lcp rfc-default

设置LCP协商选项为PPP协议缺省值,不协商所有LCP选项。

参数

无参数和关键词

缺省

LCP协商选项不为协议缺省值,即协商LCP选项 。

命令模式

接口配置态

使用说明

一般情况下,该命令不需要设置。仅用于测试或对端不支持LCP协商的情况。

示例

设置LCP协商为协议缺省。

ppp lcp rfc-default

相关命令

encapsulation ppp

3.1.24   ppp lcp

ppp lcp [close | listen | open]

对LCP连接进行open、close、listern操作。

参数

参数

参数说明

close

关闭LCP连接。

listen

设置LCP为监听状态。

open

建立LCP连接。

缺省

LCP为监听状态

命令模式

接口配置态

使用说明

当使用ppp lcp close命令关闭当前PPP连接后,LCP为closed状态。以后即使远端拨入,也不建立连结。必须通过ppp lcp listen或ppp lcp open将其启动,其中ppp lcp open主动发送LCP协议请求报文。

示例

关闭LCP连接。

ppp lcp close

相关命令

encapsulation ppp

3.1.25   ppp max-bad-auth

使用接口配置命令ppp max-bad-auth配置一个点到点接口,让它在认证失败后并不立即复位,还允许一定次数的认证。使用no ppp max-bad-auth 命令则在认证失败后马上复位。

ppp max-bad-auth number

no ppp max-bad-auth

参数

参数

参数说明

number

指定可以重复认证的次数(1-255),缺省值是5

缺省

5

命令模式

接口配置态

使用说明

该命令应用于任何使用PPP封装的串行接口(异步串行接口、同步串行接口或ISDN接口)上。

示例

下面例子把接口BRI0设置成在首次认证失败后还可允许2次认证(一共可以进行3次认证的尝试)

!

interface bri 0

encapsulation ppp

ppp authentication chap 

ppp max-bad-auth 3

!

相关命令

encapsulation ppp

3.1.26   ppp multilink

接口配置命令ppp multilink,用于启用多链路PPP。使用no ppp multilink 命令关闭多链路PPP。

ppp multilink

no ppp multilink

参数

缺省

没有启用multilink。

命令模式

接口配置态

使用说明

该命令应用于任何使用PPP封装的串行接口(异步串行接口、同步串行接口或ISDN接口)上。

示例

!

interface Dialer0

ip address 99.0.0.2 255.0.0.0

encapsulation ppp

dialer idle-timeout 500

dialer map 99.0.0.1 name dialname1 broadcast 81012345678901

dialer load-threshold 30 either

dialer-group 1

ppp authentication chap

ppp multilink

!

相关命令

encapsulation ppp

3.1.27   ppp pap refuse

拒绝对端使用PAP验证本地。

参数

无参数和关键词

缺省

缺省时不拒绝对端使用PAP验证本地。

命令模式

接口配置态

使用说明

配置ppp pap refuse后,将要拒绝所有user使用PAP认证本地(包括合法user)。

示例

配置接口Serial1/0拒绝PAP验证。

!

interface s1/0

encapsulation ppp

ppp pap refuse

!

相关命令

ppp authentication

3.1.28   ppp pap sent-username

使用接口配置命令ppp pap sent-username在接口上激活远端PAP支持并在PAP认证请求报文中使用sent-unsername和password。使用no ppp pap sent-username禁止远端PAP的支持。

ppp pap sent-username username password

no ppp pap sent-username

参数

参数

参数说明

username

发送在PAP认证请求中的用户名。

password

发送在PAP认证请求中的密码。

缺省

禁止远端PAP支持 。

命令模式

接口配置态

使用说明

使用这条命令激活远端PAP支持(例如响应对端要求使用PAP认证的请求)同时指定发送PAP认证请求时的参数。

示例

下面例子把拨号接口0配置成作为拨号组头并在接口上激活PPP封装。CHAP或PAP仅仅对收到的呼叫进行认证。当远端要求路由器用PAP进行认证时guest1作为用户名、mykey作为密码发送给远端。

!

interface dialer0

encapsulation ppp

ppp authentication chap pap callin

ppp chap hostname guest1

ppp pap sent-username guest1 mykey

!

相关命令

aaa authentication ppp

ppp authentication

ppp chap hostname

3.1.29   ppp timeout authentication

设置PPP认证超时时间。

ppp timeout authentication seconds

参数

参数

参数说明

seconds

协商超时时间,单位为秒。

缺省

缺省的PPP认证超时时间为3秒。

命令模式

接口配置态

使用说明

在PPP 认证过程中,如果在这个时间间隔内没有收到对端的应答报文,则PPP将会重发前一次发送的认证报文。

示例

设置PPP认证超时时间为10秒。

ppp timeout authentication 10

相关命令

encapsulation ppp

ppp authentication

3.1.30   ppp timeout ncp

设置PPP NCP协商超时时间。

ppp timeout ncp seconds

参数

参数

参数说明

seconds

为NCP协商超时时间,单位为秒。

缺省

缺省的PPP NCP协商超时时间为3秒。

命令模式

接口配置态

使用说明

在PPP NCP协商过程中,如果在这个时间间隔内没有收到对端的应答报文,则PPP将会重发前一次发送的报文。

示例

设置PPP NCP协商超时时间为10秒。

ppp timeout ncp 10

相关命令

encapsulation ppp

3.1.31   ppp timeout lcp

设置PPP LCP协商超时时间。

ppp timeout lcp seconds

参数

参数

参数说明

seconds

为LCP协商超时时间,单位为秒。

缺省

缺省的PPP LCP协商超时时间为3秒。

命令模式

接口配置态

使用说明

在PPP LCP协商过程中,如果在这个时间间隔内没有收到对端的应答报文,则PPP将会重发前一次发送的报文。

示例

设置PPP LCP协商超时时间为10秒。

ppp timeout lcp 10

相关命令

encapsulation ppp 

3.1.32   show ip local pool

使用show ip local pool显示IP地址池的统计信息。

show ip local pool

参数

无参数和关键词

命令模式

特权EXEC模式

使用说明

软件将显示所有定义的地址池的通用列表和相应的IP地址。

示例

下面是命令show ip local pool 的举例。

Router# show ip local pool

Name     Begin                 End                 Number

sun      192.168.0.1        192.168.0.10         10

相关命令

ip local pool 

3.1.33   show ppp

使用show ip local pool显示IP地址池的统计信息

show ppp { multilink |queue| status | version }

参数

参数

参数说明

multilink

显示ppp multilink相关信息 。

queue

显示PPP队列没有处理消息个数 。

Status

显示配置PPP的相关接口状态信息 。

version

PPP模块的版本 。

命令模式

非用户模式

使用说明

本命令用来显示PPP相关信息。

示例

下面是命令显示接口状态信息的举例。

Router# show ppp sta

PPP status information:

    5 links (total)

    1 links (protocol up)

    4 links (protocol down)

Protocol up:

    Name      ID Type   Status           Uptime       Peer          

    S2/0       2 ALGC   Network Phase    0:04:32:01   1.0.0.2        

Protocol down:

    Name      ID Type   Status           Downtime

    a0/0       1 ADC    Link Dead        0:04:48:15

    vt1        4 LVT    Link Dead        0:04:48:07

    d1         6 D      Link Dead        0:04:48:07

    m1         7 LMU    LCP Phase        0:04:48:07

上面标识路由器共有5个接口配置了PPP,只有s2/0处于协议Up,协议Up时间为4小时32分1秒。对端地址为1.0.0.2。其他端口处于线路Down状态。

相关命令

 无

3.1.34   username

使用全局配置命令指定一个口令,该口令在PPP CHAP呼叫方标识和PAP中使用。

username name password secret

参数

参数

参数说明

name

主机名、服务器名、用户ID、或命令名。

secret

对CHAP而言:为本地路由器、访问服务器或远端设备指定密钥口令。这个密钥经加密后在本地路由器或访问服务器上存储,这可以防止密钥被盗用。密钥口令最多可由11个可打印的ASCII字符组成,但不能包括空格和下划线。对username/password对的数目没有限制,允许任意数目的远端设备被认证。

缺省

没有预先定义的口令

命令模式

全局配置态

使用说明

为每个需要在本地路由器或访问服务器上认证的每个远程系统增加一个name入口。

作为配置认证协议(例如CHAP和PAP)的一部分,命令username是必须的。如果需要对和本地路由器或访问服务器通信的每个远程系统进行认证的话,你必须增加一个username入口。

示例

下面例子在串行接口0上启动了CHAP。它为本地服务器Adam和远程服务器Eve定义了一个口令。

!

hostname Adam

!

interface s1/0

encapsulation ppp

ppp authentication chap

username Eve password theirsystem

!

相关命令

hostname  

3.1.35   debug ppp

显示PPP协议参数协商、认证、报文发送、接收过程和出错信息。

debug ppp [ authentication | cbcp | error | multilink | negotiation | packet | raw ] [interface]

注:raw 仅仅在异步接口上生效。

使用no debug ppp命令停止显示信息。

参数

参数

参数说明

authentication

打开PPP认证的调试开关。

cbcp

打开PPP回拨控制协议的调试开关。

error

打开PPP出错信息的调试开关。

negotiation

打开PPP参数协商的调试开关。

packet

打开PPP输入输出报文的调试开关。

raw

打开PPP异步输入输出原始报文的调试开关。

interface

要PPP调试信息的接口。

命令模式

管理态

使用指南

打开PPP调试信息开关后,输出PPP协议参数协商过程、认证过程、报文发送、接收过程和出错信息,帮助用户进行PPP故障诊断。

示例

下面示例描述了调试PPP收发报文的情形。

Router#debug ppp packet s1/2

PPP Serial1/2: TX -> packet, len=88, protocol: LCP

FF 03 00 21 45 00 00 54 00 2F 00 00 FF 01 3E F1   ...!E..T./....>.

01 00 00 0C 7B 7B 00 02 08 00 CB 37 00 12 00 00   ....{{.....7....

00 02 37 A5 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F   ..7.............

10 11 12 13 14 15 16 17 18 19 1A 1B 1C 1D 1E 1F   ................

PPP Serial1/2: RX <- packet, len=85

21 45 00 00 54 9E 73 00 00 FF 01 A0 AC 7B 7B 00   !E..T.s......{{.

02 01 00 00 0C 00 00 D3 37 00 12 00 00 00 02 37   ........7......7

A5 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F 10 11 12   ................

13 14 15 16 17 18 19 1A 1B 1C 1D 1E 1F 20 21 22   ............. !"

描述

PPP

当前调试的是PPP协议

Serial1/2

当前的调试接口

TX -> packet

PPP发送报文

Len=85

发送报文的长度

protocol: LCP

当前PPP协议中封装的子协议

FF 03 00 21 45 00 00 54 00 2F 00 00 FF 01 3E F1 01 00 00 0C 7B 7B 00 02 08 00 CB 37 00 12 00 00 00 02 37 A5 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F10 11 12 13 14 15 16 17 18 19 1A 1B 1C 1D 1E 1F

前4字节为PPP帧头,后面为数据

...!E..T./....>. ....{{.....7.... ..7............. ................

发送报文的ASCII码表示。不在ASCII码表示范围之内的用“.”表示

RX <- packet

PPP接收报文

Len=88

接收报文的长度

21 45 00 00 54 9E 73 00 00 FF 01 A0 AC 7B 7B 00 02 01 00 00 0C 00 00 D3 37 00 12 00 00 00 02 37 A5 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F 10 11 12 13 14 15 16 17 18 19 1A 1B 1C 1D 1E 1F 20 21 22

第一个字节0X21 , 为PPP中IP协议及PFC压缩后的值,原先为0X0021. 后面为数据区

!E..T.s......{{. ........7......7 ................ ............. !"

接收报文的ASCII码表示。不在ASCII码表示范围之内的用“.”表示

下面示例描述了调试PPP协议参数协商简化过程。

Router#debug ppp negotiation s1/2

PPP Serial1/2: LCP  Listen  ; Start

PPP Serial1/2: LCP  Listen  ; TX -> Config Req, id: 52, len: 14

PPP Serial1/2: LCP  Req Sent; RX <- Config Ack, id: 52, len: 14

PPP Serial1/2: LCP  Ack Rcvd; RX <- Config Req, id: 88, len: 14

PPP Serial1/2: LCP  Ack Rcvd; TX -> Config Ack, id: 88, len: 14

PPP Serial1/2: LCP  Ack Rcvd; Opened

PPP Serial1/2: IPCP Listen  ; Start

PPP Serial1/2: IPCP Listen  ; TX -> Config Req, id: 53, len: 10

PPP Serial1/2: IPCP Req Sent; RX <- Config Req, id: 89, len: 16

PPP Serial1/2: IPCP Req Sent; TX -> Config Ack, id: 89, len: 16

PPP Serial1/2: IPCP Ack Sent; RX <- Config Ack, id: 53, len: 10

PPP Serial1/2: IPCP Ack Sent; Opened

描述

Serial1/2

当前的调试接口

PPP

PPP协议

LCP

链路控制协议

IPCP

IP控制协议

Listen、Req Sent、Ack Rcvd、Ack Sent

PPP协议状态

id: 53

报文标志

len:10

报文的长度

第4章   SLIP配置命令

4.1  SLIP配置命令

SLIP配置命令包括:

l   debug slip

l   encapsulation slip

4.1.1   debug slip

显示SLIP协议的报文发送、接收过程和出错信息。使用no debug slip命令停止显示信息。

[no] debug slip [error|events|packet] [interface]

参数

参数

参数说明

interface

要显示SLIP调试信息的接口。

error

打开SLIP出错信息的调试开关。

events

打开SLIP协议事件的调试开关 。

packet

打开SLIP接收/发送报文的调试开关。

命令模式

管理态

使用指南

打开SLIP调试信息开关后,输出SLIP收、发报文信息或者出错信息,帮助用户进行SLIP故障诊断。

示例

下面示例描述了调试SLIP接收报文的情形:

Router#debug slip packet s1/2

Router#

SLIP Serial1/2: RX <- packet, len=1

C0                                            .

SLIP Serial1/2: RX <- packet, len=62

45 00 00 3C D5 CD 00 00 7F 01 9B 3A DB DC A8 00   E..<.......:....

10 0A 00 00 01 08 00 18 5C 02 00 33 00 61 62 63       ........\..3.abc

64 65 66 67 68 69 6A 6B 6C 6D 6E 6F 70 71 72 73      defghijklmnopqrs

74 75 76 77 61 62 63 64 65 66 67 68 69 C0            tuvwabcdefghi.

描述

SLIP

当前调试的是SLIP协议。

Serial0/2

当前的调试接口。

RX <- packet

SLIP接收到报文。

len=1

接收报文的长度。

C0

SLIP帧的起始定界符。

45 00 00 3C D5 CD 00 00 7F 01 9B 3A DB DC A8 00 10 0A 00 00 01 08 00 18 5C 02 00 33 00 61 62 63 64 65 66 67 68 69 6A 6B 6C 6D 6E 6F 70 71 72 73 74 75 76 77 61 62 63 64 65 66 67 68 69 C0

接收报文的16进制表示。

E..<.......:.... ........\..3.abc defghijklmnopqrs tuvwabcdefghi.

接收报文的ASCII码表示。不在ASCII码表示范围之内的用“.”表示。

下面示例描述了调试SLIP发送报文的情形:

Router#debug slip packet s1/2

Router#

SLIP Serial1/2: TX -> packet, len=86

C0 45 00 00 54 00 0A 00 00 FF 01 A7 9C 0A 00 00   .E..T...........

01 0A 00 00 02 08 00 39 55 00 0D 00 00 00 01 C9    .......9U.......

8D 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F 10 11 12   ................

13 14 15 16 17 18 19 1A 1B 1C 1D 1E 1F 20 21 22   ............. !"

描述

SLIP

当前调试的是SLIP协议

Serial1/2

当前的调试接口

TX -> packet

SLIP在发送报文

len=86

发送报文的长度

C0 45 00 00 54 00 0A 00 00 FF 01 A7 9C 0A 00 00 01 0A 00 00 02 08 00 39 55 00 0D 00 00 00 01 C9 8D 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F 10 11 12 13 14 15 16 17 18 19 1A 1B 1C 1D 1E 1F 20 21 22

发送报文的16进制表示

.E..T........... .......9U....... ................ ............. !"

发送报文的ASCII码表示。不在ASCII码表示范围之内的用“.”表示

4.1.2   encapsulation slip

接口封装SLIP。no取消封装。

encapsulation slip

no encapsulation slip

参数

缺省

命令模式

接口配置态

使用指南

使用no取消封装,即回到封装PPP方式。建议在改变封装类型前,先用no命令关闭接口。虽然这不是必需的,但这样操作更安全。

示例

下面例子在串口s1/1配置SLIP封装方式:

!

interface s1/1

encapsulation slip

!

第5章   HDLC配置命令

5.1  HDLC配置命令

HDLC配置命令包括:

l   debug hdlc

l   encapsulation hdlc

5.1.1   debug hdlc

显示HDLC协议的报文发送和接收过程。使用no debug hdlc命令停止显示信息。

[no] debug hdlc [packet | error] [interface]

参数

参数

参数说明

interface

要显示HDLC调试信息的接口。

packet

打开HDLC发送/接收报文的调试开关。

error

打开HDLC出错信息的调试开关。

命令模式

管理态

使用指南

打开HDLC调试信息开关后,输出HDLC收、发报文和出错信息,帮助用户进行HDLC故障诊断。

示例

下面示例描述了调试HDLC接收/发送报文的情形:

Router#debug hdlc packet s1/2

Router#

Serial1/2 HDLC RX <- packet, len=64

0F 00 08 00 45 00 00 3C BE 4A 00 00 7F 01 B2 BD   ....E..<.J......

C0 A8 00 10 0A 00 00 01 08 00 19 5C 02 00 32 00    ...........\..2.

61 62 63 64 65 66 67 68 69 6A 6B 6C 6D 6E 6F 70   abcdefghijklmnop

71 72 73 74 75 76 77 61 62 63 64 65 66 67 68 69     qrstuvwabcdefghi

Serial0/2 HDLC RX <- link check frame, len=22

8F 00 80 35 00 00 00 02 00 00 00 33 00 00 00 C7   ...5.......3....

FF FF 00 00 0B DE                           ......

描述

HDLC

当前调试的是HDLC协议。

Serial0/2

当前的调试接口。

RX <- packet

HDLC接收到IP报文。

len=64

接收报文的长度。

0F 00 08 00 45 00 00 3C BE 4A 00 00 7F 01 B2 BD C0 A8 00 10 0A 00 00 01 08 00 19 5C 02 00 32 00 61 62 63 64 65 66 67 68 69 6A 6B 6C 6D 6E 6F 70 71 72 73 74 75 76 77 61 62 63 64 65 66 67 68 69

前4字节为HDLC帧头,后面为数据。

....E..<.J...... ...........\..2. abcdefghijklmnop qrstuvwabcdefghi

接收报文的ASCII码表示。不在ASCII码表示范围之内的用“.”表示。

RX <- link check frame

HDLC接收到链路检测帧。

len=22

链路检测帧的长度。

8F 00 80 35 00 00 00 02 00 00 00 33 00 00 00 C7 FF FF 00 00 0B DE

链路检测帧的16进制表示。

...5.......3.... ......

链路检测帧的ASCII码表示。不在ASCII码表示范围之内的用“.”表示。

HDLC Serial0/2: TX -> packet, len=88

0F 00 08 00 45 00 00 54 00 07 00 00 FF 01 A7 9F   ....E..T........

0A 00 00 01 0A 00 00 02 08 00 00 03 00 0A 00 00   ................

00 01 02 E3 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F  ................

10 11 12 13 14 15 16 17 18 19 1A 1B 1C 1D 1E 1F  ................

HDLC Serial0/2: TX -> link check frame, len=24

8F 00 80 35 00 00 00 02 00 00 01 15 00 00 00 42   ...5...........B

FF FF 30 2E 33 B9 53 01                      ..0.3.S.

描述

HDLC

当前调试的是HDLC协议。

Serial1/2

当前的调试接口。

TX -> packet

HDLC在发送IP报文。

len=88

发送报文的长度。

0F 00 08 00 45 00 00 54 00 07 00 00 FF 01 A7 9F 0A 00 00 01 0A 00 00 02 08 00 00 03 00 0A 00 00 00 01 02 E3 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F 10 11 12 13 14 15 16 17 18 19 1A 1B 1C 1D 1E 1F

前4字节为HDLC帧头,后面为数据。

....E..T....... ................ ................ ................

发送报文的ASCII码表示。不在ASCII码表示范围之内的用“.”表示。

TX -> link check frame

HDLC在发送链路检测帧。

len=24

链路检测帧的长度。

8F 00 80 35 00 00 00 02 00 00 01 15 00 00 00 42 FF FF 30 2E 33 B9 53 01

链路检测帧的16进制表示。

...5...........B ..0.3.S.

链路检测帧的ASCII码表示。不在ASCII码表示范围之内的用“.”表示。

5.1.2   encapsulation hdlc

接口封装hdlc。no取消封装。

encapsulation hdlc

no encapsulation hdlc

参数

缺省

命令模式

接口配置态

使用指南

使用no取消封装,仍回到封装HDLC方式。

示例

下面例子在串口s1/1配置HDLC封装方式:

!

interface s1/1

encapsulation hdlc

!

第6章   ISDN配置命令

6.1  ISDN配置命令

ISDN配置命令包括:

l   debug isdn

l   isdn call

l   isdn disconnect

l   isdn switch-type

l   isdn tei-negotiation

l   show isdn

6.1.1   debug isdn

显示ISDN相关的事件、I/O报文、Q931或者Q921报文的跟踪信息。使用no debug isdn命令停止显示信息。

[no] debug isdn [event | packet | q921| q931]

参数

参数

参数说明

event

ISDN事件跟踪信息。

packet

ISDN输入输出报文。

q921

ISDN Q921报文的跟踪信息。

q931

ISDN Q931报文的跟踪信息。

命令模式

管理态

使用说明

打开ISDN调试信息开关后,输出ISDN事件、原始I/O报文、Q931报文或者Q921报文的跟踪信息,帮助用户进行ISDN故障诊断。

示例

下面示例描述了调试ISDN原始I/O报文的情形:

Router#debug isdn packet

Router#

ISDN BRI0/3: TX -> packet,  length=8

          fc ff 03 0f 61 28 01 ff  

ISDN BRI0/3: RX <- packet,  length=8

          fe ff 03 0f 61 28 02 af  

ISDN BRI0/3: TX -> packet,  length=3

          00 af 7f  

ISDN BRI0/3: RX <- packet,  length=3

          00 af 73

描述

ISDN

当前调试的是ISDN协议

BRI0/3

当前调试的端口是BRI0/3

TX

ISDN发送报文

RX

ISDN接收报文

Length

报文的长度

fc ff 03 0f 61 28 01 ff

原始I/O报文

下面示例描述了调试ISDN Q921报文跟踪的情形:

Router#debug isdn q921

Router#

ISDN BRI0/3: TX ->  IDREQ  ri = 86  ai = 127

ISDN BRI0/3: RX <-  IDASSN  ri = 86  ai = 89

ISDN BRI0/3: TX ->  SABMEp sapi = 0  tei = 89

ISDN BRI0/3: RX <-  UAf sapi = 0  tei = 89

ISDN BRI0/3: TX ->  INFOc sapi = 0  tei = 89  ns = 0  nr = 0  i = 0x08010105040288901801832c0438313633

ISDN BRI0/3: RX <-  RRr sapi = 0  tei = 89  nr = 1

ISDN BRI0/3: RX <-  INFOc sapi = 0  tei = 89  ns = 0  nr = 1  i = 0x08018102180189

ISDN BRI0/3: TX ->  RRr sapi = 0  tei = 89  nr = 1

描述

ISDN

当前调试的是ISDN协议 。

BRI0/3

当前调试的端口是BRI0/3 。

TX

ISDN发送报文 。

RX

ISDN接收报文 。

IDREQ、IDASSN、SABME、UA、INFO、RR

ISDN Q921帧类型,分别是:身份请求、身份分配、置扩展异步平衡方式、无编号确认响应、信息帧、接收准备好 。

p/f

询问/结束 。

callref

呼叫参考 。

ri

参考号码 。

ai

动作指示语 。

sapi

服务接入点标识符 。

tei

终端端点标识符。

ns

发送序号 。

nr

接收序号 。

i

信息帧中的Q931消息 。

下面示例描述了调试ISDN Q931报文跟踪的情形:

Router#debug isdn q931

Router#

ISDN BRI0/3: TX ->  SETUP pd = 8  callref = 0x06

        Bearer Capability i = 0x8890

        Channel ID i = 0x83

        Keypad Facility i = 0x38313633

ISDN BRI0/3: RX <-  CALL_PROC pd = 8  callref = 0x86

        Channel ID i = 0x89

ISDN BRI0/3: RX <-  ALERTING pd = 8  callref = 0x86

ISDN BRI0/3: RX <-  CONNECT pd = 8  callref = 0x86

ISDN BRI0/3: TX ->  CONNECT_ACK pd = 8  callref = 0x06

ISDN BRI0/3: RX <-  DISCONNECT pd = 8  callref = 0x86

        Cause i = 0x8090 - Normal call clearing

ISDN BRI0/3: TX ->  RELEASE pd = 8  callref = 0x06

        Cause i = 0x8090 - Normal call clearing

ISDN BRI0/3: RX <-  RELEASE_COMP pd = 8  callref = 0x86  

描述

ISDN

当前调试的是ISDN协议

BRI0/3

当前调试的端口是BRI0/3

TX

ISDN发送报文

RX

ISDN接收报文

SETUP、CALL_PROC、ALERTING、CONNECT、CONNECT_ACK、RELEASE、RELEASE_COMP

ISDN Q931消息类型,分别是:建立、呼叫进程、提醒、连接、连接确认、释放、释放完成

pd

协议鉴别语

callref

呼叫参考

Bearer Capability、Channel ID、Keypad Facility、Cause

ISDN Q931消息中的信息单元,分别是:承载能力、通路标识、键盘设施、原因

6.1.2   isdn call

isdn call以手工方式发起一次ISDN呼叫。

isdn call interface bri[x/x] word

isdn call interface s[x/x]:15 word

参数

参数

参数说明

word

ISDN电话号码。

命令模式

管理态

使用说明

可以用手工的方式(不是根据流量拨号)发起一次ISDN呼叫。

示例

下面示例描述了在端口BRI0/0向8163发起一次ISDN呼叫:

Router#isdn call interface bri0/0 8163

6.1.3   isdn disconnect

isdn call以手工方式发起一次ISDN呼叫。

isdn disconnect interface bri[x/x] [all |channel number]

isdn disconnect interface s[x/x]:15  [all |channel number]

参数

参数

参数说明

all

断开所有B信道上的呼叫。

Channel number

断开指定B信道上的呼叫。

命令模式

管理态

使用说明

可以用手工的方式(不是根据流量拨号)发起一次ISDN呼叫。

示例

下面示例描述了在端口BRI0/0所有信道上断开ISDN呼叫:

Router#isdn disconnect interface bri0/0 all

6.1.4   isdn switch-type

isdn switch-type选择ISDN交换机类型,no isdn switch-type恢复缺省的交换机类型。

[no] isdn switch-type [basic-1tr6 | basic-5ess | basic-dms100 | basic-net3| basic-ni| basic-ts013 | kdd | ntt | vn2 | vn3|primary-net5]

参数

参数

参数说明

basic-1tr6

1TR6 交换机类型(德国)

basic-5ess

AT&T 5ESS 交换机类型(美国)

basic-dms100

DMS-100 交换机类型(北美)

basic-net3

NET3 交换机类型(英国和欧洲)

basic-ni

National ISDN 交换机类型(北美)

basic-ts013

TS013 交换机类型(澳大利亚)

kdd

KDD 交换机类型(日本)

ntt

NTT 交换机类型(日本)

vn2

VN2 交换机类型(法国)

vn3

VN3 交换机类型(法国)

Primary-net

Primary-net交换机类型(欧洲PRI接口交换机,与多种PRI交换机类型可互通)

缺省

basic-5ess。

命令模式

全局配置模式

使用说明

使用该命令设置BRI接口相连的交换机类型。

示例

下面例子设置全局交换机类型是basic-1tr6:

Router_config#isdn switch-type basic-1tr6

6.1.5   isdn tei-negotiation

isdn isdn-negotiation设置ISDN的TEI协商方式,no isdn tei-negotiation恢复缺省的TEI协商方式。

[no] isdn tei-negotiation [first-call | powerup]

参数

参数

参数说明

first-call

在第一次呼叫时进行ISDN TEI协商。

powerup

在路由器开机时进行ISDN TEI协商。

缺省

powerup。

命令模式

全局配置模式

使用说明

使用该命令设置ISDN的TEI协商方式。

示例

下面例子设置在第一次呼叫时进行ISDN TEI协商:

Router_config#isdn tei-negotiation first-call

6.1.6    show isdn

show isdn显示ISDN的当前状态和定时器信息。

[no] show isdn [status | timers]

参数

参数

参数说明

status

显示ISDN BRI接口的当前状态。

timers

显示ISDN定时器配置信息。

缺省

命令模式

管理态。

使用说明

使用该命令显示ISDN第一层(线路)、第二层(Q921)和第三层(Q931)状态以及各层定时器的配置信息。

示例

下面例子显示ISDN各层状态:

Router#show isdn status

Global ISDN Switchtype = basic-5ess

ISDN BRI0/3 interface :

    Layer 1 Status:

        ACTIVE

    Layer 2 Status:

        TEI = 89, State = MULTIPLE_FRAME_ESTABLISHED

    Layer 3 Status:

        No Active Layer 3 Call(s)

    Activated dsl 0 CCBs = 0

Total Allocated ISDN CCBs = 0

参数

参数说明

Global ISDN Switchtype = basic-5ess

全局的ISDN交换机类型

ISDN BRI0/3 interface

ISDN BRI0/3端口

Layer 1 Status

ISDN第一层状态

Layer 2 Status

ISDN第二层状态

Layer 3 Status

ISDN第三层状态

ACTIVE

第一层处于激活状态

TEI = 89

交换机为BRI接口分配的TEI

State = MULTIPLE_FRAME_ESTABLISHED

第二层处于多帧建立状态

No Active Layer 3 Call(s)

第三层没有活动的呼叫

Activated dsl 0 CCBs = 0

激活的DSL是0,分配的CCB数是0

Total Allocated ISDN CCBs = 0

所有分配的CCB数是0

下面例子显示ISDN各层状态:

Router#show isdn timers

    Global ISDN Switchtype = basic-5ess

        ISDN Layer 2 values:

         K    = 1   outstanding I-frames

         N200 = 3   max number of retransmits

         T200 = 1   seconds

         T202 = 2   seconds

         T203 = 10  seconds

        ISDN Layer 3 values:

         T303 = 4   seconds

         T305 = 4   seconds

         T308 = 4   seconds

         T310 = 60  seconds

         T313 = 4   seconds

         T316 = 120 seconds

         T318 = 4   seconds

         T319 = 4   seconds

描述

Global ISDN Switchtype = basic-5ess

全局的ISDN交换机类型。

ISDN Layer 2 values

ISDN第二层数值。

ISDN Layer 3 values:

ISDN第三层数值。

K

待确认I帧的最大数目。

N200

重发的最多次数。

T200

命令帧与响应帧(或者确认帧)之间最大的时间间隔。

T202

发送TEI身份请求消息间的最小时间间隔。

T203

无帧交换的最大允许时间。

T303

发送起始定时器,从发送SETUP消息到接收响应消息的最大时间间隔。

T305

拆线请求定时器,从发送DISC到接收RELEASE(或DISC)间的最大时间间隔。

T308

释放请求定时器,从发送RELEASE到接收RELEASE_CMP(或RELEASE)间的最大时间间隔。

T310

呼出进程定时器,从接收CALL_PROC到接收后继消息(ALERT、CONNECT、DISC、PROGRESS)之间的最大时间间隔。

T313

连接请求定时器,从发送CONNECT到接收CONNECT_ACK间的最大时间间隔。

T316

重新启动请求定时器,从发送RESTART到接收RESTART_ACK间的最大时间间隔。

T318

恢复请求定时器,从发送RESUME到接收RESUME_ACK间的最大时间间隔。

T319

暂停请求定时器,从发送SUSPEND到接收SUSPEND或SUSPEND_REJ间的最大时间间隔。

第7章   WAN性能配置命令

快速转发原理描述和限制见WAN性能配置指南中关于快速转发部分。

7.1  WAN性能配置命令

WAN性能配置命令包括:

l   Ip fast-switch enable(全局配置态)

l   Ip fast-switch enable(接口配置态)

l   Show ip fast-switch stat

l   Show version module fsc

7.1.1   Ip fast-switch enable(全局配置态)

设置快速转发全局有效

Ip fast-switch enable

no Ip fast-switch enable

参数

缺省

no Ip fast-switch enable

命令模式

全局配置模式

使用说明

改命令设置快速转发全局有效。

示例

router>enable

router#config

router_config#ip fast-switch enable

7.1.2   Ip fast-switch enable(接口配置态)

在接口设置快速转发

Ip fast-switch enable

no Ip fast-switch enable

参数

缺省

no Ip fast-switch enable

命令模式

接口配置态

使用说明

改命令设置某个接口进行快速转发,必须在全局配置快速转发后,该命令才有效。

示例

router>enable

router#config

router_config#interface f0/0

router_config_if#ip fast-switch enable

7.1.3   Show ip fast-switch stat

显示快速转发统计信息

show ip fast-switch stat

参数

缺省

命令模式

全局配置态或接口配置态或管理态。

使用说明

只有配置了快速转发,才会显示快速转发相关信息。

示例

router>enable

router#config

router_config#show ip fast-switch stat

显示结果如下: 

Ethernet1/1 configure fast switch

encasulation ARP

line protocol is up

Total packets with protocol wrong 0

Total packets with version or length wrong 0

Total packets with TTL expiry 0

Total packets forward successly 2378

Total packets receive 4679

Total packets with check sum error 0

Serial 2/0 configure fast switch

encasulation PPP

line protocol is up

Total packets with protocol wrong 0

Total packets with version or length wrong 0

Total packets with TTL expiry 0

Total packets forward successly 2234

Total packets receive 3789

Total packets with check sum error 0

其中显示的统计信息含义如下:

Total packets with protocol wrong:表示协议类型不为46的IP报文个数。

Total packets with version or length wrong:表示IP报文版本号不是V4或IP报文头部长度不是20的报文个数,对这种报文不进行转发。

Total packets with TTL expiry:表示TTL值<2的IP报文个数(可能出现环路)。

Total packets with check sum error:表示校验错误的IP报文个数

Total packets forward successly:表示成功转发出去的报文个数(对于广播,组播和本地的IP报文不进行转发,交给IP模块处理)。

Total packets receive:表示收到报文的总数。  

7.1.4   Show version module fsc

显示快速转发模块版本信息 。

show ip module fsc

参数

缺省

命令模式

全局配置态或接口配置态或管理态。

使用说明

当前版本为0.0.0

示例

router>enable

router#show version module fsc

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

发表于

我来说两句

0 条评论
登录 后参与评论

相关文章

来自专栏SDNLAB

源码解读ODL与OpenFlow交换机建立过程

编者按:OpenDaylight两大技术特色:1.采用了OSGi框架;2.引入了SAL,而今天我们主要介绍服务抽象层(SAL)适配的南向协议之一OF协议模块。 ...

3814
来自专栏Danny的专栏

必备的网络常用测试命令(ping命令)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/huyuyang6688/article/...

3412
来自专栏林冠宏的技术文章

基于 xorm 的服务端框架 XGoServer

作者:林冠宏 / 指尖下的幽灵 掘金:https://juejin.im/user/587f0dfe128fe100570ce2d8 博客:htt...

2745
来自专栏刘望舒

Android网络编程(八)源码解析OkHttp中篇[复用连接池]

1.引子 在了解OkHttp的复用连接池之前,我们首先要了解几个概念。 TCP三次握手 通常我们进行HTTP连接网络的时候我们会进行TCP的三次握手,然后传输数...

32810
来自专栏互联网杂技

前端进阶-让你升级的网络知识

在正文之前,我想问大家一个问题: 问:亲,你有基础吗? 答: 有啊,你说前端吗? 不就是HTML,JS,CSS 吗? so easy~ 问: oh-my-zsh...

3918
来自专栏移动开发的那些事儿

TCP问题分析

![tcp1.jpg](http://upload-images.jianshu.io/upload_images/1609288-0260d9484b...

2063
来自专栏Android中高级开发

Android开发之漫漫长途 XIX——HTTP

该文章是一个系列文章,是本人在Android开发的漫漫长途上的一点感想和记录,我会尽量按照先易后难的顺序进行编写该系列。该系列引用了《Android开发艺术探索...

1252
来自专栏c#开发者

BizTalk 2010/2013 EDI B2B项目实践(1)

BizTalk 2010/2013 EDI B2B项目实践(1) BizTalk开发标准EDI B2B是件非常容易的事情,但对于初学者可能有很多专业术语不太理解...

3656
来自专栏老安的博客

openstack windows 镜像密码注入的问题

2292
来自专栏黄子玥的专栏

深入理解websocket传输过程

上一篇已经大概介绍了websocket是基于tcp传输的上层协议,且握手方式借用了http的过程,这个过程我们通过一个强大的网络抓包工具wires...

2514

扫码关注云+社区

领取腾讯云代金券