object file (xx.a(xx.o)) was built for newer iOS version (10.3) than being linked (10.2)

BUG出现情景: 自己打包的静态库,在引用的时候编译报警告错误。

原因:

看下面的图就明白了

第一张:这是打包静态库最低要求SDK版本

第二张:这是运用工程SDK最低版本

解决办法:静态库版本低于等于运行工程版本即可。

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

发表于

我来说两句

0 条评论
登录 后参与评论

扫码关注云+社区

领取腾讯云代金券