前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU Ellipse(simpson积分)

HDU Ellipse(simpson积分)

作者头像
attack
发布2019-01-30 16:43:22
3940
发布2019-01-30 16:43:22
举报

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2677    Accepted Submission(s): 1208

Problem Description

Math is important!! Many students failed in 2+2’s mathematical test, so let's AC this problem to mourn for our lost youth.. Look this sample picture:

A ellipses in the plane and center in point O. the L,R lines will be vertical through the X-axis. The problem is calculating the blue intersection area. But calculating the intersection area is dull, so I have turn to you, a talent of programmer. Your task is tell me the result of calculations.(defined PI=3.14159265 , The area of an ellipse A=PI*a*b )

Input

Input may contain multiple test cases. The first line is a positive integer N, denoting the number of test cases below. One case One line. The line will consist of a pair of integers a and b, denoting the ellipse equation

, A pair of integers l and r, mean the L is (l, 0) and R is (r, 0). (-a <= l <= r <= a).

Output

For each case, output one line containing a float, the area of the intersection, accurate to three decimals after the decimal point.

Sample Input

2 2 1 -2 2 2 1 0 2

Sample Output

6.283 3.142

Author

威士忌

Source

HZIEE 2007 Programming Contest

Recommend

lcy   |   We have carefully selected several similar problems for you:  1722 1727 1721 1726 1725

直接强上simpso积分就行

稍微有点卡精度

代码语言:javascript
复制
#include<cstdio>
#include<cmath>
int N;
double a, b, L, R;
double f(double x) {
    return 2 * b * sqrt(1.0 - (x * x) / (a * a));
}
double sim(double l, double r) {
    return (f(l) + f(r) + 4.0 * f((l + r) / 2.0)) * (r - l) / 6.0;
}
double asr(double l, double r, double eps, double ans) {
    double mid = (l + r) / 2;
    double la = sim(l, mid), ra = sim(mid, r);
    if(fabs(la + ra - ans) < eps) return la + ra;
    return asr(l, mid, eps / 2, sim(l, mid)) + asr(mid, r, eps / 2, sim(mid, r));
}
main() {
    scanf("%d", &N);
    while(N--) {
        scanf("%lf %lf %lf %lf", &a, &b, &L, &R);
        printf("%.3lf\n", asr(L, R, 1e-5, sim(L, R)));
    }
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2018-06-07 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档