前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU 1003 动态规划 求最大子串和

HDU 1003 动态规划 求最大子串和

作者头像
csxiaoyao
发布2019-02-18 17:59:58
8040
发布2019-02-18 17:59:58
举报
文章被收录于专栏:csxiaoyaocsxiaoyao

首先是题目:大意是求最大子串和

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 126443    Accepted Submission(s): 29293

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

代码语言:javascript
复制

2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5

Sample Output

代码语言:javascript
复制

Case 1: 14 1 4 Case 2: 7 1 6

代码语言:javascript
复制
#include<stdio.h>
void main()
{
	int cases,i,m,n,sum,max,start,end,laststart,temp;
	while(scanf("%d",&cases)!=EOF)
	{
		for(m=1;m<=cases;m++)
		{
			scanf("%d",&n);
			sum=0;
			max=-1001;//*****
			start=end=laststart=0;
			for(i=0;i<n;i++)
			{	
				scanf("%d",&temp);
				sum+=temp;
                if(sum>max)
				{
                    start=laststart;
                    end=i;
                    max=sum;
                }
                if(sum<0)
				{
                    laststart=i+1;
                    sum=0;
                }
			}
			printf("Case %d:\n",m);
			printf("%d %d %d\n",max,start+1,end+1);
			if(m!=cases)
				printf("\n");
		}
	}
}

个人小结 1、设置一个laststart用来记录上一个开始的位置 2、sum设为0,max设为-1001,题目有数据范围-1000到1000

本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2014年02月16日,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 首先是题目:大意是求最大子串和
  • Max Sum
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档