前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >2017 ACM-ICPC 亚洲区(乌鲁木齐赛区)网络赛- A. Banana

2017 ACM-ICPC 亚洲区(乌鲁木齐赛区)网络赛- A. Banana

作者头像
Enterprise_
发布2019-02-21 17:09:28
5570
发布2019-02-21 17:09:28
举报
文章被收录于专栏:小L的魔法馆小L的魔法馆
  • 题目来源:Banana
  • 题目描述和输出: Bananas are the favoured food of monkeys.

In the forest, there is a Banana Company that provides bananas from different places.

The company has two lists.

The first list records the types of bananas preferred by different monkeys, and the second one records the types of bananas from different places.

Now, the supplier wants to know, whether a monkey can accept at least one type of bananas from a place.

Remenber that, there could be more than one types of bananas from a place, and there also could be more than one types of bananas of a monkey’s preference.

Input Format

The first line contains an integer T, indicating that there are T test cases.

For each test case, the first line contains two integers N and M, representing the length of the first and the second lists respectively.

In the each line of following N lines, two positive integers i, j,i,j indicate that the i-th monkey favours the j-th type of banana.

In the each line of following MM lines, two positive integers j, k,j,k indicate that the j-th type of banana could be find in the k-th place.

All integers of the input are less than or equal to 50.

Output Format

For each test case, output all the pairs x, y,x,y that the x-the monkey can accept at least one type of bananas from the y-th place.

These pairs should be outputted as ascending order. That is say that a pair of x, y,x,y which owns a smaller xx should be output first.

If two pairs own the same x, output the one who has a smaller y first.

And there should be an empty line after each test case.

样例输入

1 6 4 1 1 1 2 2 1 2 3 3 3 4 1 1 1 1 3 2 2 3 3 样例输出

1 1 1 2 1 3 2 1 2 3 3 3 4 1 4 3

  • 题目分析: 第i个猴子喜欢第j种水果,这种水果在第k个地方,将两个关系矩阵压在一起,利用不同的标记分开i,j和j,k,最后输出。 矩阵乘法求传递闭包也是一种思路,但是实现很麻烦.
  • 完整代码:
代码语言:javascript
复制
#include <bits/stdc++.h>
using namespace std;
const int N = 60;
int a[N][N], b[N][N];
int main()
{
    //freopen("2.txt", "r", stdin);
    int T;
    int x, y, z;
    scanf("%d", &T);
    while (T--)
    {
        int n, m;
        memset(a, 0, sizeof(a));
        memset(b, 0, sizeof(b));
        scanf("%d%d", &n, &m);
        for (int i = 0; i < n; i++)
        {
            scanf("%d%d", &x, &y);
            a[x][y] = 1;
        }
        for (int i = 0; i < m; i++)
        {
            scanf("%d%d", &y, &z);
            if (!a[y][z])
                a[y][z] = 2;
            else
                a[y][z] = 3;
        }
        for (int i = 0; i <= 50; i++)
            for (int j = 0; j <= 50; j++)
                for (int k = 0; k <= 50; k++)
                {
                    if ((a[i][k] == 1 && a[k][j] == 2) || (a[i][k] == 1 && a[k][j] == 3) || (a[i][k] == 3 && a[k][j] == 2) || (a[i][k] == 3 && a[k][j] == 3))
                        b[i][j] = 1;
                }
        for (int i = 0; i <= 50; i++)
            for (int j = 0; j <= 50; j++)
            {
                if (b[i][j])
                    printf("%d %d\n", i, j);
            }
        printf("\n");
    }
    return 0;


}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2017年09月09日,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档