wepy踩坑-未发现相关 sass 编译器配置,请检查wepy.config.js文件

执行 wepy build编译的时候,会出现这样的错误

[WARNING] 找不到编译器:wepy-compiler-sass。
[Error] 未发现相关 sass 编译器配置,请检查wepy.config.js文件。

解决办法 查看文档,检查wepy.config.js文件

原因:没有安装sass 编译器,所以需要手动安装和配置一下。

//安装sass
npm i node-sass
//安装wepy-compiler-sass插件
npm install wepy-compiler-sass --save-dev

//配置wepy.config.js
module.exports = {
    "compilers": {
        sass: {
            'outputStyle': 'compressed'
        }
    }
};

好了,再次编译,编译是成功的


原文作者:祈澈姑娘 技术博客:https://www.jianshu.com/u/05f416aefbe1 90后前端妹子,爱编程,爱运营,文艺与代码齐飞,魅力与智慧共存的程序媛一枚。 坚持总结工作中遇到的技术问题,坚持记录工作中所所思所见,对于博客上面有不会的问题,可以加入qq技术交流群聊:649040560。

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

发表于

我来说两句

0 条评论
登录 后参与评论

扫码关注云+社区

领取腾讯云代金券