Swift3.0项目升级到4.2遇到问题

版权声明:转载请标明出处 https://blog.csdn.net/ZY_FlyWay/article/details/88824879

  1. Overriding non-@objc declarations from extensions is not supported 原因: 不支持从扩展中覆盖non-@objc声明 解决:将方法写到主类里
  2. Cannot subscript a value of type ‘[String : Any]’ with an index of type ‘UIImagePickerController.InfoKey’ 最初代码: var image:UIImage? = info[UIImagePickerControllerEditedImage] as? UIImage 修改: var image:UIImage? = info[UIImagePickerController.InfoKey.editedImage.rawValue] as? UIImage
  3. ‘…<’ is unavailable: Any String view index conversion can fail in Swift 4; please unwrap the optional indices 原因: 可选值进行对比 解决: 解包
  4. Swift4.0没有initialize方法 解决:定义一个静态方法,在app启动的时候调用。

待续。。

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

发表于

我来说两句

0 条评论
登录 后参与评论

扫码关注云+社区

领取腾讯云代金券