Ubuntu 18.04.2 LTS nvidia-docker2 : 依赖: docker-ce (= 5:18.09.0~3-0~ubuntu-bionic)

平台:Ubuntu 18.04.2 LTS nvidia-docker2 版本:2.0.3 错误描述:在安装nvidia-docker2的时候报dpkg依赖错误 nvidia-docker2 : 依赖: docker-ce (= 5:18.09.0~3-0~ubuntu-bionic) 先看一下依赖关系,我的docker-ce版本是17,太低

apt-cache madison nvidia-docker2 nvidia-container-runtime

解决办法:更换到官方docker安装源,指定版本安装 先卸载所有的旧版本docker

sudo apt-get remove docker* --purge
  1. 安装包以允许通过HTTPS使用存储库
sudo apt-get install \
    apt-transport-https \
    ca-certificates \
    curl \
    software-properties-common
  1. 添加Docker的官方GPG密钥:
curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -
sudo apt-key fingerprint 0EBFCD88

通过搜索指纹的最后8个字符,确认您现在拥有指纹9DC8 5822 9FC7 DD38 854A E2D8 8D81 803C 0EBF CD88的密钥。

  1. 添加到源

即使您还想从边缘或测试存储库安装构建,您始终需要稳定的存储库。要添加边缘或测试存储库,请在以下命令中的单词stable之后添加单词edge或test(或两者)

sudo add-apt-repository \
   "deb [arch=amd64] https://download.docker.com/linux/ubuntu \
   $(lsb_release -cs) \
   stable"
  1. 最后
sudo apt-get install -y nvidia-docker2

注意,到这就结束是因为docker-ce18.09.0已经自动安装 如果颠倒顺序就是:

sudo apt-get install docker-ce=18.09.0
sudo apt-get install -y nvidia-docker2

吐槽:CSDN上面写的都是些什么玩意儿?不懂请退圈,别误导新人

(adsbygoogle = window.adsbygoogle || []).push({});

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

发表于

我来说两句

0 条评论
登录 后参与评论

扫码关注云+社区

领取腾讯云代金券