在对 Angular 的文档 aio 进行编译的时候提示错误

error angular-examples-master@1.0.0: The engine "yarn" is incompatible with this module. Expected version ">=1.10.1 <1.14.0". Got "1.14.0"
error Found incompatible module
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
C:\Users\Yucheng\Documents\WorkDir\Repository\Angular\angular-cn\aio\node_modules\yargs\yargs.js:1078
else throw err
^

根据错误的提示是 Yarn 的版本过高了。

请需要根据提示使用 Yarn 1.13 版本就可以了。我们在 aio 文档进行编译的时候,发现如果 yarn 的版本过高的话是没有办法编译成功的,因此请不要按照过高的 yarn 版本。

原创声明,本文系作者授权云+社区发表,未经许可,不得转载。

如有侵权,请联系 yunjia_community@tencent.com 删除。

发表于

我来说两句

0 条评论
登录 后参与评论

扫码关注云+社区

领取腾讯云代金券