linux服务器搭建之路2-安装git最新版本

centos自带的git还是1.x版本,已经很老了,建议安装新版本,步骤如下:

1. 卸载老版本并安装依赖

sudo yum remove git

yum install libcurl-devel expat-devel perl-ExtUtils-MakeMaker package   -y

依赖中curl是必须要有的,不然安装完成后会出现git clone 不能使用

2. 安装新版本

先去官网查看新版本,例如我现在的最新版本就是2.18.0,根据版本就该链接

  • 下载文件
wget https://github.com/git/git/archive/v2.18.0.tar.gz
  • 解压
tar zxvf v2.18.0.tar.gz 
cd git-2.18.0/
  • 安装
make configure
./configure --prefix=/usr/local/git --with-iconv=/usr/local/libiconv
make all doc
sudo make install install-doc install-html
  • 修改环境变量
vim ~/.bashrc

在末尾加上

export PATH=/usr/local/git/bin:$PATH

保存后使其立即生效

source ~/.bashrc
  • 验证其是否生效
git --version

3. 报错处理

错误代码:`Permission denied (publickey). fatal: 无法读取远程仓库。

请确认您有正确的访问权限并且仓库存在。` 这是因为没有rsa导致的。 解决办法:

  • 添加本地rsa
ssh-keygen -t rsa

一路回车,直到完成。

  • 将rsa添加到github上面。 登录github.com --AccountSetting–ssh 点击Add,复制~/.ssh/id_rsa.pub的内容到github的ssh中。

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

发表于

我来说两句

0 条评论
登录 后参与评论

扫码关注云+社区

领取腾讯云代金券