专栏首页力哥聊运维与云计算openvswitch配置端口绑定

openvswitch配置端口绑定

openvswitch配置端口绑定

测试环境如下

网络设备 cisco 2960s

服务器 dell r610

操作系统 fedora 15+update

服务器上添加一块intel 82571双端口的网卡,分别接交换机的1口,2口

配置如下

1 交换机配置

interface Port-channel1

switchport trunk allowed vlan 200

switchport mode trunk

!

interface FastEthernet0

no ip address

shutdown

!

interface GigabitEthernet0/1

switchport trunk allowed vlan 200

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

!

interface GigabitEthernet0/2

switchport trunk allowed vlan 200

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

!

2 服务器配置

ovs-vsctl add-bond br0 pc p1p1 p1p2

ovs-vsctl -- set port pc lacp=paasive

在交换机上查看

snda-intel-lab-2960s-250# sh int port-channel 1

Port-channel1 is up, line protocol is up (connected)

Hardware is EtherChannel, address is 88f0.77c0.8f01 (bia 88f0.77c0.8f01)

MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, link type is auto, media type is unknown

input flow-control is off, output flow-control is unsupported

Members in this channel: Gi0/1 Gi0/2

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 1000 bits/sec, 1 packets/sec

5 minute output rate 2000 bits/sec, 2 packets/sec

1680 packets input, 168447 bytes, 0 no buffer

Received 90 broadcasts (52 multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 52 multicast, 0 pause input

0 input packets with dribble condition detected

2293 packets output, 211880 bytes, 0 underruns

0 output errors, 0 collisions, 8 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

可以看到portchannel已经起来了

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • unixbench详解

    unixbench是一套unix系统基准测试套件。unixbench的设计目标是为类unix系统提供一套基本的指标,所以有许多项目测试系统各方面的性能。各项的...

    力哥聊运维与云计算
  • kvm虚拟化7月更新日志

    https://fedoraproject.org/wiki/Releases/19/FeatureList

    力哥聊运维与云计算
  • CentOS7全自动安装光盘制作详解

    系统安装的时候,按照ks.cfg文件的内容进行安装,我们把ks.cfg文件放到isolinux目录下:

    力哥聊运维与云计算
  • Python的is None vs ==None

    想要弄清楚is None和==None的区别,首先要清楚==和is的区别。==和is的区别如下:

    Tyan
  • 学习日志-python基础01,浅谈p

    py3study
  • Python 循环语句

    Python提供了for循环和while循环(在Python中没有do..while循环):

    py3study
  • 【群友记录】记录写rust遇到一个坑

    目的是想在map新增key的时候做一些处理,看起来很美好,编译通过了,但是多了警告 warning: value assigned to is_new is n...

    MikeLoveRust
  • sql sever模糊查询和聚合函数

    使用is null 的时候 要确保 查询的列 可以为空! null:   01.标识  空值   02.不是0,也不是空串""   03.只能出现在定义 允许...

    房上的猫
  • 必须要了解的Python关键词

    每种编程语言都会有一些特殊的单词,称为关键词。对待关键词的基本要求是,你在命名的时候要避免与之重复。本文将介绍一下Python中的关键词。关键词不是内置函数或者...

    老齐
  • 腾讯QQ域名防报毒工具V1.4 - 短网址生成

    Youngxj

扫码关注云+社区

领取腾讯云代金券