Android Studio 2.3 升级 gradle 报错

错误提示如下:

Gradle sync failed: Cause: error in opening zip file                Consult IDE log for more details (Help | Show Log)

今天升级 2.2 到 2.3 后打开一个项目提示升级 gradle,就同意了,结果报了上面的错误。

大概原因应该是下载的最新的 gradle 包有问题,新升级后配置的代理失效了。

操作如下:

  1. 删除项目目录下的 .gradle/ 整个项目
  2. 查看项目目录下的 gradle/wrapper/gradle-warpper.propertiesdistributionUrl 的 gradle 版本,比如是 3.3 ,然后去电脑 ~/.gradle/warpper/dists/ (Mac 下的路径,Window 下略有不同)下删除对应版本的 gradle,我这里是 gradle-3.3-all
  3. 然后重启 Android Studio 并进行同步

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

发表于

我来说两句

0 条评论
登录 后参与评论

扫码关注云+社区

领取腾讯云代金券