前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >10300 - Ecological Premium

10300 - Ecological Premium

作者头像
熙世
发布2019-07-15 16:24:28
4150
发布2019-07-15 16:24:28
举报
文章被收录于专栏:Code思维奇妙屋

Problem A

Ecological Premium

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

German farmers are given a premium depending on the conditions at their farmyard. Imagine the following simplified regulation: you know the size of each farmer's farmyard in square meters and the number of animals living at it. We won't make a difference between different animals, although this is far from reality. Moreover you have information about the degree the farmer uses environment-friendly equipment and practices, expressed in a single integer greater than zero. The amount of money a farmer receives can be calculated from these parameters as follows. First you need the space a single animal occupies at an average. This value (in square meters) is then multiplied by the parameter that stands for the farmer's environment-friendliness, resulting in the premium a farmer is paid per animal he owns. To compute the final premium of a farmer just multiply this premium per animal with the number of animals the farmer owns.

Input

The first line of input contains a single positive integer n (<20), the number of test cases. Each test case starts with a line containing a single integer f (0<f<20), the number of farmers in the test case. This line is followed by one line per farmer containing three positive integers each: the size of the farmyard in square meters, the number of animals he owns and the integer value that expresses the farmer’s environment-friendliness. Input is terminated by end of file. No integer in the input is greater than 100000 or less than 0.

Output

For each test case output one line containing a single integer that holds the summed burden for Germany's budget, which will always be a whole number. Do not output any blank lines.

Sample Input

代码语言:javascript
复制
3
代码语言:javascript
复制
5
代码语言:javascript
复制
1 1 1
代码语言:javascript
复制
2 2 2
代码语言:javascript
复制
3 3 3
代码语言:javascript
复制
2 3 4
代码语言:javascript
复制
8 9 2
代码语言:javascript
复制
3
代码语言:javascript
复制
9 1 8
代码语言:javascript
复制
6 12 1
代码语言:javascript
复制
8 1 1
代码语言:javascript
复制
3
代码语言:javascript
复制
10 30 40
代码语言:javascript
复制
9 8 5
代码语言:javascript
复制
100 1000 70

Sample Output

38

86

7445


(The Joint Effort Contest, Problem setter: Frank Hutter)

注:每块土地的三个参数:x , y , z。

x代表这块土地所占空间;

y代表这块土地上的动物数;

z代表这块土地的经济效益;

根据题意:每只动物所需支付的金钱为:x/y*z;

即所有动物所需金钱为:x/y*z*y=x*z;

代码:

代码语言:javascript
复制
#include "stdio.h"

int main()
{
    long long sum,x,y,z;
    int n,f;
    scanf("%d",&n);
    while(n--)
    {
        sum=0;
        scanf("%d",&f);
        while(f--)
        {
            scanf("%lld %lld %lld",&x,&y,&z);
            sum=sum+x*z;
        }
        printf("%lld\n",sum);
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2014-04-06 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档