专栏首页网络技术联盟站华为实操系列 | 交换机在局域网中是怎么应用的,看完你肯定懂了!

华为实操系列 | 交换机在局域网中是怎么应用的,看完你肯定懂了!

  • 编辑 | 排版 | 制图 | 测试 | ©瑞哥
  • 此文用时0小时48分钟,原创不易,坚持更不易,希望我的每一份劳动成果都可以得到大家的一个【在看】

交换机在局域网中的应用

交换机在局域网中的应用分为两种:

1、作为二层交换机使用,为多个用户划分VLAN,实现同网段数据访问。

2、作为三层交换机使用,部署用户的网关,实现跨网段数据访问。

三种典型组网

PC属于同一局域网同一网段时,交换机不需要任何配置,可以直接使用!

二层交换机在局域网中的应用

如图所示:

用户PC1和PC2的属于不同的VLAN域。PC1属于VLAN2,PC2属于VLAN 3。PC1的IP地址是10.2.1.2/24,网关是10.2.1.1/24;PC2的IP地址是10.3.1.3/24 ,网关是10.3.1.1/24 。

用户PC1和PC2的IP地址属于同一网段,且网关都部署在路由器上。

配置思路和配置步骤

子接口1:

IP地址是10.2.1.1/24, 终结VLAN2。

子接口2:

IP地址是10.3.1.1/24,终结VLAN3。

第一步:批量创建VLAN 2和VLAN 3

<Switch> system-view

[Switch] vlan batch 2 to 3

第二步:配置连接PC的接口GE0/0/1和GE0/0/2,以access方式加入对应VLAN。

[Switch] interface GigabitEthernet 0/0/1

[Switch-GigabitEthernet0/0/1] port link-type access

[Switch-GigabitEthernet0/0/1] port default vlan 2

[Switch-GigabitEthernet0/0/1] quit

[Switch] interface GigabitEthernet 0/0/2

[Switch-GigabitEthernet0/0/2] port link-type access

[Switch-GigabitEthernet0/0/2] port default vlan 3

[Switch-GigabitEthernet0/0/2] quit

第三步:配置连接路由器的接口GE0/0/3,以trunk方式加入VLAN 2和VLAN 3。

[Switch] interface GigabitEthernet 0/0/3

[Switch-GigabitEthernet0/0/3] port link-type trunk

[Switch-GigabitEthernet0/0/3] port trunk allow-pass vlan 2 to 3

[Switch-GigabitEthernet0/0/3] quit

本文分享自微信公众号 - 网络技术联盟站(it666lmz),作者:夏轩

原文出处及转载信息见文内详细说明,如有侵权,请联系 yunjia_community@tencent.com 删除。

原始发表时间:2019-05-19

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • 华为网络工程师实战 | 如何配置重定向实现策略路由?

    在企业网络中,很多用户希望能够在传统路由转发的基础上根据自己定义的策略进行报文转发和选路,即策略路由。交换机上一般使用重定向来实现策略路由。

    网络技术联盟站
  • Segment Routing之IPv6 SR概述

    IPv6 SR(SRv6)是指在IPv6网络中使用Segment Routing,将IPv6地址作为SID,SRv6 节点根据SID对报文进行 转发。SRv6将...

    网络技术联盟站
  • 锐捷路由技术 | NTP配置

    RSR路由器可以做为NTP的服务器,但是现网大部分情况下并非以路由器做为NTP服务器。

    网络技术联盟站
  • 6.1.3 系统总线的结构

    单总线结构将CPU、主存、I/O设备(通过I/O接口)都挂在一组总线上,运行I/O设备之间、I/O设备与主存之间直接交换信息。CPU与主存,CPU与外设之间可以...

    week
  • 500Startups第16次Demo Day里有这10家创业企业

    YoDerm ? 想找到一名皮肤病专家让你看病非常难,而且也很耗时间,但是美国数百万青春痘患者可不想等—要么就花钱让专家给你诊断。YoDerm将青春痘患者和...

    点滴科技资讯
  • Dav1d移动端解码高清视频达30FPS

    LiveVideoStack正在招募编辑/记者/运营,与全球顶尖多媒及技术专家和LiveVideoStack年轻的伙伴一起,推动多媒体技术生态发展。了解岗位信息...

    LiveVideoStack
  • 弗拉特利定律:Illumina如何缔造基因革命

    大数据文摘
  • Java 8 新特性(一)lambda表达式

    Java 9 好像也快出了,不过我连Java 8的新特性都还没认真研究过,所以这几篇文章就是来介绍Java 8的新特性的。首先,第一个重要的特性就是传说中的la...

    乐百川
  • 大咖丁奇:加唯一索引怎么会导致丢数据?

     点击上方蓝字每天学习数据库 一起构建MySQL知识网络,我是林晓斌,今天的文章我们从索引说起。 ? 林晓斌 林晓斌,网名丁奇,腾讯云数据库负责人,数据库领域...

    腾讯云数据库 TencentDB
  • Mysql索引知识详谈

    原文地址:https://www.t-io.org/1159984867644153856

    talent-tan

扫码关注云+社区

领取腾讯云代金券