专栏首页网络技术联盟站网络工程师从入门到精通-通俗易懂系列 | VLAN这些知识点都涉及到了,了解一下吧!

网络工程师从入门到精通-通俗易懂系列 | VLAN这些知识点都涉及到了,了解一下吧!

交换基础

典型园区网结构

核心层

汇聚层

接入层

也可以没有汇聚层

这种架构叫做大二层

交换机功能

学习MAC地址

根据MAC地址进行转发

打破二层环路(依靠STP协议)

交换机寻址

学习源MAC地址,与接口做对应关系,存放到MAC地址表中

查看目的MAC地址,根据MAC地址表条目进行转发

没有查到目的MAC地址,则会泛洪

泛洪:除了收到数据帧的接口,其他的接口都发送一遍

VLAN

虚拟局域网

主要就是赋予交换机隔离广播域的能力

集线器:所有端口处在一个冲突域,整机属于一个广播域

交换机:每个端口独立的冲突域,整机属于一个广播域,

路由器:每个端口都属于独立的冲突域和广播域;

一个VLAN属于一个广播域,不同的VLAN属于不同的广播域

广播,单播不能跨VLAN传递

一个VLAN一般为一个网段,一个VLAN可以有多个成员

不同VLAN间不能互访,需要依靠三层设备,路由器,三层交换机

VLAN是基于交换机接口

VLAN模式:

静态VLAN,手动登录设备配置交换机端口

动态VLAN,依靠VMPS服务器,动态下发,太麻烦,需要登记全网设备MAC地址到服务器

现网常用静态VLAN

interface e0/1

switchport mode access

switchport access vlan 10

一个Access模式的接口,只能属于一个vlan

TIPS

在模拟环境中,同一个VLAN下,两个设备(路由器)处在不同网段,是可以进行通信的

其目的,主要是让大家更加深入的理解VLAN的概念与交换机的转发机制

真实电脑会有些差异,但也能实现,没啥意义

Trunk

当一条链路,需要承载多VLAN信息的时

或者多个VLAN需要跨越交换机进行通信时,需要使用trunk来实现

交换机的端口 access,Trunk模式,可以自动协商

叫DTP协议,CISCO私有

现网一般为静态指定

封装协议:

ISL:

CISCO私有,没有破坏原始以太网数据帧,而是在原始数据帧前面,加入ISL头部

基于硬件封装,速度快

只能承载1024个VLAN,现网不常用

802.1Q

公有协议,破坏原始以太网数据帧,在原始以太网数据帧中插入了802.1Q头部

并且重新计算FCS

NATIVE VLAN 不打标签,默认是VLAN1

在端口下使用switchport trunk native vlan X 可以修改,两端建议保持一致,否则会出现流量串流

承载4096个VLAN,现网常用

配置:

interface Ethernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

CISCO 交换机默认传递所有VLAN流量

可使用 switchport trunk allow vlan X 单独放行某个VLAN,

不同的IOS版本中配置有协议不同,有些设备,能支持ISL与801.Q封装

所以在配置的时候,需要指定 switchport trunk encapsulation 封装模式

CISCO 没有Hybrid模式

VTP

VLAN中继协议,CISCO私有

在交换机之间的Trunk链路上,传递配置的VLAN信息,

通过组播MAC地址01-00-0C-CC-CC-CC传递

5分钟定时更新,或者触发更新

三种模式:

配置:

SW1(config)#vtp domain CCNA

SW1(config)#vtp mode server

SW1(config)#vtp password CCNA

SW1(config)#vtp version 2

域名,密码有大小写敏感,信息必须一致,否则无法同步

两台交换机处于不同的VTP域中,会提示不匹配消息,

VTP修剪

在交换机之间,修剪掉多余VLAN的流量,由于交换机之间配置了Trunk链路,广播数据帧会通过Trunk泛洪到其他交换机

VTP可以根据交换机的端口access vlan成员,动态的将不需要的VLAN流量修剪掉

VTP Pruning默认关闭

VTP Pruning只能在Server 上开启

Tips:(VTP仍然会通告VLAN信息,只是会修剪Client不需要的VLAN流量),

这个需要明确一下

例如:

SW1上的VLAN10的广播流量,不会被传递到SW2,因为在Trunk上就被修剪掉了

还有另外的方式,叫做手动修剪,通过配置Trunk放行VLAN的方式

在没启用VTP Pruning 的情况下,Trunk默认让所有VLAN通过,可使用一下命令手动修剪。

手动修剪配置:

interface Ethernet0/1

switchprot trunk allowed vlan ?

ALL // 允许所有VLAN 通过

remove // 移除允许通过的VLAN

add // 增加允许通过的VLAN

except //除了这些VLAN以外,其他都允许,可以使用单个或者一个范围

none // 不允许所有VLAN 通过

第二种手动修剪配置:

interface Ethernet0/1

switchport trunk pruning vlan ?

WORD VLAN IDs of the allowed VLANs when this port is in trunking mode

add add VLANs to the current list

except all VLANs except the following

none no VLANs

remove remove VLANs from the current list

本文分享自微信公众号 - 网络技术联盟站(it666lmz),作者:夏轩

原文出处及转载信息见文内详细说明,如有侵权,请联系 yunjia_community@tencent.com 删除。

原始发表时间:2019-07-07

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • 网络工程师必看 | 从动态图看VLAN技术,建议收藏!

    VLAN(Virtual Local Area Network)即虚拟局域网,是将一个物理的LAN在逻辑上划分成多个广播域的通信技术。VLAN内的主机间可以直接...

    网络技术联盟站
  • 做了几年的网工也未必了解VLAN和VXLAN的区别,今天我来告诉你!

    资深网络工程师对于vlan和vxlan应该能够区别开,但是刚入行、或者平时不太关注技术栈的网工们对于vlan和vxlan常常混淆,甚至都没有听过vxlan,那么...

    网络技术联盟站
  • 交换机与VLAN:以办公室为例趣讲一波!

    上一次,我们在宿舍里组建了一个本地的局域网 LAN,可以愉快地玩游戏了。这是一个非常简单的场景,因为只有一台交换机,电脑数目很少。今天,让我们切换到一个稍微复杂...

    网络技术联盟站
  • VLAN是什么?划分VLAN的作用及方法

    有朋友提到了如何划分vlan,其实划分vlan是网络技术应用中必不可少,很多的网络都需要进行vlan的划分,今天就一起了解下这方面的内容。

    瑞新
  • 网络工程师必看 | 从动态图看VLAN技术,建议收藏!

    VLAN(Virtual Local Area Network)即虚拟局域网,是将一个物理的LAN在逻辑上划分成多个广播域的通信技术。VLAN内的主机间可以直接...

    网络技术联盟站
  • Python黑帽编程 3.4 跨域VLAN

    Python黑帽编程 3.4 跨域VLAN VLAN(Virtual Local Area Network),是基于以太网交互技术构建的虚拟网络,既可以将同一物...

    用户1631416
  • (收藏必看)HCIE | 彻底搞懂LAN技术-CSS、Eth-trunk、MSTP、vlan

    高可靠性:集群系统两台成员交换机之间冗余备份,同时利用链路聚合功能实现跨设备的链路冗余备份。

    网络技术联盟站
  • 「镁客·请讲」华捷艾米:体感技术最早将于明年年底爆发

    镁客网
  • uni-app 结合云函数开发小程序博客(三):接入云函数,实现完善的列表刷新机制

    因为项目做的是博客demo, 首页进来想给人直观的就能看到文章,看到分类。所以想的一个是可以左右滑动,切换分类,一个是页面以列表形式,直接 list 渲染。类似...

    一只图雀
  • 地平线机器人杨铭:深度神经网络在图像识别应用中的演化

    机器之心整理 编辑:杜雪 4 月 15 日,杨铭博士在机器之心线下活动 Interface 上做了一次题为「深度神经网络在图像识别应用中的演化」的演讲。这篇文章...

    机器之心

扫码关注云+社区

领取腾讯云代金券