专栏首页网络技术联盟站网络工程师从入门到精通-通俗易懂系列 | 看完这篇文章,突然觉得OSPF路由协议好简单啊!

网络工程师从入门到精通-通俗易懂系列 | 看完这篇文章,突然觉得OSPF路由协议好简单啊!

OSPF路由协议

在同一个OSPF自制系统内每一台运行OSPF协议的路由器总是将本地网络的连接状态用LSA(链路状态通告)描述,并广播到整个自制系统中去。这样,每台路由器都收到了自制系统中所有路由器生成的LSA,这些LSA的集合组成了LSDB(链路状态数据库),这样所有的OSPF路由器都维护一个相同的描述自治系统内部结构的数据库。

特点

· 公有协议,管理距离是110;IP协议号为89

· OSPF路由协议采用cost作为度量标准;

· 每隔30分钟定时发送更新,触发更新

· 支持等价负载均衡;

· 支持区域划分,构成层次化的网络,提供路由分级管理;

· 支持简单口令和MD5认证;

· 以组播方式(224.0.0.5或224.0.0.6)传送协议数据包;

· OSPF维护邻居表、拓扑表和路由表。

OSPF区域

OSPF COST计算

OSPF三张表

OSPF邻接与邻居区别

OSPF Router-ID

· Router-ID用来标识同一个OSPF域中的路由器,全网唯一

· LSBDs中,使用Router-ID区分不同的路由器

· Router-ID可以通过手动指定,或者自动选举

自动选举:若有Loopback接口,则选最大的Loopback接口,若无,则选举活跃的物理接口中IP地址为最大的。

手动指定:(config-router)#router-id 1.1.1.1

想让手动指定的Router-ID生效.必须清除进程,clear ip ospf process

OSPF DR/BDR:

· OSPF路由器也是通过Hello数据报文来发现邻居,然后进入2-Way状态,在这个状态下选举DR和BDR。

· 选举是利用Hello报文内的ID和Priority(优先级)来确定。优先级大小为0-255(默认值为1,0代表不参加选举)

· 优先级值最高的路由器成为DR。

· 修改接口优先级 ip ospf priority xx

· 如果优先级值大小一样,则Router-ID最高的路由器选举为DR,Router-ID次之为BDR。

· 并且DR具有非抢占性,要么重启路由器,要么clear ip ospf process

· DR负责向其他路由器发送更新信息,BDR则监控DR状态。

· DR出故障时,BDR升级为DR,并选举新的BDR。

DRother 用224.0.0.6通知DR/BDR路由器,监听224.0.0.5

DR/BDR利用组播地址224.0.0.5通知DRother路由器,监听224.0.0.6

OSPF单区域配置

R1:

router ospf 1
router-id 1.1.1.1
network 1.1.1.1 0.0.0.0 area 0
network 192.168.12.1 0.0.0.0 area 0
!

R2:

router ospf 1
router-id 2.2.2.2
network 2.2.2.2 0.0.0.0 area 0
network 192.168.12.2 0.0.0.0 area 0
network 192.168.23.2 0.0.0.0 area 0
!

R3:

router ospf 1
router-id 3.3.3.3
network 3.3.3.3 0.0.0.0 area 0
network 192.168.23.3 0.0.0.0 area 0
!

OSPF多区域配置

R1/R2配置不再赘述:

R3:

router ospf 1
router-id 3.3.3.3
network3.3.3.3 0.0.0.0 area 0
network 192.168.23.3 0.0.0.0 area 0
network 192.168.34.3 0.0.0.0 area 1
!

R4:

router ospf 1
router-id 4.4.4.4
network 4.4.4.4 0.0.0.0 area1
network 192.168.34.4 0.0.0.0 area 1
network 192.168.0.0 0.0.3.255 area 1
!

OSPF区域间汇总

必须在ABR汇总

R3:

router ospf 1
area 1 rang 192.168.0.0 255.255.252.0
!

默认路由

OSPF默认路由:(本地有静态默认路由)

R1:

ip route 0.0.0.0 0.0.0.0 x.x.x.x
router ospf 1
default-information originate

OSPF默认路由:(本地没有静态默认路由)

R1:

router ospf 1
default-information originate always //强制下发

OSPF默认路由:(重分布)

R1:

ip route 0.0.0.0 0.0.0.0 x.x.x.x
router ospf 1
redistribute static metric 1 subnets

OSPF相关命令

show ip ospf interface brief //查看接口关于OSPF的信息
show ip ospf interface serial 1/0 //查看某个接口关于OSPF的详细信息
show ip route ospf //查看OSPF路由
show ip ospf neighbor //查看ospf邻居
show ip ospf database //查看ospf链路状态数据库
debug ip ospf adj //查看OSPF邻居关系建立过程
debug ip ospf hello //查看OSPF hello包
debug ip ospf events //查看OSPF相关事件

本文分享自微信公众号 - 网络技术联盟站(it666lmz),作者:夏轩

原文出处及转载信息见文内详细说明,如有侵权,请联系 yunjia_community@tencent.com 删除。

原始发表时间:2019-07-18

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • HCIP学习 | OSPF魔鬼知识点,你又知道多少呢?

    OSPF 是 Open Shortest Path First 的简称,OSPF 是一种基于 SPF 算法的链路状态协议,同时 OSPF 也是一种内部网...

    网络技术联盟站
  • 锐捷路由技术 | OSPF技术

    OSPF(OpenShortest Path First)为 IETF OSPF 工作组开发的一种基于链路状态的内部网关路由协议。OSPF 是专为 IP 开发的...

    网络技术联盟站
  • 从零开始学习华为路由交换 | OSPF修改计时器

    网络技术联盟站
  • 锐捷路由技术 | OSPF技术

    OSPF(OpenShortest Path First)为 IETF OSPF 工作组开发的一种基于链路状态的内部网关路由协议。OSPF 是专为 IP 开发的...

    网络技术联盟站
  • 新特性解读 | MySQL 8.0 语句摘要功能介绍

    资深数据库专家,专研 MySQL 十余年。擅长 MySQL、PostgreSQL、MongoDB 等开源数据库相关的备份恢复、SQL 调优、监控运维、高可用架构...

    爱可生开源社区
  • Bitmovin: 视频开发者报告 2018

    今年的视频开发者报告(Video Developer Report)在发布前总共收到了来自6大洲67个国家的456份调研问卷。该报告旨在对当前工业界使用的视频技...

    用户1324186
  • 腾讯云使用kubeadm安装k8s

    k8s是现在最热门的技术之一。常混在技术圈的你,是否有种蠢蠢欲动的感觉,却因k8s环境的安装复杂性,却放弃。本篇文章将对k8s的安装进行展开。

    暮雨
  • 7个案例15分钟让你了解Python套路!

    古人云:书山有路勤为径 学海无涯苦作舟 。 注:一般标榜着 “ XX天学会XX”、“ XX 分钟了解XX”的文章都不会是让你增长功力的文章,如本文。 随着互联...

    小小科
  • 记discuz的ucenter密码忘记处理方法

    Discuz 的 UCenter 密码默认是首次安装discuz时指定的管理员密码,如果密码忘记了,可以通过下列方法进行重置:

    大大大黑白格子
  • 大佬们是如何使用设计模式

    关于设计模式,如果使用得当,将会使我们的代码更加简洁,并且更具扩展性。本文主要讲解Spring中大佬们是如何使用策略模式,工厂方法模式以及Builder模式。

    用户4143945

扫码关注云+社区

领取腾讯云代金券