专栏首页网络技术联盟站华为网络工程师 | 高级vlan再难咱也不怕,看完这篇文章,原理理解喽,命令也会敲喽!

华为网络工程师 | 高级vlan再难咱也不怕,看完这篇文章,原理理解喽,命令也会敲喽!

高级vlan 的配置之 基于mac地址的vlan

vlan batch 10 20
vlan 10
mac-vlan mac-address 0000-0000-0001
vlan 20
mac-vlan mac-address 0000-0000-0002
interface GigabitEthernet0/0/1
port hybrid untagged vlan 10 20 配置混合接口
mac-vlan enable 启用基于mac地址学习vlan

vlan 高级配置之 基于IP子网划分vlan

sw2 创建vlan 并将相应接口划入相应vlan 和sw1 相连的接口配置trunk

sw1:

int gi 0/0/2
port link-ty trunk
port trunk allow-pass vlan 10 20
interface GigabitEthernet0/0/1 (特殊处理)
port hybrid untagged vlan 10 20
ip-subnet-vlan enable
vlan batch 10 20
vlan 10
ip-subnet-vlan 1 ip 192.168.10.0 255.255.255.0
vlan 20
ip-subnet-vlan 1 ip 192.168.10.0 255.255.255.0

超级vlan

vlan batch 10 20 30
将相关接口划入相应vlan (略)
vlan 30
aggregate-vlan 将vlan30 定义为聚合vlan
access-vlan 10 20 将vlan 10 20 定义为vlan30 的子vlan
int vlan 30
ip add 192.168.1.1 24 该地址将作为vlan 10 和vlan 20 的网关

相同vlan 隔离端口

int gi 0/0/4
port-isolate enable 将4口设置为隔离端口,并加入隔离组1 (默认都会加入隔离组1)
int gi 0/0/1
port-isolate enable

注:同一台交换机相同隔离组的端口不能互访

vlan的映射:vlan mapping (vlan 的翻译)

sw3 sw4 配置vlan 和trunk,交换机和交换机之间级联的接口配置trunk

sw1:

vlan 100
int gi 0/0/1
port link-ty trunk
port trunk allow-pass vlan 100

sw2 :

interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 30 to 31
interface GigabitEthernet0/0/3
port link-type trunk
port trunk allow-pass vlan 32
int gi 0/0/2
port link-type trunk
port trunk allow-pass vlan 100
qinq vlan-translation enable 启用vlan 标签的转换
port vlan-mapping vlan 30 to 39 map-vlan 100 将vlan的标签30-39 转换成100

注:trunk 封装:802.1q 协议

hybrid 混合接口

hybrid 接口是一种混合接口,是华为设备特有的接口。华为交换设备默认的接口封装类型。hybrid 接口同时具备access 和trunk 的两种功能。

将hybrid 口当成access 口来使用:

sw1:

int gi 0/0/1
port hybrid pvid vlan 10
port hybrid untagged vlan 10
interface GigabitEthernet0/0/2
port hybrid pvid vlan 20
port hybrid untagged vlan 20
将hybrid 口当成trunk 来使用:
interface GigabitEthernet0/0/3
port hybrid tagged vlan 10 20

sw2:略

使用hybrid 接口实现特殊通信:

房间之间不能通信,但是每个房间都可以与出口路由器通信

sw1:

本文分享自微信公众号 - 网络技术联盟站(it666lmz),作者:夏轩

原文出处及转载信息见文内详细说明,如有侵权,请联系 yunjia_community@tencent.com 删除。

原始发表时间:2019-07-28

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • 华为网络工程师 | 听说MSTP配置很难?在我这里不存在,这篇文章可以用两字形容:真香!

    Muliti stp 多生成树协议 (华为交换机默认运行mstp)工作原理:将多个vlan 捆绑在一起,运行在一个stp 实例里面,不同实例间的stp互相独立。...

    网络技术联盟站
  • H3CNE实验系列 | 单臂路由

    [H3C-Ethernet1/0/1]port trunk permit vlan all

    网络技术联盟站
  • 思科综合实验 | 模拟器虚拟机三层交换综合实验,举一反三!

    主要是通过dynamips(模拟路由器和交换机)和微软virtualpc(模拟多台客户端和服务器),以及真实电脑(通过物理网卡桥接路由器和真实网络,虚拟...

    网络技术联盟站
  • H3C 2126系列

    1.system-view 进入系统试图 2.sysname GeisNetwork 命名用户名 3.management-vlan vlan-id 指定管理v...

    py3study
  • 【Ceph RGW】Bucket Sharding的设置

    Ceph RGW 会把 bucket 的索引数据存在 index_pool 里,这个索引池,默认叫做 .rgw.buckets.index,如果一个桶有很多对象...

    runzhliu
  • 别让数据坑了你!用置信学习找出错误标注(附开源实现)

    在实际工作中,你是否遇到过这样一个问题或痛点:无论是通过哪种方式获取的标注数据,数据标注质量可能不过关,存在一些错误?亦或者是数据标注的标准不统一、存在一些歧义...

    zenRRan
  • 护理机器人可能率先被公众广泛接受

    认知神经学教授,谢菲尔德机器人中心主任Tony Prescott认为,医疗行业可能会最先改变人们心中机器人的公众形象。为什么?因为这一行业已经认识到机器人有多好...

    机器人网
  • 爬了下Unsplash上的高清壁纸,总有一款适合你

    Unsplash是个高清摄影图片的网站,里面的照片非常精美,分辨率也很高,最重要的是,所有的照片都没有版权,无须向原作者申请授权,即可任意使用。

    数据森麟
  • 在Visual Studio 2015下使用pthread win32编译报错

    版权声明:本文为博主原创文章,转载请注明源地址。 https://blog.csdn.net...

    用户1148648
  • PostSharp 1.0 RTM发布了

        经过了4年的发展,2008年9月11日终于发布了1.0 RTM版本,这个版本已经非常稳定,所有修复的缺陷都是轻微的。可以从这里下载:http://www...

    张善友

扫码关注云+社区

领取腾讯云代金券