编译问题--Could not download kotlin-reflect.jar

问题

在某个没有使用Kotlin的项目中,第一次编译的时候报出:

Could not download kotlin-reflect.jar (org.jetbrains.kotlin:kotlin-reflect:1.2.0)

但是在该工程中并没有使用Kotlin,怀疑是因为Android Studio版本过高并且下载了Kotlin插件的原因,导致在没有使用Kotlin的项目中会出现该问题。

解决方案

在编译的项目中先编译Kotlin的stdlib,在编译通过后再删除即可。

implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk7:1.3.31"

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

发表于

我来说两句

0 条评论
登录 后参与评论

扫码关注云+社区

领取腾讯云代金券