前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >【PAT甲级】A+B in Hogwarts

【PAT甲级】A+B in Hogwarts

作者头像
喜欢ctrl的cxk
发布2019-11-08 14:36:30
2920
发布2019-11-08 14:36:30
举报
文章被收录于专栏:Don的成长史Don的成长史

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。

本文链接:https://blog.csdn.net/weixin_42449444/article/details/89516425

Problem Description:

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

代码语言:javascript
复制
3.2.1 10.16.27

Sample Output:

代码语言:javascript
复制
14.1.28

解题思路:

先把A,B都转换成以Knut为单位进行相加得到一个总和sum(单位:Kunt),然后再把sum转换成Galleon.Sickle.Knut的形式即可。需要注意的是用int型会有一个测试点出现WA,把它改成long long型就好啦。

AC代码:

代码语言:javascript
复制
#include <bits/stdc++.h>
using namespace std;

int main()
{
    long long Ag,As,Ak,Bg,Bs,Bk;   
    scanf("%lld.%lld.%lld %lld.%lld.%lld",&Ag,&As,&Ak,&Bg,&Bs,&Bk);
    long long sum = (Ag*17+As)*29+Ak + (Bg*17+Bs)*29+Bk;   //A+B的总和(单位:Knut)
    long long Knut = sum%29;
    long long Sickle = (sum/29)%17;
    long long Galleon = (sum/29)/17;
    printf("%lld.%lld.%lld\n",Galleon,Sickle,Knut);
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2019-04-25 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Problem Description:
  • Input Specification:
  • Output Specification:
  • Sample Input:
  • Sample Output:
  • 解题思路:
  • AC代码:
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档