前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >【PAT甲级】The Black Hole of Numbers

【PAT甲级】The Black Hole of Numbers

作者头像
喜欢ctrl的cxk
发布2019-11-08 15:41:52
3670
发布2019-11-08 15:41:52
举报
文章被收录于专栏:Don的成长史Don的成长史

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。

代码语言:txt
复制
                 本文链接:[https://blog.csdn.net/weixin\_42449444/article/details/89964089](https://blog.csdn.net/weixin_42449444/article/details/89964089) 

Problem Description:

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

代码语言:javascript
复制
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

代码语言:javascript
复制
6767

Sample Output 1:

代码语言:javascript
复制
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

代码语言:javascript
复制
2222

Sample Output 2:

代码语言:javascript
复制
2222 - 2222 = 0000

解题思路:

这道题跟【PAT乙级】数字黑洞【蓝桥杯】ADV-170 数字黑洞类似。先将输入的那个四位整数拆成4个数字放入一个数组中,然后用这4个数字升序排列、降序排列分别组成最小的数字和最大的数字,用大数减去小数可以得到一个新的数字 输出这个计算式,直到结果是6174或者0时为止。

AC代码:

代码语言:javascript
复制
#include <bits/stdc++.h>
using namespace std;

int arr2num(int a[])   //把数组里的数按照下标次序来组成一个新的数字
{
    int n = 0;
    for(int i = 0; i < 4; i++)
    {
        n = n*10 + a[i];
    }
    return n;
}

int main()
{
    int n;
    cin >> n;
    int a[4];
    do{
        for(int i = 0; i < 4; i++)   //把各位数存入数组里面
        {
            a[i] = n%10;
            n /= 10;
        }
        sort(a,a+4);    //升序排列
        int x = arr2num(a);     //得到由数组a中元素组成的最大数字
        sort(a,a+4,greater<int>());   //降序排列
        int y = arr2num(a);     //得到由数组a中元素组成的最小数字
        n = y-x;    //作差得到一个新的四位数
        printf("%04d - %04d = %04d\n",y,x,n);
    }while(n!=0 && n!=6174);
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2019-05-08 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Problem Description:
  • Input Specification:
  • Output Specification:
  • Sample Input 1:
  • Sample Output 1:
  • Sample Input 2:
  • Sample Output 2:
  • 解题思路:
  • AC代码:
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档