专栏首页网络技术联盟站H3C | S6X00系列交换机策略路由配置案例

H3C | S6X00系列交换机策略路由配置案例

组网及说明

1 配置需求或说明

1.1适用产品系列

本案例适用于如S6300-52QF、S6520X-30QC-HI、S6800-54QT、S6820-4C S6900-2F等S6X00系列的交换机

1.2配置需求及实现的效果

交换机SW1上配置一条静态路由,使终端访问114.114.114.114的时候通过R2,其中192.168.2.0这个网段,访问114.114.114.114 的时候匹配策略路由从R3去访问。

2 组网图

配置步骤

3 配置步骤

一.交换机和路由器上ip地址基本配置

#在SW1上进图系统视图

<H3C>system-view
System View: return to User View with Ctrl+Z.

#创建vlan 1-4

[H3C]vlan 1 to 4

#配置vlan 1-vlan 4虚接口IP地址

[H3C]interface Vlan-interface 1
[H3C-Vlan-interface1] ip address 192.168.1.1 255.255.255.0
[H3C-Vlan-interface1]quit
[H3C]interface Vlan-interface 2
[H3C-Vlan-interface2] ip address 192.168.2.1 255.255.255.0
[H3C-Vlan-interface2]quit
[H3C]interface Vlan-interface 3
[H3C-Vlan-interface3] ip address 10.10.10.1 255.255.255.0
[H3C-Vlan-interface3]quit
[H3C]interface Vlan-interface 4
[H3C-Vlan-interface4] ip address 20.20.20.1 255.255.255.0
[H3C-Vlan-interface4]quit

#将端口分别划分到所属vlan,端口1属于vlan 3,端口4属于vlan 4,端口5属于默人vlan 1,端口6属于vlan 2。

[H3C]interface GigabitEthernet 1/0/1
[H3C-GigabitEthernet1/0/1] port access vlan 3
[H3C-GigabitEthernet1/0/1]quit
[H3C]interface GigabitEthernet 1/0/4
[H3C-GigabitEthernet1/0/4] port access vlan 4
[H3C-GigabitEthernet1/0/4]quit
[H3C]interface GigabitEthernet 1/0/6
[H3C-GigabitEthernet1/0/6] port access vlan 2
[H3C-GigabitEthernet1/0/6]quit

#配置到114.114.114.0网段的静态路由

[H3C] ip route-static 114.114.114.0 24 10.10.10.2
[H3C]save force

#在R1上进图系统视图

<H3C>system-view
System View: return to User View with Ctrl+Z.

#创建环回接口LoopBack 0用来模拟主机,地址是114.114.114.114/24

[H3C]interface LoopBack 0
[H3C-LoopBack0]ip address 114.114.114.114 255.255.255.0
[H3C-LoopBack0]quit

#为路由器1口和2口分别配置IP地址。

[H3C]int GigabitEthernet 0/1
[H3C-GigabitEthernet0/1] ip address 30.30.30.1 255.255.255.0
[H3C]int GigabitEthernet 0/2[H3C-GigabitEthernet0/2] ip address 40.40.40.1 255.255.255.0
[H3C-GigabitEthernet0/2]quit

#配置到192.168.1.0网段的静态路由

[H3C]ip route-static 192.168.1.0 24 30.30.30.2

#配置到114.114.114.0网段的静态路由

[H3C]ip route-static 192.168.2.0 24 40.40.40.2

#开启设备的ICMP目的不可达报文的发送功能

[H3C]ip unreachables enable

#开启ICMP超时报文发送功能

[H3C]ip ttl-expires enable
[H3C]save force

#在R2上进图系统视图

<H3C>system-view
System View: return to User View with Ctrl+Z.

#为路由器1口和2口分别配置IP地址。

[H3C]int GigabitEthernet 0/0
[H3C-GigabitEthernet0/0] ip address 30.30.30.2 255.255.255.0
[H3C]int GigabitEthernet 0/1
[H3C-GigabitEthernet0/1] ip address 10.10.10.2 255.255.255.0

#配置到114.114.114.0网段的静态路由

[H3C] ip route-static 114.114.114.0 24 30.30.30.1

#配置到192.168.1.0网段的静态路由

[H3C] ip route-static 192.168.1.0 24 10.10.10.1

#配置到114.114.114.0网段的静态路由

[H3C] ip route-static 192.168.2.0 24 10.10.10.1

#开启设备的ICMP目的不可达报文的发送功能

[H3C]ip unreachables enable

#开启ICMP超时报文发送功能

[H3C]ip ttl-expires enable[H3C]save force

#在R3上进图系统视图

<H3C>system-view
System View: return to User View with Ctrl+Z.

#为路由器1口和2口分别配置IP地址。

[H3C]int GigabitEthernet 0/0
[H3C-GigabitEthernet0/0] ip address 40.40.40.2 255.255.255.0
[H3C]int GigabitEthernet 0/1
[H3C-GigabitEthernet0/1] ip address 20.20.20.2 255.255.255.0

#配置到114.114.114.0网段的静态路由

[H3C] ip route-static 114.114.114.0 24 40.40.40.1

#配置到192.168.1.0网段的静态路由

[H3C] ip route-static 192.168.1.0 24 10.10.10.2

#配置到114.114.114.0网段的静态路由

[H3C] ip route-static 192.168.2.0 24 10.10.10.

#开启设备的ICMP目的不可达报文的发送功能

[H3C]ip unreachables enable

#开启ICMP超时报文发送功能

[H3C]ip ttl-expires enable
[H3C]save force

二.交换机策略路由配置

<H3C>system-view
System View: return to User View with Ctrl+Z.

#定义访问控制列表3000,用来匹配内网源地址为192.168.2.0/24网段的数据流

[H3C]acl advanced 3000
[H3C-acl-ipv4-adv-3000]rule permit ip source 192.168.2.0 0.0.0.255
[H3C-acl-ipv4-adv-3000]quit

# 定义访问控制列表3001,用来匹配内网192.168.2.0/24网段去访问内网192.168.1.0/24网段的数据流。

[H3C]acl advanced 3001
[H3C-acl-adv-3001]rule permit ip source 192.168.2.0 0.0.0.255 destination 192.168.1.0 0.0.0.255
[H3C-acl-adv-3001]quit

# 创建策略路由,名称为aaa,节点为10,匹配acl 3001的数据流,不设置apply动作(如果不设置动作,则匹配到的数据转发时根据路由表来进行转,且不再匹配下一节点,配置这个节点的作用是实现内网不同网段之间互访的流量不匹配策略路由,达到可以互访的目的。备注:默认情况下,网关在路由器上的不同网段是可以互相访问的)。

[H3C]policy-based-route aaa permit node 10
[H3C-pbr-aaa-10]if-match acl 3001
[H3C-pbr-aaa-10]quit

#创建策略路由aaa的节点20,匹配acl 3000的数据流,设置apply动作,指定数据的下一跳为20.20.20.2。

[H3C]policy-based-route aaa node 20
[H3C-pbr-aaa-20]if-match acl 3000
[H3C-pbr-aaa-20]apply next-hop 20.20.20.2
[H3C-pbr-aaa-20]quit

#在内网VLAN虚接口(网关)上应用策略路由

[H3C]interface vlan 2
[H3C-Vlan-interface2]ip policy-based-route aaa
[H3C-Vlan-interface2]quit
[H3C]save force

4 验证配置

# 交换机上没有配置策略路由的时候,在两台终端上tracert路径的结果如下:

192.168.1.2:

192.168.2.2:

# 配置了策略路由以后

192.168.1.2:

192.168.2.2:

本文分享自微信公众号 - 网络技术联盟站(it666lmz),作者:夏轩

原文出处及转载信息见文内详细说明,如有侵权,请联系 yunjia_community@tencent.com 删除。

原始发表时间:2019-11-08

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • H3C系列 | H3C全系列交换机配置指导手册汇总集【共53个文档】

    嗨,大家好,今天给大家带来的干货是H3C全系列交换机配置指导手册汇总集,一共有53个文档。

    网络技术联盟站
  • 锐捷路由技术 | NTP配置

    RSR路由器可以做为NTP的服务器,但是现网大部分情况下并非以路由器做为NTP服务器。

    网络技术联盟站
  • H3CNE实验系列 | 网络地址转换NAT

    如下图所示,一个公司通过 h3c 路由器的地址转换功能连接到广域网。要求该公司能够通过 h3c 路由器 s 1/0 访问 internet,公司内部对外...

    网络技术联盟站
  • H3C PPPOE 基本配置

    [H3C]local-user server [H3C-luser-server]password simple 123456 [H3C-luser-ser...

    用户2398817
  • H3C 交换机常用配置命令

    1、配置主机名 [H3C]systemnameH3C 2、配置console口密码 #进入系统视图。 <H3C>system-view #进入AUX用户界面视...

    DevinGeng
  • H3C BGP MPLS ×××

    2、配置PE1-P-PE2公网路由 以PE1为例: [H3C]ospf 1 [H3C-ospf-1]area 0 [H3C-ospf-1-area-0....

    用户2398817
  • H3C交换机常用命令汇总

    root@root:~# netstat -an|grep -E "6002|6003"

    业余草
  • H3C 配置

    配置Web网管用户  localuser user_name password 1 进入VTY界面视图  user-interface vty 0 设置...

    用户2398817
  • 管理H3C交换机

    2,创建VLAN 1,并指定VLAN 1为交换机的管理VLAN [H3C] vlan 1 [H3C-vlan1] quit [H3C] managemen...

    用户2398817
  • Python Debug调试技巧

    Debug 对于任何coding人士都是一项非常重要的技能,它能够帮助我们准确的定位错误,发现程序中的 bug。有时候通过程序运行时的报错可以很容易的找到出错的...

    ITester软件测试小栈

扫码关注云+社区

领取腾讯云代金券