专栏首页网络技术联盟站H3C | 双smart-link组(v7版本)

H3C | 双smart-link组(v7版本)

组网及说明

采用双smart-link组,实现两路冗余及流量负载均衡。

配置步骤

  1. 在SW1创建两个smart-link组
  2. 需要两个保护VLAN,这里提前规划,VLAN10作为smart-link组1的保护VLAN,VLAN20作为smart-link组2的保护VLAN

配置关键点

配置过程: SW1:

[H3C]sysname SW1
[SW1]vl 10
[SW1-vlan10]qu
[SW1]vl 20
[SW1-vlan20]qu
[SW1]vl 30
[SW1-vlan30]qu
[SW1]vl 40
[SW1-vlan40]qu
[SW1]
[SW1]stp region-configuration
[SW1-mst-region]region-name H3C.COM
[SW1-mst-region]instance 0 vlan 10 30
[SW1-mst-region]instance 1 vlan 20 40
[SW1-mst-region]active region-configuration
[SW1-mst-region]quit
[SW1]int ran gi 1/0/1 to gi 1/0/2
[SW1-if-range]po li tr
[SW1-if-range]undo po tr pe vlan 1
[SW1-if-range]po tr pe vlan 10 20 30 40
[SW1-if-range]smart-link flush enable control-vlan 10 20
[SW1-if-range]undo stp en
[SW1-if-range]qu
[SW1]smart-link group 1
[SW1-smlk-group1]protected-vlan reference-instance 0
[SW1-smlk-group1]flush enable control-vlan 10
[SW1-smlk-group1]po gi 1/0/1 primary
[SW1-smlk-group1]po gi 1/0/2 secondary
[SW1-smlk-group1]quit
[SW1]
[SW1]smart-link group 2
[SW1-smlk-group2]protected-vlan reference-instance 1
[SW1-smlk-group2]flush enable control-vlan 20
[SW1-smlk-group2]port gi 1/0/2 primary
[SW1-smlk-group2]port GigabitEthernet 1/0/1 secondary
[SW1-smlk-group2]quit
[SW1]

SW2:

[H3C]sysname SW2
[SW2]vl 10
[SW2-vlan10]qu
[SW2]vl 20
[SW2-vlan20]qu
[SW2]vl 30
[SW2-vlan30]qu
[SW2]vl 40
[SW2-vlan40]qu
[SW2]int ran gi 1/0/1 to gi 1/0/2
[SW2-if-range]po li tr
[SW2-if-range]undo po tr pe vlan 1
[SW2-if-range]po tr pe vlan 10 20 30 40
[SW2-if-range]smart-link flush enable control-vlan 10 20
[SW2-if-range]quit
[SW2]monitor-link group 1
[SW2-mtlk-group1]port gi 1/0/1 uplink
[SW2-mtlk-group1]port gi 1/0/2 downlink
[SW2-mtlk-group1]quit

SW3:

[SW3]vlan 10
[SW3-vlan10]qu
[SW3]vl 20
[SW3-vlan20]qu
[SW3]vl 30
[SW3-vlan30]qu
[SW3]vl 40
[SW3-vlan40]qu
[SW3]int ran gi 1/0/1 to gi 1/0/2
[SW3-if-range]po li tr
[SW3-if-range]undo po tr pe vlan 1
[SW3-if-range]po tr pe vlan 10 20 30 40
[SW3-if-range]smart-link flush enable co
[SW3-if-range]smart-link flush enable control-vlan 10 20
[SW3-if-range]quit
[SW3]monitor-link group 1
[SW3-mtlk-group1]port gi 1/0/1 uplink
[SW3-mtlk-group1]port GigabitEthernet 1/0/2 downlink
[SW3-mtlk-group1]quit
[SW3]

SW4(网关所在设备):

[H3C]sysname SW4
[SW4]vlan 10
[SW4-vlan10]qu
[SW4]vlan 20
[SW4-vlan20]quit
[SW4]vlan 30
[SW4-vlan30]quit
[SW4]vlan 40
[SW4-vlan40]quit
[SW4]int ran gi 1/0/1 to gi 1/0/2
[SW4-if-range]po li tr
[SW4-if-range]undo po tr pe vlan 1
[SW4-if-range]po tr pe vlan 10 20 30 40
[SW4-if-range]smart-link flush enable control-vlan 10 20
[SW4-if-range]quit
[SW4]int vlan 30
[SW4-Vlan-interface30]ip address 192.168.30.254 24
[SW4-Vlan-interface30]undo shutdown
[SW4-Vlan-interface30]quit
[SW4]int vlan 40
[SW4-Vlan-interface40]ip address 192.168.40.254 24
[SW4-Vlan-interface40]undo shutdown
[SW4-Vlan-interface40]quit
[SW4]int LoopBack 0
[SW4-LoopBack0]ip address 1.1.1.1 30
[SW4-LoopBack0]undo shutdown
[SW4-LoopBack0]quit
[SW4]

本文分享自微信公众号 - 网络技术联盟站(it666lmz),作者:夏轩

原文出处及转载信息见文内详细说明,如有侵权,请联系 yunjia_community@tencent.com 删除。

原始发表时间:2019-11-24

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • H3CNE实验系列 | 单臂路由

    [H3C-Ethernet1/0/1]port trunk permit vlan all

    网络技术联盟站
  • 华为网络工程师 | 高级vlan再难咱也不怕,看完这篇文章,原理理解喽,命令也会敲喽!

    sw2 创建vlan 并将相应接口划入相应vlan 和sw1 相连的接口配置trunk

    网络技术联盟站
  • STP 实验

    步骤 1 :根据 HCL 模拟器的运行机制, SW1 的 Mac 地址应该是最小的,会成为根网桥,在SW1 上查看 STP 运行状态,确认 SW1 为根网桥

    网络技术联盟站
  • 『初中级前端必看』谈谈如何更有质量地看源码

    作为一个优秀(或说合格)的开源项目,它的代码一定不会是晦涩难懂的。不仅是代码本身,这些项目配套的注释,单元测试,示例代码,函数名以及文档一定是能够很好地辅助你读...

    陈大鱼头
  • 熊孩子乱花钱怎么办?多半是还没玩这个小游戏

    知晓君
  • [翻] ML 代码完整性检查清单

    翻译 ML Code Completeness Checklist 完整版请戳原文查看。

    caoqi95
  • caffe源码学习之Proto数据格式【1】

    前言:   由于业务需要,接触caffe已经有接近半年,一直忙着阅读各种论文,重现大大小小的模型. 期间也总结过一些caffe源码学习笔记,断断续续,这次打算系...

    Gxjun
  • 而立之年——回顾我的前端转行之路

    在成为程序员之前,我干过很多工作。由于学历的问题(高中),我的工作基本上都是体力活。包括但不限于:工厂普工、销售(没有干销售的才能)、搬运工、摆地摊等,转行前最...

    谭光志
  • teg zte f822 onu 常用配置举例

    1、端口限速,实际下载速度为 rate-limit 1024/8 由于相对于用户为发送数据设置out方向,限制用户下载,in方向为上传。 configure ...

    葫芦
  • 万字长文之 Serverless 实战详细指南

    Serverless = Faas (Function as a service) + Baas (Backend as a service)

    winty

扫码关注云+社区

领取腾讯云代金券