vps dd安装routeros

安装

wget http://download2.mikrotik.com/routeros/6.43.8/chr-6.43.8.img.zip -O chr.img.zip && \
gunzip -c chr.img.zip > chr.img && \
mount -o loop,offset=33554944 chr.img /mnt && \
ADDRESS0=`ip addr show eth0 | grep global | cut -d' ' -f 6 | head -n 1` && \
GATEWAY0=`ip route list | grep default | cut -d' ' -f 3` && \
echo "/ip address add address=$ADDRESS0 interface=[/interface ethernet find where name=ether1]
/ip route add gateway=$GATEWAY0
" > /mnt/rw/autorun.scr && \
umount /mnt && \
echo u > /proc/sysrq-trigger && \
dd if=chr.img bs=1024 of=你的硬盘 && \
reboot

重启之后视你vps服务器的性能,我用ruvds dd的时候大概等了10-20分钟。安装好了之后在控制台里面用vnc或者console可以看到登录界面。默认的账号是admin,密码是

配置

# 查看网卡名称
[admin@MikroTik] > interface print 
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU
 0  R  ether1                              ether            1500

#配置IP地址和掩码
/ip address add address=IP地址/掩码 interface=网卡名
#定义网关
/ip route add gateway=网关地址

# 查看配置的地址
[admin@MikroTik] > /ip address print 
Flags: X - disabled, I - invalid, D - dynamic 
#   ADDRESS            NETWORK         INTERFACE                                
0   45.141.XXX.XXX/25  45.141.XXX.0    ether1、

连接测试

winbox下载:点击下载

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

发表于

我来说两句

0 条评论
登录 后参与评论

扫码关注云+社区

领取腾讯云代金券

年度创作总结 领取年终奖励