专栏首页python3H3CNE实验(Vlan/Ftp/DHC

H3CNE实验(Vlan/Ftp/DHC

实验拓扑:

试验简述:1、PC1与PC2分别属于Vlan 1 和Vlan 2 ;

2、SW1的Ethernet1/0/1和 Ethernet1/0/5分别属于Vlan1 和Vlan2

3、SW1的Ethernet1/0/8和Ethernet1/0/9端口分别与SW2的Ethernet1/0/8和Ethernet1/0/9端口相连;

实验器材:SW1与SW2均为H3C S3610交换机。

实验目标

目标一、实现Vlan间的互访(希望在SW2上实现路由);

目标二、在SW1和SW2上使用链路聚合,用于提高带宽和稳定性;

目标三、在SW2上能够为PC1和PC2分配IP地址;

目标四、在SW1和SW2上配置静态域名解析,使得在SW1和SW2上能够使用名称PC和PC2访问主机PC1和主机PC2。

目标五、分别对TELNET、FTP、DHCP进行抓包并分析其工作过程

实验内容

SW1的简要配置与分析

#

version 5.20, Release 5309P02

#

sysname sw1

#

ip host pc1 192.168.1.2 //静态域名解析PC1

ip host pc2 192.168.2.2 //静态域名解析PC2

#

vlan 1

#

vlan 2 //创建VLAN 2

#

interface Bridge-Aggregation8 //创建链路聚合组 8

port link-type trunk //在组上设置端口端口类型为trunk

port trunk permit vlan all //在trunk上允许所有vlan通过

#

interface Ethernet1/0/5

port link-mode bridge

port access vlan 2 //将该端口e1/0/5加入到vlan 2中

#

interface Ethernet1/0/8

port link-mode bridge

port link-type trunk //在e1/0/8上设置其端口类型为trunk

port trunk permit vlan all //在trunk上允许所有vlan通过

port link-aggregation group 8 //将e1/0/8端口加入到链路聚合组 8 中

#

interface Ethernet1/0/9

port link-mode bridge

port link-type trunk //在e1/0/9上设置其端口类型为trunk

port trunk permit vlan all //在trunk上允许所有vlan通过

port link-aggregation group 8 //将e1/0/9端口加入到链路聚合组 8 中

#

return

SW2的简要配置与分析

#

version 5.20, Release 5309

#

sysname sw2

#

ip host pc1 192.168.1.2 //静态域名解析PC1

ip host pc2 192.168.2.2 //静态域名解析PC2

#

vlan 1

#

vlan 2

#

dhcp server ip-pool 1.0 //配置DHCP 的ip地址池,名为:1.0

network 192.168.1.0 mask 255.255.255.0

gateway-list 192.168.1.1

dns-list 192.168.1.1

#

dhcp server ip-pool 2.0 //配置DHCP 的ip地址池,名为:2.0

network 192.168.2.0 mask 255.255.255.0

gateway-list 192.168.2.1

dns-list 192.168.2.1

#

user-group system

#

stp enable

#

interface Bridge-Aggregation8 //创建链路聚合组 8

port link-type trunk //在链路聚合端口上设置其端口类型为trunk

port trunk permit vlan all //允许所有vlan通过

#

interface Vlan-interface1

ip address 192.168.1.1 255.255.255.0 //在vlan 1上配置IP地址

#

interface Vlan-interface2

ip address 192.168.2.1 255.255.255.0 //在vlan 2上配置IP地址

#

interface Ethernet1/0/8

port link-mode bridge

port link-type trunk //在e1/0/8上设置其端口类型为trunk

port trunk permit vlan all //在trunk上允许所有vlan通过

port link-aggregation group 8 //将e1/0/8端口加入到链路聚合组 8 中

#

interface Ethernet1/0/9

port link-mode bridge

port link-type trunk //在e1/0/9上设置其端口类型为trunk

port trunk permit vlan all //在trunk上允许所有vlan通过

port link-aggregation group 8 //将e1/0/9端口加入到链路聚合组 8 中

#

Return

抓包分析:1、Telnet工作过程查看与分析:

A、 连接建立:如下图:

Telnet在连接建立时,采用TCP三次握手建立可靠连接

B、数据传输阶段:如下图:

telnet在数据传输阶段采用回显(主机输入的命令先传输到服务器,再由服务器发回相同的数据供显示到用户的显示器),每完成一个回合,由客户机发送确认信息进行数据确认。

C:连接关闭阶段:如下图:

Telnet在关闭阶段采用TCP的四次挥手机制。

2、FTP工作过程查看与分析:

A、连接建立:如下图:

Ftp连接建立阶段采用TCP的三次握手机制,保证数据的可靠传输

B、数据传输:如下图:

Ftp的数据传输阶段采用的机制和Telnet不同,服务器不会回显客户机发送的报文,但仍然是具有确认传输机制

C、 连接断开阶段:如下图:

Ftp连接断开时采用TCP的四次挥手机制

3、DHCP工作过程查看与分析

如下图:

DHCP的工作过程采用四部曲,需要注意的是客户机发送的报文全是广播,而服务器发送的报文全是以单播形式发送

实验总结

1、 在配置链路聚合时,非常容易忽视在聚合端口上配置trunk端口,从而导致整个网络不通畅的问题,因此应该先进行链路聚合,而后在考虑vlan间路由问题。

2、 若在不考虑链路聚合基础上可以通过在SW1是将中间两根线缆对应的端口分别分配给不同的vlan,同时在SW2上,将对应的端口改为三层端口,并配上三层地址,分别作为不同vlan中主机的网关,此时也可以完成vlan间的路由功能,但无法再进行链路聚合(因为SW2的三层接口无法进行链路聚合)。

3、 DHCP 地址池的分配问题,同时配置两个地址池并不矛盾,不会产生将vlan 2的ip地址分配给vlan 1的问题,因为SW2会根据DHCP请求报文中的vlan标识分配相应的IP地址。

4、 Ftp/Telnet都是采用TCP协议保证可靠传输,因此在工作的开始和结束都会存在三次握手和四次挥手机制;DHCP采用UDP协议进行报文传输,速度快报文小,若地址租约到期,客户机和服务器发送的报文只有最后的两种:request和ack。

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • H3C PPP认证试验报告(h3c网上学

    [r1]dis cur #  version 5.20, Alpha 1011 #  sysname r1 #  password-control ...

    py3study
  • h3c交换机-初级命令

    参考文档 H3C_S3600_v1510 手册 H3C_S5000E 手册 网上其他热心网友的配置文档 #######################...

    py3study
  • H3CNE综合实验

    XX公司的一个分支机构正在建设中。根据公司的设计需要,分支机构的网络只能使用192.168.1x.0/24的网段,该网络中共有3个部门(分别是工程部、市场部、...

    py3study
  • H3C PPP认证试验报告(h3c网上学

    [r1]dis cur #  version 5.20, Alpha 1011 #  sysname r1 #  password-control ...

    py3study
  • 未来数据中心网络必需的三大件

    短短几年间,很多人从不知道什么是SDN、Trill、VXlan,对这些技术不屑一顾,到现在几乎每个数据中心都在谋求转型,每个从事信息技术的人如果还不知道这些单词...

    SDNLAB
  • 因特网之父:我都用纸张保存资料

    文顿瑟夫被尊称为「因特网之父」。(东方IC) 「现在或许是21世纪,但我还穿着19世纪的三件式西装,」网络之父文顿瑟夫在网络管理论坛上说。 这场探讨未来网络发展...

    企鹅号小编
  • Spring整合Schedule定时任务详解

    所以,这里还是先讲第三个吧,前两个跟Spring没关系,这里不讲,quartz配置麻烦,后面篇幅再说。

    品茗IT
  • 数说交换机——关于交换机市场的几个真相

    SDNLAB
  • Confluence 6 配置服务器基础地址备注

    使用不同 URL。如果你配置了不同的基础 URL 地址或者你站点的访问者使用了不同的 URL 地址来访问你的 Confluence 地址,你有很大概率可能会受到...

    HoneyMoose
  • 19.7 zabbix的主动模式和被动模式

    主动模式和被动模式 主动或者被动是相对客户端来讲的 被动模式,服务端会主动连接客户端获取监控项目数据,客户端被动地接受连接,并把监控信息传递给服务端,服...

    运维小白

扫码关注云+社区

领取腾讯云代金券