前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >06-图2 Saving James Bond - Easy Version (25分)

06-图2 Saving James Bond - Easy Version (25分)

作者头像
AI那点小事
发布2020-04-18 20:19:08
5150
发布2020-04-18 20:19:08
举报
文章被收录于专栏:AI那点小事AI那点小事

This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers NN (\le 100≤100), the number of crocodiles, and DD, the maximum distance that James could jump. Then NN lines follow, each containing the (x, y)(x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line “Yes” if James can escape, or “No” if not.

Sample Input 1:

14 20 25 -15 -25 28 8 49 29 15 -35 -2 5 28 27 -29 -8 -28 -20 -35 -25 -20 -13 29 -30 15 -35 40 12 12 Sample Output 1: Yes

Sample Input 2: 4 13 -12 12 12 12 -12 -12 12 -12 Sample Output 2: No


代码如下:

代码语言:javascript
复制
#include <iostream>
#include <cmath>
#include <vector>
using namespace std;

class Crocodile{
    private:
        int x;                  //x坐标 
        int y;                  //y坐标 
    public:
        //构造函数
        Crocodile(){
            this->x = 0;
            this->y = 0;
        } 

        Crocodile(int x,int y){
            this->x = x;
            this->y = y;
        } 

        int getX(){
            return this->x;
        } 

        int getY(){
            return this->y;
        }
};

class Save007{
    private:
        vector<Crocodile> crocodiles;
        int* isVisited; 
        int MaxdDistance;
        int Maxnum;
    public:
        Save007(int maxnum,int maxdistance){
            this->Maxnum = maxnum; 
            this->isVisited = new int[maxnum];
            this->MaxdDistance = maxdistance;
            for ( int i = 0 ; i < this->Maxnum ; i++){
                int x,y;
                cin>>x>>y;
                Crocodile tmp(x,y);
                this->crocodiles.push_back(tmp);
                this->isVisited[i] = 0; 
            }
        }

        //判断该鳄鱼是否能让007跳上岸 
        int Judge(Crocodile crocodile){
            int distX = 50 - abs(crocodile.getX());
            int distY = 50 - abs(crocodile.getY());

            if ( distX <= this->MaxdDistance || distY <= this->MaxdDistance){
                return 1;
            }else{
                return 0;
            }
        }

        //计算007是否能跳到这只鳄鱼上 
        int Caculate(Crocodile crocodile1,Crocodile crocodile2,double jump_distance){
            int distX =  crocodile1.getX() - crocodile2.getX();
            int distY =  crocodile1.getY() - crocodile2.getY();
            double dist = sqrt(pow(distX,2)+ pow(distY,2));
            if (dist <= jump_distance){
                return 1;
            }else{
                return 0;
            }
        }

        //DFS遍历
        void DFS(int start){
            int flag  = 0;
            this->isVisited[start] = 1;
            if (this->Judge(this->crocodiles[start])){
                cout<<"Yes";
                exit(0);
            }else{
                for ( int i = 0 ; i < this->Maxnum ; i++){
                    int judge = this->Caculate(this->crocodiles[start],this->crocodiles[i],this->MaxdDistance);
                    if ( !this->isVisited[i] && judge){
                        DFS(i);
                    }
                }
            }
        }

        void Save(){
            int start;
            int result = 0;
            vector<int> first_jump; 
            //第一跳单独拿出来 
            for ( int i = 0 ; i < this->Maxnum ; i++){
                Crocodile tmp(0,0);
                if (this->Caculate(this->crocodiles[i], tmp ,this->MaxdDistance+7.5)){
                    first_jump.push_back(i);
                }
            }

            if ( first_jump.empty()){
                cout<<"No";
                return;
            }else{
                for (int i = 0 ; i < first_jump.size() ; i++){
                    DFS(first_jump[i]);
                }
                cout<<"No";
                return;
            }
        } 
}; 

int main()
{
    int maxnum,maxdistance;
    cin>>maxnum>>maxdistance;
    Save007 save(maxnum,maxdistance);

    save.Save();

    return 0;
 } 

本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档