前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >04-树6 Complete Binary Search Tree (30分)

04-树6 Complete Binary Search Tree (30分)

作者头像
AI那点小事
发布2020-04-18 20:24:00
6500
发布2020-04-18 20:24:00
举报
文章被收录于专栏:AI那点小事AI那点小事

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key. The right subtree of a node contains only nodes with keys greater than or equal to the node’s key. Both the left and right subtrees must also be binary search trees. A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer NN (\le 1000≤1000). Then NN distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input: 10 1 2 3 4 5 6 7 8 9 0 Sample Output: 6 3 8 1 5 7 9 0 2 4


思路: 这个题想了好久,最后还是看别人的代码才明白了,就是根据完全二叉树的性质,完全二叉树在数组中某个节点的下标为i,则其左右孩子的下标分别为2*1,2*i+1。然后递归建树。


AC代码:

代码语言:javascript
复制
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

int pos = 0;
int root = 1;
int N;
vector<int> CBT;
vector<int> AVL;

void Build_CBT(int root)
{
    if ( root > N){
        return;
    }else{
        int left = 2 * root;
        int right = 2 * root + 1;
        Build_CBT(left);
        CBT[root] = AVL[pos++];
        Build_CBT(right);
    }
}

int main()
{
    cin>>N;
    AVL = vector<int>(N,0);
    CBT = vector<int>(N+1,0);

    for ( int i = 0 ; i < N ; i++){
        cin>>AVL[i];
    }
    sort(AVL.begin(),AVL.end());

    Build_CBT(root);

    cout<<CBT[1];
    for ( int i = 2 ; i < CBT.size() ; i++){
        cout<<" "<<CBT[i];
    }


    return 0;
 } 

本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档