前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >03-树2 List Leaves (25分)

03-树2 List Leaves (25分)

作者头像
AI那点小事
发布2020-04-20 16:20:32
6190
发布2020-04-20 16:20:32
举报
文章被收录于专栏:AI那点小事AI那点小事

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer NN (\le 10≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N-1N−1. Then NN lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8 1 - - - 0 - 2 7 - - - - 5 - 4 6 Sample Output:

4 1 5


AC代码如下:

代码语言:javascript
复制
#include <iostream>
#include <vector>
#include <queue>
using namespace std;

struct Node{
    int data;
    int left;
    int right;
};

//建树函数,返回根节点 
int BuildTree(vector<struct Node> &Tree,int N){
    int root = -1;
    char left,right;
    vector<int> check(N,0);

    for ( int i = 0 ; i < N ; i++){
        cin>>left>>right;
        Tree[i].data = i;
        //判断左子树是否为空,不为空则把ckeck数组相应位置1,否则置-1 
        if ( left != '-'){
            Tree[i].left = (int)(left-'0');
            check[Tree[i].left] = 1;
        }else{
            Tree[i].left = -1;
        }
        //判断右子树是否为空,不为空则把ckeck数组相应位置1,否则置-1 
        if ( right != '-'){
            Tree[i].right = (int)(right-'0');
            check[Tree[i].right] = 1;
        }else{
            Tree[i].right = -1;
        }
    }

    //寻找根节点的索引 
    for ( int i = 0 ; i < N ; i++){
        if ( check[i] == 0){
            root = i;
            break;
        }
    }
    return root;
} 

//寻找叶子节点函数
vector<int> Find_Leaves(vector<struct Node> &Tree,int root)
{
    vector<int> leaves;
    queue<struct Node> que;
    struct Node treenode;
    if ( root == -1){
        return {};
    }else{
        que.push(Tree[root]);
        while(!que.empty()){
            treenode = que.front();
            que.pop();
            if ( treenode.left == -1 && treenode.right == -1){
                leaves.push_back(treenode.data);
            }
            if ( treenode.left != -1){
                que.push(Tree[treenode.left]);
            }
            if ( treenode.right != -1){
                que.push(Tree[treenode.right]);
            }
        }
    }
    return leaves;
}

void Print(vector<int> & leaves)
{
    cout<<leaves[0];
    for ( int i = 1 ; i < leaves.size() ; i++){
        cout<<" "<<leaves[i];
    }
}

int main()
{
    int N;//树节点的个数 
    cin>>N;
    vector<struct Node> Tree(N); //存储树结点的数组 

    //完成建树过程,返回根节点索引
    int root = BuildTree(Tree,N);

    //寻找叶子结点数组 
    vector<int> leaves = Find_Leaves(Tree,root);

    //打印所有叶子结点 
    Print(leaves);

    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档