前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ 1163(数字三角形)

POJ 1163(数字三角形)

作者头像
AI那点小事
发布2020-04-20 16:45:47
2920
发布2020-04-20 16:45:47
举报
文章被收录于专栏:AI那点小事AI那点小事

Description

7 3 8 8 1 0 2 7 4 4 4 5 2 6 5

(Figure 1) Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99. Output

Your program is to write to standard output. The highest sum is written as an integer. Sample Input

5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5

Sample Output

30


递归版本的AC代码如下:

代码语言:javascript
复制
import java.util.Scanner;

public class Main {
    static int[][] D = new int[101][101];
    static int[][] maxsum = new int[101][101];
    static int N;

    public static int MaxSum(int i,int j){
        if ( maxsum[i][j] != -1){
            return maxsum[i][j];
        }
        if ( i == N ){
            maxsum[i][j] = D[i][j];
        }else{
            int x = MaxSum(i+1, j);
            int y = MaxSum(i+1, j+1);
            maxsum[i][j] = max(x,y)+D[i][j];
        }
        return maxsum[i][j];
    }

    public static int max(int a , int b){
        return (a > b)?a:b;
    }

    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner in = new Scanner(System.in);
        N = in.nextInt();
        for ( int i = 1 ; i <= N ; i++){
            for ( int j = 1 ; j <= i ; j++){
                D[i][j] = in.nextInt();
                maxsum[i][j] = -1;
            }
        }
        System.out.print(MaxSum(1, 1));
        in.close();
    }

}

递归版本的AC代码:

代码语言:javascript
复制
import java.util.Scanner;

public class Main {
    static int[][] D = new int[101][101];
    static int N;

    public static int MaxSum(){
        for ( int i1 = N-1 ; i1 >= 1 ; i1--){
            for ( int j1 = 1 ; j1 <= i1 ; j1++){
                D[N][j1] = max(D[N][j1],D[N][j1+1]) + D[i1][j1];
            }
        }
        return D[N][1];
    }

    public static int max(int a , int b){
        return (a > b)?a:b;
    }

    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner in = new Scanner(System.in);
        N = in.nextInt();
        for ( int i = 1 ; i <= N ; i++){
            for ( int j = 1 ; j <= i ; j++){
                D[i][j] = in.nextInt();
            }
        }
        System.out.print(MaxSum());
        in.close();
    }

}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档