前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >1043. 输出PATest(20)

1043. 输出PATest(20)

作者头像
AI那点小事
发布2020-04-20 17:34:38
2820
发布2020-04-20 17:34:38
举报
文章被收录于专栏:AI那点小事AI那点小事

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“PATestPATest….”这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按PATest的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例: redlesPayBestPATTopTeePHPereatitAPPT 输出样例: PATestPATestPTetPTePePee

代码语言:javascript
复制
#include <iostream>
using namespace std;

int Isempty(int* count , int n)
{
    int flag = 1;
    for ( int i = 0 ; i < n ; i++){
        if ( count[i] > 0 ){
            flag = 0;
            break;
        }
    }

    return flag;
}

int main()
{
    string str;
    cin>>str;
    char letter[6]={'P','A','T','e','s','t'};
    int count[6] = {0};

    for ( int i = 0 ; i < str.length() ; i++){
        if ( str[i] == 'P'){
            count[0]++;
        }
        if ( str[i] == 'A'){
            count[1]++;
        }
        if ( str[i] == 'T'){
            count[2]++;
        }
        if ( str[i] == 'e'){
            count[3]++;
        }
        if ( str[i] == 's'){
            count[4]++;
        }
        if ( str[i] == 't'){
            count[5]++;
        }
    }

    while (!Isempty(count,6)){
        for ( int i = 0 ; i < 6 ; i++){
            if ( count[i] != 0){
                cout<<letter[i];
                count[i]--; 
            }else{
                continue;
            }
        }
    } 

    return 0;
}
这里写图片描述
这里写图片描述
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档