前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >【POJ 3176】Cow Bowling(DP)

【POJ 3176】Cow Bowling(DP)

作者头像
饶文津
发布2020-05-31 23:38:32
4220
发布2020-05-31 23:38:32
举报
文章被收录于专栏:饶文津的专栏饶文津的专栏

Description

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

代码语言:javascript
复制
 7 

 3   8 

 8   1   0 

 2   7   4   4 

 4   5   2   6   5

Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.  Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N  Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

代码语言:javascript
复制
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

代码语言:javascript
复制
30

Hint

Explanation of the sample: 

代码语言:javascript
复制
 7 
 *

 3   8 
 *

 8   1   0 
 *

 2   7   4   4 
     *

 4   5   2   6   5

The highest score is achievable by traversing the cows as shown above.

题意:每次向下或者向右下走,求最大和

分析:正向:每步来源于上方或者左上方,dp[i][j]表示第i行第j列的最大值

dp[i][j]=max{dp[i-1][j],dp[i-1][j-1]}+a[i][j].

代码语言:javascript
复制
#include<stdio.h>
#include<algorithm>
using namespace std;
int n,a[355][355],ans[355][355],maxans;
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        for(int j=1;j<=i;j++)
            scanf("%d",&a[i][j]);
    for(int i=1;i<=n;i++){
        for(int j=1;j<=i;j++){
            ans[i][j]=max(ans[i-1][j],ans[i-1][j-1])+a[i][j];
            maxans=max(ans[i][j],maxans);
        }
    }
    printf("%d",maxans);
    return 0;
}

逆向:逆着从n-1行到第1行,每次比较下方和右下方的大小,大的加上去,最后输出a[1][1]即可。

代码语言:javascript
复制
#include<stdio.h>
#include<algorithm>
using namespace std;
int n,i,j,a[355][355];
int main(){
    scanf("%d",&n);
    for(i=1;i<=n;i++)
        for(j=1;j<=i;j++)
            scanf("%d",&a[i][j]);
    for(i=n-1;i>=1;i--)
        for(j=1;j<=i;j++)
            a[i][j]+=max(a[i+1][j],a[i+1][j+1]);
    printf("%d",a[1][1]);
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-02-05 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档