前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >【HDU 1009】FatMouse' Trade

【HDU 1009】FatMouse' Trade

作者头像
饶文津
发布2020-05-31 23:38:42
6680
发布2020-05-31 23:38:42
举报
文章被收录于专栏:饶文津的专栏饶文津的专栏

Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.  The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain. 

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000. 

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain. 

Sample Input

5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1

Sample Output

13.333 31.500

题意:给你m克猫粮,n个房间分别可以用猫粮以J[i]/F[i]的比例换取至多J[i]克咖啡豆,问最多能换取多少咖啡豆

分析:先排下序再贪心

代码语言:javascript
复制
#include <stdio.h>
#include <algorithm>
using namespace std;
int n,u;
double m,ans;
struct room
{
    double j,f,p;
} r[1005];
int cmp(room a,room b)
{
    return a.p>b.p;
}
int main()
{
    while(scanf("%lf%d",&m,&n)&&n!=-1&&m!=-1)
    {
        for(int i=0;i<n;i++)
        scanf("%lf%lf",&r[i].j,&r[i].f),
              r[i].p=r[i].j/r[i].f;
        sort(r,r+n,cmp);
        u=ans=0;
        while(m&&u<n)
        {
            if(r[u].f>m) ans+=m*r[u].p,m=0;
//剩下的猫粮不够把这个房间的咖啡豆换过来,那就能换多少换多少
            else ans+=r[u].j,m-=r[u].f;
//够的话,这间房子全部咖啡豆换过来
            u++;
        }
//        while(m>=r[u].f&&u<n) //换种写法
//        {
//            ans+=r[u].j;
//            m-=r[u].f;
//            u++;
//        }
//        if(u!=n) ans+=m*r[u].p;
        printf("%.3lf\n",ans);

    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-02-05 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档