前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >【POJ 2484】A Funny Game

【POJ 2484】A Funny Game

作者头像
饶文津
发布2020-05-31 23:39:40
4620
发布2020-05-31 23:39:40
举报
文章被收录于专栏:饶文津的专栏饶文津的专栏

Description

Alice and Bob decide to play a funny game. At the beginning of the game they pick n(1 <= n <= 10 6) coins in a circle, as Figure 1 shows. A move consists in removing one or two adjacent coins, leaving all other coins untouched. At least one coin must be removed. Players alternate moves with Alice starting. The player that removes the last coin wins. (The last player to move wins. If you can't move, you lose.) 

Figure 1 Note: For n > 3, we use c1, c2, ..., cn to denote the coins clockwise and if Alice remove c2, then c1 and c3 are NOT adjacent! (Because there is an empty place between c1 and c3.)  Suppose that both Alice and Bob do their best in the game.  You are to write a program to determine who will finally win the game.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (1 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input. 

Output

For each test case, if Alice win the game,output "Alice", otherwise output "Bob". 

Sample Input

代码语言:javascript
复制
1
2
3
0

Sample Output

代码语言:javascript
复制
Alice
Alice
Bob

题意:给出n个硬币围成一圈,两个人轮流操作,每次操作可以移走一个或者两个相邻硬币,取走最后硬币的人获胜,求赢家。

分析:1、2个先手赢,3个后手赢,现在分析n>=4的情况,先手操作后,环就变成了链,如果取走链的中间一个或者两个,变成两个相同的链,那么接下来对方怎么取,就再另一串链进行相同操作,这样就可以赢了。

也就是说00 00、000 000、0000 0000、......这样的左右相同的情况都是先手必败的情况。

所以一条链时是先手必赢,一个环(n>3)是先手必败的情况。

代码语言:javascript
复制
#include<stdio.h>
int main(){
    int n;
    while(scanf("%d",&n)&&n!=0){
        if(n<3)printf("Alice\n");
        else printf("Bob\n");
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-02-06 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档