首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT 1019 General Palindromic Number (20分)

PAT 1019 General Palindromic Number (20分)

作者头像
vivi
发布2020-07-14 10:35:11
2160
发布2020-07-14 10:35:11
举报
文章被收录于专栏:vblogvblog

题目

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification: Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9​​ is the decimal number and 2≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification: For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​ ... a​0​​ ". Notice that there must be no extra space at the end of output.

Sample Input 1: 27 2 Sample Output 1: Yes 1 1 0 1 1 Sample Input 2: 121 5 Sample Output 2: No 4 4 1

题目大意

给定一个十进制数N和一个进制base,问n的base进制下的表示是不是一个回文数,如果是,输出“Yes”换行,输出它的base进制序列;如果不是,输出“No”,输出它的base进制。

  • 这个题没什么难度,能看懂题目的都知道这就是把N转成base进制,用数组存储就好了。
  • 至于判断回文,就是从左到中间,从右到中间扫描,判断数组是否“对称”就好了,注意扫描时左右指针的取值范围,不要漏掉某个位置元素,我就因为这个问题在测试点3卡了半天没想明白。
  • ==注意点1:== 最后一行的输出,最后一个数字后面不能有多余空格
  • ==注意点2:== 如果输入的N是0,它的base进制输出为 0,不能没有输出 所以我们在对N做进制转换时,采用 do {} while(),这样可以直接包含N=0的情况,就不用单独处理了。

完整代码

#include <iostream>
using namespace std;

int main() {

	// 回文数字
	int n, base;
	cin >> n >> base;

	// 把n转成base进制,再判断是不是对称位置都相等即可
	int arr[50] = {0};
	int i = 0;
	do {
		arr[i++] = n % base;
		n = n / base;
	} while (n > 0);

	// do while结束后,i停留在最后一个有效位的后一位置
	i -= 1;
	bool flag = true;
	// 判断是否 "对称",注意这里的 j <= i / 2
	for (int j = 0; j <= i / 2; ++j) {
		if (arr[j] != arr[i - j]) {
			flag = false;
            break;
		}
	}
	cout << (flag ? "Yes" : "No") << endl;

	// 输出base进制编码
	while (i >= 1)
		cout << arr[i--] << " ";

	cout << arr[0];
	return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2020-05-13 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 题目
  • 题目大意
  • 完整代码
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档