前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT 1006 Sign In and Sign Out (25分) 字符串比较

PAT 1006 Sign In and Sign Out (25分) 字符串比较

作者头像
vivi
发布2020-07-14 10:44:30
3170
发布2020-07-14 10:44:30
举报
文章被收录于专栏:vblogvblog

题目

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification: Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification: For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input: 3 CS301111 15:30:28 17:00:10 SC3021234 08:00:00 11:25:25 CS301133 21:45:00 21:58:40 Sample Output: SC3021234 CS301133

题目解析

早上来的最早的人要开门,晚上离开的最晚的人要锁门。 给出M个人的编号 到达时间 离开时间 输出 开门的那个人的编号 锁门的那个人的编号

这题真没啥意思,不就是一个排序或者说比大小

千万不要去创建结构体,真没必要,我们只需要编号,所以直接用两个变量保存负责开门的编号,负责关门的编号,在读入这些人信息的时候直接做比较,根据到达时间判断改变这个两个变量就可以了。

至于怎么保存“时间”以及比较,你可以把它转为以00:00:00开始的秒数,但我比较懒,直接用string类对象比较,> < 就可以搞定,只是比较字符串可能比比较整数速度慢,但是影响不大。

代码

代码语言:javascript
复制
#include <iostream>
#include <string>
using namespace std;

int main() {

    // m个员工
    int m;
    cin >> m;
    // 开锁的员工,上锁的员工
    string unlock_no, lock_no;
    // 初始化开锁时间,上锁时间
    string unlock_time = "23:59:59", lock_time = "00:00:00";
    // 当前员工编号,到达时间,离开时间
    string emp_no, sign_in_time, sign_out_time;
    for (int i = 0; i < m; ++i) {
        cin >> emp_no >> sign_in_time >> sign_out_time;
        // 最早来的那个人开锁,通过string类对象比较方法
        if (sign_in_time < unlock_time) {
            unlock_time = sign_in_time;
            unlock_no = emp_no;
        }
        // 最晚走的那个人锁门
        if (sign_out_time > lock_time) {
            lock_time = sign_out_time;
            lock_no = emp_no;
        }
    }
    // 开锁的 锁门的
    cout << unlock_no << " " << lock_no;
    return 0;
}

// 将时间转为秒进行比较
// int main() {
//     int n, minn = INT_MAX, maxn = INT_MIN;
//     scanf("%d", &n);
//     string unlocked, locked;
//     for(int i = 0; i < n; i++) {
//         string t;
//         cin >> t;
//         int h1, m1, s1, h2, m2, s2;
//         scanf("%d:%d:%d %d:%d:%d", &h1, &m1, &s1, &h2, &m2, &s2);
//         int tempIn = h1 * 3600 + m1 * 60 + s1;
//         int tempOut = h2 * 3600 + m2 * 60 + s2;
//         if (tempIn < minn) {
//             minn = tempIn;
//             unlocked = t;
//         }
//         if (tempOut > maxn) {
//             maxn = tempOut;
//             locked = t;
//         }
//     }
//     cout << unlocked << " " << locked;
//     return 0;
// }
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2020-05-18 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 题目
  • 题目解析
  • 代码
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档