前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT 1037 Magic Coupon (25分) 贪心+排序+负负/正正得正

PAT 1037 Magic Coupon (25分) 贪心+排序+负负/正正得正

作者头像
vivi
发布2020-07-14 10:49:21
4810
发布2020-07-14 10:49:21
举报
文章被收录于专栏:vblog

题目

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M7) to get M28 back; coupon 2 to product 2 to get M12 back; and coupon 4 to product 4 to get M3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification: Each input file contains one test case. For each case, the first line contains the number of coupons NC​​ , followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​ , followed by a line with N​P​​ product values. Here 1≤NC​​ ,N​P​​ ≤105​​ , and it is guaranteed that all the numbers will not exceed 230​​ .

Output Specification: For each test case, simply print in a line the maximum amount of money you can get back.

加粗样式Sample Input:

代码语言:javascript
复制
4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

代码语言:javascript
复制
43

题目解读

英语不行看懂题目是真的费劲,完全明白之后才发现这又是加减乘除。

先看题目:

  • 给出NC个优惠券,每个优惠券面额可正可负;给出NP个产品价格,也是可正可负
  • 一个优惠券只能用在一个产品上,不能重复使用
  • 面额为N的优惠券用在价格为P的产品上,能获得 N * P 的回扣;所以当N>0&&P>0 或者 N<0&&P<0时,得到的是N*P的回利,二者异号时,是N*P的付出。
  • 问:如何使用优惠券,才能获得最大的回扣?

分析:

  • 既然要回扣,所以肯定考虑正正负负
  • 既然要最大,肯定最小的负数优惠券用于最低的负数价格产品;最大的整数面额优惠券用于价格最高的正数价格产品。

思路:

  • 用两个数组分别存储NC个优惠券面额和NP个产品价格
  • 对两数组分别进行排序(从小到大
  • 左边开始处理卡券和商品均负整数的情况,从右边开始处理卡券和商品均正整数的情况,累加结果。

完整代码

代码语言:javascript
复制
#include <iostream>
#include <algorithm>
using namespace std;

int main() {
    // NC中优惠券
    int NC, NP;
    cin >> NC;
    int coupons[NC];
    // 每个优惠券的面额
    for (int i = 0; i < NC; ++i) cin >> coupons[i];
    // NP中产品
    cin >> NP;
    int products[NP];
    // 每个产品标价
    for (int i = 0; i < NP; ++i) cin >> products[i];
    // 优惠券从小到大排序
    sort(coupons, coupons + NC);
    // 产品从低到高排序
    sort(products, products + NP);
    int ans = 0,i = 0, j = 0;
    // 最小的负数优惠券,用于最小的负数价格产品,获得最大的正数回馈
    while (i < NC && j < NP && coupons[i] < 0 && products[j] < 0) {
        ans += coupons[i] * products[j];
        ++i;++j;
    }
    // 最大正数优惠券,用于最大的正数价格产品,获得最大的正数回馈
    i = NC - 1, j = NP - 1;
    while (i >= 0 && j >= 0 && coupons[i] > 0 && products[j] > 0) {
        ans += coupons[i] * products[j];
        --i;--j;
    }
    // 一正一负情况不考虑
    cout << ans;      
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2020-06-10 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 题目
  • 题目解读
  • 完整代码
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档