专栏首页程序生涯composer update 的时候提示the requested PHP extension pcntl is missing from your system.的方法处理

composer update 的时候提示the requested PHP extension pcntl is missing from your system.的方法处理

今天在composer require aliyuncs/oss-sdk-php的时候报了一个错误如下:

解决办法是在后面加上

--ignore-platform-reqs

整体命令行如下:

composer require aliyuncs/oss-sdk-php --ignore-platform-reqs

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • Laravel框架使用MongoDB遇到的问题解决

    之前说的,我一直是将macOS作为开发平台,直接在macOS系统配置Nginx PHP及MySQL,由于项目需求,需要使用到MongoDB,这篇就是一部在mac...

    OwenZhang
  • laravel安装intervention/image图像处理扩展 报错 intervention/image 2.3.7 requires ext-fileinfo…

    在安装intervention/image图像处理扩展 报错fileinfo is missing

    全栈程序员站长
  • CentOS7下安装php7.1以及composer遇到的问题汇总

    用户8851537
  • CentOS7下安装php7.1以及composer遇到的问题汇总

    子润先生
  • 教你一步步composer安装Magento2.2

      以前外贸建站一直用zencart,这段时间ytkah比较有时间,就决定用magento来创建一下站点。magento不像普通的程序一样下载就可以直接安装,需...

    ytkah
  • docker安装php7.2记录

    准备通过Dockerfile构建php镜像,在使用docker-php-ext-install安装mcrypt扩展时遇到如下错误:

    lestat
  • shell 安装 composer

    魔王卷子
  • Composer de涉水初探

    版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/u011415782/article/de...

    泥豆芽儿 MT
  • 安利一个github上面的一个神级库thefuck,Linux命令敲错了,没关系,自动纠正你的命令

    没错就是这么神奇,名字相当噶性,thefuck。当你命令输入错误不要怕,直接来一句fuck,自动纠正你输入的命令。

    landv
  • PHP扩展开发详解

    对于PHP扩展程序,在进行源码编译时有两种选择:1是将其编译到PHP应用程序中;2是以.so动态链接库的方式,单独编译。由于PHP通常对应的是前端开发,需求经常...

    asfan
  • 腾讯云PHP SDK之Windows PHP Composer

    http://www.downxia.com/downinfo/162121.html

    shawyang
  • 用Docker搭建Laravel开发环境

    在这篇文章中我们将通过Docker在个人本地电脑上构建一个快速、轻量级、不依赖本地电脑所安装的任何开发套件的可复制的Laravel和Vue项目的开发环境(开发环...

    KevinYan
  • PHP扩展模块一览及简要说明

    沈唁
  • SAP Commerce(SAP Hybris)学习资料汇总

    运行时动态更新配置:RuntimeConfigLoader,定期轮询properties文件是否有变化。

    Jerry Wang
  • laravel5.0+ 常见报错整理

    版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/u011415782/article/de...

    泥豆芽儿 MT
  • VsCode插件巡礼-phpcs

    我们希望规范项目开发中PHP代码的编码规范,锁定了php-code-sniffer这款插件,在安装执行过程中遇到的问题及理解分享如下

    needrunning
  • CentOS中基于不同版本安装重复包的解决方案

    在更新 PHP 版本的时候,出现了NOKEY的错误提示后,暂时没有解决掉这个问题,于是就手动安装了php-mbstring...rpm  包的高版本,这样在接...

    拓荒者
  • VS Code 扩展巡礼-phpcs

    本篇文章中介绍的扩展是 vscode-phpcs,用于项目开发中 PHP 代码的编码规范。

    needrunning
  • zabbix报错排错大全3 原

    https://www.cnblogs.com/losbyday/category/876878.html作者总结的很全棒

    拓荒者

扫码关注云+社区

领取腾讯云代金券