专栏首页黑白天安全团队OSPF 路由协议配置

OSPF 路由协议配置

OSPF 实验

OSPF的区域设计:

  • 每个区域都维护独立的LSDB
  • Area 0 是骨干区域,其他区域都必须与此区相连

规则一:当area id为0,则说明area 0 为骨干区域 规则二:非骨干区域必须围绕着骨干区域而搭建 规则三:骨干区域不能被分隔

角色说明:

ABR:区域边界路由器

  • 必须处于area 0 与其他区域的交接处
  • 必须与area 0中某台设备有full的邻接关系 ASBR:边界路由器
  • 如果存在引入外部路由器的行为,这台设备就被定义为ASBR 设备性能的排序:
  • 1.设备性能高 --- ABR/ASBR
  • 2.设备性能一般 --- 骨干区域
  • 3.设备性能差 – 非骨干区域

搭建拓扑图

划分区域

划分区域

实验要求

  • 内网使用OSPF协议;
  • 划分出一个骨干和两个非骨干区域;
  • 全网可达。

配置过程

配置IP地址与缺省

R1:

system-view
[Huawei]sysname R1
[R1]int gi 0/0/0
[R1-GigabitEthernet0/0/0]ip add 192.168.1.1 24
[R1-GigabitEthernet0/0/0]int gi 0/0/1
[R1-GigabitEthernet0/0/1]ip add 172.16.1.1 24
[R1-GigabitEthernet0/0/1]int gi 0/0/2
[R1-GigabitEthernet0/0/2]ip add 202.100.1.1 24
[R1-GigabitEthernet0/0/2]quit

R2:

system-view
[Huawei]sysname R2
[R2]int gi 0/0/0
[R2-GigabitEthernet0/0/0]ip add 172.16.2.1 24
[R2-GigabitEthernet0/0/0]int gi 0/0/1
[R2-GigabitEthernet0/0/1]ip add 192.168.1.2 24
[R2-GigabitEthernet0/0/1]int gi 0/0/2
[R2-GigabitEthernet0/0/2]ip add 10.1.1.1 24
[R2-GigabitEthernet0/0/2]quit
[R2]ip route-static 0.0.0.0 0 192.168.1.1

R3:

system-view
[Huawei]sysname R3
[R3]int gi 0/0/0
[R3-GigabitEthernet0/0/0]ip add 10.1.1.2 24
[R3-GigabitEthernet0/0/0]int gi 0/0/1
[R3-GigabitEthernet0/0/1]ip add 172.16.3.1 24
[R3-GigabitEthernet0/0/1] int se 1/0/0
[R3-Serial1/0/0]ip add 192.168.2.1 24
[R3-Serial1/0/0]quit
[R3]ip route-static 0.0.0.0 0 10.1.1.1

R4:

system-view
[Huawei]sysname R4
[R4]int gi 0/0/0
[R4-GigabitEthernet0/0/0]ip add 10.1.1.3 24
[R4-GigabitEthernet0/0/0]int gi 0/0/1
[R4-GigabitEthernet0/0/1]ip add 172.16.4.1 24
[R4-GigabitEthernet0/0/1]int se 1/0/0
[R4-Serial1/0/0]ip add 192.168.2.2 24
[R4-Serial1/0/0]int se 1/0/1
[R4-Serial1/0/1]ip add 192.168.3.1 24
[R4-Serial1/0/1]quit
[R4]ip route-static 0.0.0.0 0 10.1.1.1

R5:

system-view
[Huawei]sysname R5
[R5]int gi 0/0/0
[R5-GigabitEthernet0/0/0]ip add 10.1.1.4 24
[R5-GigabitEthernet0/0/0]int gi 0/0/1
[R5-GigabitEthernet0/0/1]ip add 172.16.5.1 24
[R5-GigabitEthernet0/0/1]int se 1/0/1
[R5-Serial1/0/1]ip add 192.168.3.2 24
[R5-Serial1/0/1]quit
[R5]ip route-static 0.0.0.0 0 10.1.1.1

配置OSPF协议

R1:

[R1]ospf 1 router-id 1.1.1.1
[R1-ospf-1]area 1
[R1-ospf-1-area-0.0.0.1]net
[R1-ospf-1-area-0.0.0.1]network 172.16.1.0 0.0.0.255
[R1-ospf-1-area-0.0.0.1]network 192.168.1.0 0.0.0.255
[R1-ospf-1-area-0.0.0.1]quit
[R1-ospf-1]bandwidth-reference 10000 //修改参考带宽
[R1-ospf-1]default-route-advertise always //强制下发缺省
[R1-ospf-1]silent-interface gi 0/0/1 //修改接口为静默接口
[R1-ospf-1]quit
[R1]quit
save

R2:

[R2]ospf 1 router-id 2.2.2.2
[R2-ospf-1]a 1
[R2-ospf-1-area-0.0.0.1]net 172.16.2.0 0.0.0.255
[R2-ospf-1-area-0.0.0.1]net 192.168.1.0 0.0.0.255
[R2-ospf-1-area-0.0.0.1] a 0
[R2-ospf-1-area-0.0.0.0]net 10.1.1.0 0.0.0.255
[R2-ospf-1-area-0.0.0.0]quit
[R2-ospf-1]bandwidth-reference 10000
[R2-ospf-1]default-route-advertise always
[R2-ospf-1]silent-interface gi 0/0/0
[R2-ospf-1]quit
[R2]quit
save

R3:

[R3]ospf 1 router-id 3.3.3.3
[R3-ospf-1]a 0
[R3-ospf-1-area-0.0.0.0]net 10.1.1.0 0.0.0.255
[R3-ospf-1-area-0.0.0.0]a 2
[R3-ospf-1-area-0.0.0.2]net 172.16.3.0 0.0.0.255
[R3-ospf-1-area-0.0.0.2]net 192.168.2.0 0.0.0.255
[R3-ospf-1-area-0.0.0.2]quit
[R3-ospf-1]bandwidth-reference 10000
[R3-ospf-1]default-route-advertise always
[R3-ospf-1]silent-interface gi 0/0/1
[R3-ospf-1]quit
[R3]quit
save

R4:

[R4]ospf 1 router-id 4.4.4.4
[R4-ospf-1]a 0
[R4-ospf-1-area-0.0.0.0]net 10.1.1.0 0.0.0.255
[R4-ospf-1-area-0.0.0.0]a 2
[R4-ospf-1-area-0.0.0.2]net 192.168.2.0 0.0.0.255
[R4-ospf-1-area-0.0.0.2]net 192.168.3.0 0.0.0.255
[R4-ospf-1-area-0.0.0.2]net 172.16.4.0 0.0.0.255
[R4-ospf-1-area-0.0.0.2]quit
[R4-ospf-1]bandwidth-reference 10000
[R4-ospf-1]default-route-advertise always
[R4-ospf-1]silent-interface gi 0/0/1
[R4-ospf-1]quit
[R4]quit
save

R5:

[R5]ospf 1 router-id 5.5.5.5
[R5-ospf-1]a 0
[R5-ospf-1-area-0.0.0.0]net 10.1.1.0 0.0.0.255
[R5-ospf-1-area-0.0.0.0]a 2
[R5-ospf-1-area-0.0.0.2]net 192.168.3.0 0.0.0.255
[R5-ospf-1-area-0.0.0.2]net 172.16.5.0 0.0.0.255
[R5-ospf-1-area-0.0.0.2]quit
[R5-ospf-1]bandwidth-reference 10000
[R5-ospf-1]default-route-advertise always
[R5-ospf-1]silent-interface gi 0/0/1
[R5-ospf-1]quit
[R5]quit
save

手动配置PC端的IP地址 此时全网可达

查看查看邻居关系摘要

本文分享自微信公众号 - 黑白天(HBT-SEC),作者:jen

原文出处及转载信息见文内详细说明,如有侵权,请联系 yunjia_community@tencent.com 删除。

原始发表时间:2020-08-25

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • DC-1

    开放了22的ssh 80的http apache 111的 rpcbind等等。 重点看看到在80端口上运行着Drupal 7和一些敏感的目录文件等等。

    cn0sec
  • windows之NTLM认证

    比如当用户输入密码admin的时候,操作系统会将admin转换为16进制,经过Unicode转换后,再调用MD4加密算法加密,这个加密结果的十六进制就是NTLM...

    cn0sec
  • 渗透思路:从JS文件入手

    近期做渗透项目时,很多目标资产都是只有一个登录框,且没用常见的指纹。防护也做的非常好,像是态势感知、天字号等设备都不止一套,所以什么sql注入、XSS之类的漏洞...

    cn0sec
  • 目标检测--SqueezeDet 用于自动驾驶的实时目标检测网络

    版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.n...

    用户1148525
  • SeleniumWebDriver之FindElement和FindElements

    与Web页面的交互需要用户定位Web元素。FindElement命令用于唯一地标识页面中的(单个)Web元素。然而,FindElements命令用于唯一地标识页...

    软测小生
  • Django——基础创建

    manage.py是项目管理文件,通过它管理项目。 init.py是一个空文件,作用是这个目录demo1可以被当作包使用。 settings.py是项目的整...

    羊羽shine
  • 高效SQL语句必杀技

            No SQL,No cost. SQL语句是造成数据库开销最大的部分。而不良SQL写法直接导致数据库系统性能下降的情形比比皆是。那么如何才能称得...

    Leshami
  • 什么是SNP遗传力?

    heritability,翻译为遗传力, 用来描述表型变异中遗传变异的比例。众所周知,表型(P)由基因型(G)和环境因素(E)共同控制, 即

    生信修炼手册
  • 使用jasypt加密Spring Boot应用中的敏感配置

    本文讲述了在Spring Boot/Spring Cloud应用中使用jasypt来加密properties。

    码代码的陈同学
  • KEGG Enzyme 数据库

    生物体内的大多数反应都需要酶的参与,酶在生命活动中发挥了重要作用。IUBMB/UPAC 国际标准化命名委员会对已经发现的酶都提供了标准化的的命名方式,叫做EC ...

    生信修炼手册

扫码关注云+社区

领取腾讯云代金券