前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >杭电 1789(贪心思维练习)

杭电 1789(贪心思维练习)

作者头像
杨鹏伟
发布2020-09-11 15:05:43
3640
发布2020-09-11 15:05:43
举报
文章被收录于专栏:ypwypw

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework… Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

Output For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input 3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4

Sample Output 0 3 5

题意: 就是每个作业有不同得分值跟截至日期,到了时间没按时完成作业老师会扣分,然后如何写作业使得扣分最少。每天只能完成一项作业。

思路:我们是想在规定得时间拿到尽可能多得分数,好贪婪啊,那不就是贪心嘛! 那么我们可以这样对数组进行排序,分数大的,截至时间短得优先考虑,如果分数一样,则按照时间短的优先,否则按照分数从大到小排序。

代码语言:javascript
复制
#include<bits/stdc++.h>

using namespace std;
int vis[1000005];
int flag;
struct node{
	int day;
	int score;
}a[1005];

 
int cmpp(node a,node b){
	if(a.score == b.score) return a.day < b.day;
	return a.score > b.score;
} 

int main(){
	int t;
	cin>>t;
	int j;
	while(t--){
		memset(vis,0,sizeof(vis));
		int n;
		cin>>n;
		for(int i=0;i<n;i++){
			cin>>a[i].day;
		}
		for(int i=0;i<n;i++){
			cin>>a[i].score;
		}
		sort(a,a+n,cmpp);
		
		flag = 0;
		
		for(int i=0;i<n;i++){
	       j = a[i].day;
	       while(1){
	       	if(vis[j] == 0){
	       		vis[j] = 1;
	       		break;
			   }
			else{
				j--;
			}
			if(j == 0){
				flag += a[i].score;
				break;
			}
		   }
		   } 
		cout<<flag<<endl;
	}
	return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2020-02-08 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档