前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ1611 (并查集)

POJ1611 (并查集)

作者头像
dejavu1zz
发布2020-10-23 15:12:32
3600
发布2020-10-23 15:12:32
举报

题意描述

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). Once a member in a group is a suspect, all members in the group are suspects. However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output For each case, output the number of suspects in one line.

Sample Input 100 4 2 1 2 5 10 13 11 12 14 2 0 1 2 99 2 200 2 1 5 5 1 2 3 4 5 1 0 0 0

Sample Output 4 1 1

思路

一道并查集的题目。这道题目中需要维护的信息是与0号病人在一个集合中的人数,简单来说,就是维护每个结点的子结点个数。需要注意的是,如果两个结点的父结点已经相同的话,就不用将他们合并,所以要对这种情况做一个特判。

AC代码

代码语言:javascript
复制
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int N=30010;
int p[N],si[N],buf[N];
int find(int x){
	if(p[x]!=x) p[x]=find(p[x]);
	return p[x];
}
int main(){
	int n,m;
	while(cin>>n>>m&&n||m){
		memset(si,0,sizeof si);
		memset(p,0,sizeof p);
		for(int i=0;i<n;i++){
			p[i]=i;
			si[i]=1;
		}
		while(m--){
			int k;
			cin>>k;
			int x;
			cin>>x;
			int t=x;
			for(int i=0;i<k-1;i++){
				cin>>x;
				if(find(t)==find(x)) continue;
				si[find(t)]+=si[find(x)];
				p[find(x)]=find(t);
			}
		}
		cout<<si[find(0)]<<endl;
	}
	return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2020-03-03 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 题意描述
  • 思路
  • AC代码
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档