前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDOJ-1711(kmp算法)

HDOJ-1711(kmp算法)

作者头像
dejavu1zz
发布2020-10-23 15:16:36
4080
发布2020-10-23 15:16:36
举报
文章被收录于专栏:奇妙的算法世界

题意描述

Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input: The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].

Output For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input 2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1

Sample Output 6 -1

思路

不难看出这是一道kmp板子题,直接套模板即可。对于无法匹配的情况,我们可以使用一个标记来记录,需要注意的一点是,输入的值可能会有负数,所以我们要使用int数组来存储a和b两个序列

AC代码

代码语言:javascript
复制
#include<iostream>
#include<algorithm>
#include<cstring>
#define IOS ios::sync_with_stdio(false)
using namespace std;
const int maxn=1e6+10;
const int maxm=10010;
int w[maxm],t[maxn];
int ne[maxm];
int n;
int main(){
    IOS;cin.tie(0);
    cin>>n;
    while(n--){
        int x,y;
        bool flag=true;
        cin>>x>>y;
        for(int i=1;i<=x;i++) cin>>t[i];
        for(int i=1;i<=y;i++) cin>>w[i];
        for(int i=2,j=0;i<=y;i++){
            while(j&&w[i]!=w[j+1]) j=ne[j];
            if(w[i]==w[j+1]) j++;
            ne[i]=j;
        }
        for(int i=1,j=0;i<=x;i++){
            while(j&&t[i]!=w[j+1]) j=ne[j];
            if(t[i]==w[j+1]) j++;
            if(j==y){
                flag=false;
                cout<<i-y+1<<endl;
                break;
            }
        }
        if(flag) cout<<"-1"<<endl;
    }

}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2020/02/25 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 题意描述
  • 思路
  • AC代码
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档