前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ3279 (二进制枚举)

POJ3279 (二进制枚举)

作者头像
dejavu1zz
发布2020-10-23 15:18:09
5390
发布2020-10-23 15:18:09
举报
文章被收录于专栏:奇妙的算法世界

题意描述

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input Line 1: Two space-separated integers: M and N Lines 2… M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output Lines 1… M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input 4 4 1 0 0 1 0 1 1 0 0 1 1 0 1 0 0 1

Sample Output 0 0 0 0 1 0 0 1 1 0 0 1 0 0 0 0

思路

我们只需要枚举出第一行的状态,然后根据第一行的状态来递推出其余每一行的状态,在递推完以后,还需要判断最后一行灯是否满足题意。我们可以不在原数组中改变状态,而是根据该位置的状态是否改变过,从而绝对是否对该位置进行操作,这样可以大大的节省时间。方法1是在原数组中改变,方法2是根据位置的状态来决定是否操作。

AC代码

方法1:使用G++编译器可以勉强通过

代码语言:javascript
复制
#include<iostream>
#include<algorithm>
#include<vector>
#include<ctime>
#include<cstring>
#define IOS ios::sync_with_stdio(false); cin.tie(0); 
using namespace std;
typedef pair<int,int> PII;
const int N=20;
const int INF=0x3f3f3f3f;
int n,m;
int g[N][N],backup[N][N];
int ans[N][N];
int dx[5]={1,0,-1,0,0},dy[5]={0,1,0,-1,0};
void turn(int x,int y){
	for(int i=0;i<5;i++){
		int gx=x+dx[i],gy=y+dy[i];
		if(gx>=0&&gy>=0&&gx<n&&gy<m){
			g[gx][gy]^=1;
		}
	}
}
int main(){
	IOS;
	cin>>n>>m;
	for(int i=0;i<n;i++){
		for(int j=0;j<m;j++){
			cin>>g[i][j];
		}
	}
	//clock_t starttime,endtime;	
	//starttime=clock();
	int ccc=INF;
	for(int op=0;op<1<<m;op++){
		int cnt=0;
		memcpy(backup,g,sizeof g);
		vector<PII> res;
		PII buf;
		for(int i=0;i<m;i++){
			if(op>>i&1){
				turn(0,i);
				cnt++;
				buf.first=0,buf.second=i;
				res.push_back(buf);
			}
		}
		for(int i=1;i<n;i++){
			for(int j=0;j<m;j++){
				if(g[i-1][j]==1){
					turn(i,j);
					buf.first=i,buf.second=j;
					res.push_back(buf);
					cnt++;
				}
			}
		}
		bool is_closed=true;
		for(int i=0;i<m;i++){
			if(g[n-1][i]==1){
				is_closed=false;
				break;
			}
		}
		if(is_closed){
			if(cnt<ccc){
				ccc=cnt;
				memset(ans,0,sizeof ans);
				for(int i=0;i<res.size();i++){
					int gx=res[i].first,gy=res[i].second;
					ans[gx][gy]++;
				}
			}
		}
		memcpy(g,backup,sizeof backup);
	}
	if(ccc==INF){
		cout<<"IMPOSSIBLE"<<endl;
	}else{
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				cout<<ans[i][j]<<' ';
			}
			cout<<endl;
		}
	}
	//endtime=clock();
	//cout<<(double)(endtime - starttime) / CLOCKS_PER_SEC<<"s"<<endl;
	return 0;
}

方法2:

代码语言:javascript
复制
#include<iostream>
#include<algorithm>
#include<vector>
#include<ctime>
#include<cstring>
#define IOS ios::sync_with_stdio(false); cin.tie(0); 
using namespace std;
typedef pair<int,int> PII;
const int N=20;
const int INF=0x3f3f3f3f;
int n,m;
int g[N][N];
int ans[N][N];
int choose[N][N];
int dx[5]={1,0,-1,0,0},dy[5]={0,1,0,-1,0};
int get(int x,int y){
	int temp=g[x][y];
	for(int i=0;i<5;i++){
		int gx=x+dx[i],gy=y+dy[i];
		if(gx>=0&&gy>=0&&gx<n&&gy<m){
			temp+=choose[gx][gy];
		}
	}
	return temp&1;
}
int main(){
	IOS;
	cin>>n>>m;
	for(int i=0;i<n;i++){
		for(int j=0;j<m;j++){
			cin>>g[i][j];
		}
	}
	//clock_t starttime,endtime;	
	//starttime=clock();
	int ccc=INF;
	for(int op=0;op<1<<m;op++){
		int cnt=0;
		memset(choose,0,sizeof choose);
		for(int i=0;i<m;i++){
			choose[0][m-i-1]=op>>i&1;
		}
		for(int i=1;i<n;i++){
			for(int j=0;j<m;j++){
				if(get(i-1,j)){
					choose[i][j]=1;
				}
			}
		}
		bool is_closed=true;
		for(int i=0;i<m;i++){
			if(get(n-1,i)){
				 is_closed=false;
				 break;
			}
		}
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				cnt+=choose[i][j];
			}
		}
		if(is_closed){
			if(cnt<ccc){
				ccc=cnt;
				memcpy(ans,choose,sizeof choose);
			}
		}
	}
	if(ccc==INF){
		cout<<"IMPOSSIBLE"<<endl;
	}else{
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				cout<<ans[i][j]<<' ';
			}
			cout<<endl;
		}
	}
	return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2020/03/19 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 题意描述
  • 思路
  • AC代码
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档