前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ - 2387 Til the Cows Come Home (最短路入门)

POJ - 2387 Til the Cows Come Home (最短路入门)

作者头像
风骨散人Chiam
发布2020-10-28 09:33:37
4250
发布2020-10-28 09:33:37
举报
文章被收录于专栏:CSDN旧文

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.  Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.  Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N  * Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

代码语言:javascript
复制
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

代码语言:javascript
复制
90

Hint

INPUT DETAILS:  There are five landmarks.  OUTPUT DETAILS:  Bessie can get home by following trails 4, 3, 2, and 1.

很简单dijkstra就可以过,入门级的题目,这个题建议不要抄模板,直接自己敲,就是用来练习最短路的,模板始终不是自己的。

代码语言:javascript
复制
#include<iostream>
#include<queue>
#include<algorithm>
#include<set>
#include<cmath>
#include<vector>
#include<map>
#include<stack>
#include<bitset>
#include<cstdio>
#include<cstring>
#define Swap(a,b) a^=b^=a^=b
#define cini(n) scanf("%d",&n)
#define cinl(n) scanf("%lld",&n)
#define cinc(n) scanf("%c",&n)
#define cins(s) scanf("%s",s)
#define coui(n) printf("%d",n)
#define couc(n) printf("%c",n)
#define coul(n) printf("%lld",n)
#define speed ios_base::sync_with_stdio(0)
#define Max(a,b) a>b?a:b
#define Min(a,b) a<b?a:b
#define mem(n,x) memset(n,x,sizeof(n))
using namespace std;
typedef long long ll;
const int INF=0x3f3f3f3f;
const int maxn=1e3+10;
const double esp=1e-9;
//-------------------------------------------------------//

int n,m; //n个节点,m条边
int dis[maxn][maxn];
bool vis[maxn];
int d[maxn];
inline void dijstra();
int main()
{
    mem(dis,0x3f);
    mem(vis,0);
    mem(d,0x3f);
    for(int i=1; i<=n; i++)dis[i][i]=0;
    cini(m),cini(n);//输入边数//点数
    for(int i=0; i<m; i++)
    {
        int x,y,z;
        cini(x),cini(y),cini(z);
        dis[x][y]=min(dis[x][y],z);
        dis[y][x]=min(dis[y][x],z);
        //cout<<dis[x][y]<<endl;
    }
    dijstra();
    cout<<d[n]<<endl;
}
inline void dijstra()
{
    d[1]=0;
    for(int i=1; i<=n; i++)
    {
        int x=0;
        for(int j=1; j<=n; j++)
            if(!vis[j]&&(d[j]<d[x]||x==0))x=j;

        vis[x]=1;
        for(int j=1;j<=n;j++)
            d[j]=min(d[j],d[x]+dis[x][j]);

    }
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2019/08/12 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档