前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ - 3278 Catch That Cow 简单搜索

POJ - 3278 Catch That Cow 简单搜索

作者头像
风骨散人Chiam
发布2020-10-28 09:34:39
3220
发布2020-10-28 09:34:39
举报
文章被收录于专栏:CSDN旧文

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

代码语言:javascript
复制
5 17

Sample Output

代码语言:javascript
复制
4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

这道题是关于最短步数的,首先就要想到广搜,既然想到了广搜就可以写代码了。

代码语言:javascript
复制
#include<iostream>
#include<queue>
#include<algorithm>
#include<set>
#include<cmath>
#include<vector>
#include<map>
#include<stack>
#include<bitset>
#define Swap(a,b) a^=b^=a^=b
#define cini(n) scanf("%d",&n)
#define cinl(n) scanf("%lld",&n)
#define cinc(n) scanf("%c",&n)
#define coui(n) printf("%d",n)
#define couc(n) printf("%c",n)
#define coul(n) printf("%lld",n)
#define speed ios_base::sync_with_stdio(0);//Çв»¿ÉÓÃscnaf£»
#define Max(a,b) a>b?a:b
#define Min(a,b) a<b?a:b
using namespace std;
typedef long long ll;
const int INF=0x3f3f3f3f;
const int maxn=1e6+10;
const double esp=1e-9;
int m,n,x,y;
int cnt,mini=INF;
bool flag[maxn];
int bfs(int x);
int main()
{
    cin>>m>>n;
    cout<<bfs(m)<<endl;
}
int bfs(int x)
{
    queue<pair<int,int> > t;
    t.push(make_pair(x,0));
    while(!t.empty())
    {
        pair<int,int>w=t.front();
        if(w.first==n)break;
        t.pop();
        w.first++,w.second++;
        if(w.first<0||w.first>100000||flag[w.first]);
        else t.push(w),flag[w.first]=1;
        w.first-=2;
        if(w.first<0||w.first>100000||flag[w.first]);
        else t.push(w),flag[w.first]=1;
        w.first++;
        w.first*=2;
        if(w.first<0||w.first>100000||flag[w.first]);
        else t.push(w),flag[w.first]=1;
    }
    return t.front().second;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2019/08/07 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档