前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ 3616 Milking Time

POJ 3616 Milking Time

作者头像
风骨散人Chiam
发布2020-10-28 10:11:37
3340
发布2020-10-28 10:11:37
举报
文章被收录于专栏:CSDN旧文

Milking Time

Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 15650 Accepted: 6644 Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0…N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours. Input

  • Line 1: Three space-separated integers: N, M, and R
  • Lines 2…M+1: Line i+1 describes FJ’s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

  • Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2 1 2 8 10 12 19 3 6 24 7 10 31 Sample Output

43 题目比较简单直接上代码:

代码语言:javascript
复制
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
struct obj{
long long int st,en,val;
} ob[1050];
long long int dp[1050];
bool cmp(obj a,obj b)
{
    if(a.st==b.st) return a.en<b.en;
    return a.st<b.st;
}
int main()
{
    long long int cap,lis,re,tem1,tem2,ans;
    while(cin>>cap>>lis>>re){
            ans=0;
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=lis;i++) scanf("%d%d%d",&ob[i].st,&ob[i].en,&ob[i].val);
        sort(ob+1,ob+lis+1,cmp);
        for(int i=1;i<=lis;i++){
                tem1=tem2=0;
            dp[i]=ob[i].val;
            for(int t=i;t>=1;t--){
                if(ob[i].st>=ob[t].en+re)
                    dp[i]=max(dp[i],dp[t]+ob[i].val);
            ans=max(ans,dp[i]);
            }
        }
        // for(int i=1;i<=lis;i++) cout<<dp[i]<<' ';
        printf("%ld\n",ans);
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2019/04/16 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档