前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU Problem D [ Humble number ]——基础DP丑数序列

HDU Problem D [ Humble number ]——基础DP丑数序列

作者头像
风骨散人Chiam
发布2020-10-28 10:18:57
2910
发布2020-10-28 10:18:57
举报
文章被收录于专栏:CSDN旧文

Problem D Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 7 Accepted Submission(s) : 3 Problem Description A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers. Write a program to find and print the nth element in this sequence

Input The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output For each test case, print one line saying “The nth humble number is number.”. Depending on the value of n, the correct suffix “st”, “nd”, “rd”, or “th” for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input 1 2 3 4 11 12 13 21 22 23 100 1000 5842 0

Sample Output The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.

代码语言:javascript
复制
#include<iostream>
#include<queue>
#include<set>
#include<cstdio>
using namespace std;
set<long long int>a;
vector<long long int>c;
void js()
{
    a.insert(1);
    a.insert(2);
    a.insert(3);
    a.insert(4);
    a.insert(5);
    a.insert(6);
    a.insert(7);
    set<long long int>::iterator poi;
    for(poi=a.begin();;poi++)
    {
        a.insert(2**poi);
        a.insert(3**poi);
        a.insert(5**poi);
        a.insert(7**poi);
        if(a.size()>6800)break;
    }
    for(poi=a.begin();poi!=a.end();poi++)
    {
        c.push_back(*poi);
    }
}
string fuhao(int a)
{
    if(a%100==11) return "th";
    else if(a%100==12) return "th";
    else if(a%100==13) return "th";
    else if(a%10==1) return "st";
    else if(a%10==2) return "nd";
    else if(a%10==3) return "rd";
    else return "th";
}
int main()
{
    js();
    int  N;
    while(scanf("%d",&N)&&N)
    cout<<"The "<<N<<fuhao(N)<<" humble number is "<<c[N-1]<<'.'<<endl;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2019/03/25 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档