前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ 3273 Monthly Expense

POJ 3273 Monthly Expense

作者头像
风骨散人Chiam
发布2020-10-28 10:34:10
2490
发布2020-10-28 10:34:10
举报
文章被收录于专栏:CSDN旧文

Monthly Expense Time Limit: 2000MS Memory Limit: 65536K Total Submissions: 38688 Accepted: 14256

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M Lines 2…N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with. Sample Input

7 5 100 400 300 100 500 101 400 Sample Output

500 Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit. Source

USACO 2007 March Silver

二分,需要动动脑子,写法不唯一,二分不能学太死。

代码语言:javascript
复制
#include <cstdio>
#include <iostream>
using namespace std;
typedef long long LL;
const int inf=0x3f3f3f3f;
const double eps=1e-8;
const double pi= acos(-1.0);
const int maxn=100010;
int n,m;
int a[maxn];
int judge(int value)
{
    int i;
    int sum=0,cnt=1;
    for(i=0;i<n;i++){
        if(sum+a[i]<=value)
            sum=sum+a[i];
        else{
            sum=a[i];
            cnt++;
        }
    }
    if(cnt>m)
        return 0;
    else
        return 1; 
}
 
int main()
{
    int high,low,mid;
    while(~scanf("%d %d",&n,&m)){
            low=high=0;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            low=max(low,a[i]);
            high+=a[i];
        }
        while(low<=high){
            mid=(low+high)>>1;
            if(judge(mid))
                high=mid-1;
            else
                low=mid+1;
        }
        printf("%d",mid);
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2019/05/18 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档