前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU 2199 Can you solve this equation?

HDU 2199 Can you solve this equation?

作者头像
风骨散人Chiam
发布2020-10-28 10:34:32
3420
发布2020-10-28 10:34:32
举报
文章被收录于专栏:CSDN旧文

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 29378 Accepted Submission(s): 12331

Problem Description

Now,given the equation 8x^4 + 7x^3 + 2x^2 + 3x + 6 == Y,can you find its solution between 0 and 100; Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2 100 -4

Sample Output

1.6152 No solution!

Author

Redow

Recommend

lcy

二分水题,多看看就能理解。

代码语言:javascript
复制
#include<iostream>
#include<algorithm>
#include<vector> 
#include<cmath>
#include<iomanip>
using namespace std;
double ys(double e)
{
    return 8*pow(e,4)+7*pow(e,3)+2*pow(e,2)+3*e+6;
}
int judge(double u)
{
	double v;
	v=8*pow(100,4)+7*pow(100,3)+2*pow(100,2)+3*100+6;
	if(v>=u&&u>=6)
	return true;
	return false;
}
int main()
{
	int T;
	double n,left,right,node;
	cin>>T;
	while(T--)
	{
		cin>>n;
		if(!judge(n))
		cout<<"No solution!"<<endl;
		else
		{
			left=0;right=100;
			while(right-left>0.000001)
			{
				node=(left+right)/2;
				if(ys(node)>n)
				right=node;
				else
				left=node;
			}
			cout<<fixed<<setprecision(4)<<node<<endl;
		}
	}
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2019/05/18 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档