前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >图论--差分约束--POJ 1201 Intervals

图论--差分约束--POJ 1201 Intervals

作者头像
风骨散人Chiam
发布2020-10-28 11:46:52
3440
发布2020-10-28 11:46:52
举报
文章被收录于专栏:CSDN旧文CSDN旧文

Intervals Time Limit: 2000MS Memory Limit: 65536K Total Submissions: 30971 Accepted: 11990 Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn. Write a program that: reads the number of intervals, their end points and integers c1, ..., cn from the standard input, computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n, writes the answer to the standard output.

Input The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

Sample Input 5 3 7 3 8 10 3 6 8 1 1 3 1 10 11 1

Sample Output 6

这个题我看了很久都不懂得怎么建图。先粘个代码吧!

代码语言:javascript
复制
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define inf 99999
#define maxx 50005
struct edge
{
    int u,v,w;
}edge[maxx];
int n;
int dist[maxx];
int l;//左端点的最小值
int r;//右端点的最大值
 
void bellman_ford()
{
    int flag=1,t;
    while(flag)
    {
        flag=0;
        for(int i=1;i<=n;i++)
        {
            t=dist[edge[i].u]+edge[i].w;
            if(dist[edge[i].v]>t)
            {
                dist[edge[i].v]=t;
                flag=1;
            }
        }
        for(int i=r;i>l;i--)
        {
            t=dist[i-1]+1;
            if(dist[i]>t)
            {
                dist[i]=t;flag=1;
            }
        }
        for(int i=r;i>l;i--)
        {
            t=dist[i];
            if(dist[i-1]>t)
            {
                dist[i-1]=t;
                flag=1;
            }
        }
    }
}
 
int main()
{
    scanf("%d",&n);
    r=1,l=inf;
    int a,b,c;
    for(int i=1;i<=n;i++)
    {
        scanf("%d%d%d",&a,&b,&c);
        edge[i].u=b,edge[i].v=a-1,edge[i].w=-c;
        if(a<l)  l=a;
        if(b>r)    r=b;
        dist[i]=0;
    }
    bellman_ford();
    printf("%d\n",dist[r]-dist[l-1]);
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2019-11-18 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档